Move mount.cifs back to /sbin

It's unnecessary. The symlinks take care of it since there is no
conflicting filename in /usr/sbin. Also, not moving it is better for
now since that will allow someone to install this package on earlier
fedora versions.

Signed-off-by: Jeff Layton <jlayton@redhat.com>
This commit is contained in:
Jeff Layton 2012-02-08 13:31:22 -05:00
parent 7572d35116
commit 7f4676b38a
2 changed files with 6 additions and 64 deletions

View File

@ -1,59 +0,0 @@
From d95afa999a612badd06a5e62cb78fb2c889ac743 Mon Sep 17 00:00:00 2001
From: Jeff Layton <jlayton@samba.org>
Date: Wed, 8 Feb 2012 11:56:19 -0500
Subject: [PATCH] cifs-utils: allow specifying rootsbindir at configure time
...via the $ROOTSBINDIR environment variable, and AC_ARG_VAR macro.
The default is to use /sbin for this value, which only currently
affects the installation location of mount.cifs.
Signed-off-by: Jeff Layton <jlayton@samba.org>
---
Makefile.am | 2 +-
configure.ac | 10 +++++++++-
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 6182965..924c99e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
AM_CFLAGS = -Wall -Wextra
ACLOCAL_AMFLAGS = -I aclocal
-root_sbindir = "/sbin"
+root_sbindir = $(ROOTSBINDIR)
root_sbin_PROGRAMS = mount.cifs
mount_cifs_SOURCES = mount.cifs.c mtab.c resolve_host.c util.c
mount_cifs_LDADD = $(LIBCAP) $(CAPNG_LDADD)
diff --git a/configure.ac b/configure.ac
index 4c715ab..02b1ef2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ AC_CONFIG_MACRO_DIR(aclocal)
AM_INIT_AUTOMAKE
-# "with" options
+# "enable" options
AC_ARG_ENABLE(cifsupcall,
[AC_HELP_STRING([--enable-cifsupcall],
[Create cifs.upcall binary @<:@default=yes@:>@])],
@@ -34,6 +34,14 @@ AC_ARG_ENABLE(cifsacl,
enable_cifsacl=$enableval,
enable_cifsacl="maybe")
+# check for ROOTSBINDIR environment var
+if test -z $ROOTSBINDIR; then
+ ROOTSBINDIR="/sbin"
+ export ROOTSBINDIR
+fi
+
+AC_ARG_VAR(ROOTSBINDIR, [Location where files ordinarily under /sbin should be installed. Note: unaffected by --prefix. @<:@default=/sbin@:>@])
+
# Checks for programs.
AC_PROG_CC
AC_PROG_SED
--
1.7.7.6

View File

@ -3,7 +3,7 @@
Name: cifs-utils
Version: 5.3
Release: 2%{pre_release}%{?dist}
Release: 3%{pre_release}%{?dist}
Summary: Utilities for mounting and managing CIFS mounts
Group: System Environment/Daemons
@ -12,7 +12,6 @@ URL: http://linux-cifs.samba.org/cifs-utils/
BuildRoot: %{_tmppath}/%{name}-%{version}%{pre_release}-%{release}-root-%(%{__id_u} -n)
Source0: ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/%{name}-%{version}%{pre_release}.tar.bz2
Patch0: 0001-cifs-utils-allow-specifying-rootsbindir-at-configure.patch
BuildRequires: libcap-ng-devel libtalloc-devel krb5-devel keyutils-libs-devel autoconf automake samba-winbind-devel
Requires: keyutils
@ -27,10 +26,9 @@ file system.
%prep
%setup -q -n %{name}-%{version}%{pre_release}
%patch0 -p1
%build
%configure --prefix=/usr ROOTSBINDIR=%{_sbindir}
%configure --prefix=/usr
make %{?_smp_mflags}
%install
@ -46,10 +44,10 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc
/sbin/mount.cifs
%{_bindir}/getcifsacl
%{_bindir}/setcifsacl
%{_bindir}/cifscreds
%{_sbindir}/mount.cifs
%{_sbindir}/cifs.upcall
%{_sbindir}/cifs.idmap
%{_mandir}/man1/getcifsacl.1.gz
@ -62,6 +60,9 @@ rm -rf %{buildroot}
%config(noreplace) %{_sysconfdir}/request-key.d/cifs.spnego.conf
%changelog
* Wed Feb 08 2012 Jeff Layton <jlayton@redhat.com> 5.3-3
- revert mount.cifs move. It's unnecessary at this point.
* Wed Feb 08 2012 Jeff Layton <jlayton@redhat.com> 5.3-2
- move mount.cifs to /usr/sbin per new packaging guidelines