Move mount.cifs to /usr/sbin
Signed-off-by: Jeff Layton <jlayton@redhat.com>
This commit is contained in:
parent
9e09d11943
commit
21f4ebf84f
@ -0,0 +1,59 @@
|
||||
From d95afa999a612badd06a5e62cb78fb2c889ac743 Mon Sep 17 00:00:00 2001
|
||||
From: Jeff Layton <jlayton@samba.org>
|
||||
Date: Wed, 8 Feb 2012 11:56:19 -0500
|
||||
Subject: [PATCH] cifs-utils: allow specifying rootsbindir at configure time
|
||||
|
||||
...via the $ROOTSBINDIR environment variable, and AC_ARG_VAR macro.
|
||||
The default is to use /sbin for this value, which only currently
|
||||
affects the installation location of mount.cifs.
|
||||
|
||||
Signed-off-by: Jeff Layton <jlayton@samba.org>
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
configure.ac | 10 +++++++++-
|
||||
2 files changed, 10 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 6182965..924c99e 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
AM_CFLAGS = -Wall -Wextra
|
||||
ACLOCAL_AMFLAGS = -I aclocal
|
||||
|
||||
-root_sbindir = "/sbin"
|
||||
+root_sbindir = $(ROOTSBINDIR)
|
||||
root_sbin_PROGRAMS = mount.cifs
|
||||
mount_cifs_SOURCES = mount.cifs.c mtab.c resolve_host.c util.c
|
||||
mount_cifs_LDADD = $(LIBCAP) $(CAPNG_LDADD)
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 4c715ab..02b1ef2 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -9,7 +9,7 @@ AC_CONFIG_MACRO_DIR(aclocal)
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
|
||||
-# "with" options
|
||||
+# "enable" options
|
||||
AC_ARG_ENABLE(cifsupcall,
|
||||
[AC_HELP_STRING([--enable-cifsupcall],
|
||||
[Create cifs.upcall binary @<:@default=yes@:>@])],
|
||||
@@ -34,6 +34,14 @@ AC_ARG_ENABLE(cifsacl,
|
||||
enable_cifsacl=$enableval,
|
||||
enable_cifsacl="maybe")
|
||||
|
||||
+# check for ROOTSBINDIR environment var
|
||||
+if test -z $ROOTSBINDIR; then
|
||||
+ ROOTSBINDIR="/sbin"
|
||||
+ export ROOTSBINDIR
|
||||
+fi
|
||||
+
|
||||
+AC_ARG_VAR(ROOTSBINDIR, [Location where files ordinarily under /sbin should be installed. Note: unaffected by --prefix. @<:@default=/sbin@:>@])
|
||||
+
|
||||
# Checks for programs.
|
||||
AC_PROG_CC
|
||||
AC_PROG_SED
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -12,6 +12,7 @@ URL: http://linux-cifs.samba.org/cifs-utils/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}%{pre_release}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Source0: ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/%{name}-%{version}%{pre_release}.tar.bz2
|
||||
Patch0: 0001-cifs-utils-allow-specifying-rootsbindir-at-configure.patch
|
||||
|
||||
BuildRequires: libcap-ng-devel libtalloc-devel krb5-devel keyutils-libs-devel autoconf automake samba-winbind-devel
|
||||
Requires: keyutils
|
||||
@ -26,9 +27,10 @@ file system.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{pre_release}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure --prefix=/usr
|
||||
%configure --prefix=/usr ROOTSBINDIR=%{_sbindir}
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
@ -44,10 +46,10 @@ rm -rf %{buildroot}
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc
|
||||
/sbin/mount.cifs
|
||||
%{_bindir}/getcifsacl
|
||||
%{_bindir}/setcifsacl
|
||||
%{_bindir}/cifscreds
|
||||
%{_sbindir}/mount.cifs
|
||||
%{_sbindir}/cifs.upcall
|
||||
%{_sbindir}/cifs.idmap
|
||||
%{_mandir}/man1/getcifsacl.1.gz
|
||||
@ -60,6 +62,9 @@ rm -rf %{buildroot}
|
||||
%config(noreplace) %{_sysconfdir}/request-key.d/cifs.spnego.conf
|
||||
|
||||
%changelog
|
||||
* Wed Feb 08 2012 Jeff Layton <jlayton@redhat.com> 5.3-2
|
||||
- move mount.cifs to /usr/sbin per new packaging guidelines
|
||||
|
||||
* Sat Jan 28 2012 Jeff Layton <jlayton@redhat.com> 5.3-1
|
||||
- update to 5.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user