Update to 0.16 (#1144863)
This commit is contained in:
parent
64f1a39af2
commit
c45ff6b293
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
chrpath-0.13.tar.gz
|
||||
/chrpath-0.16.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -uNr chrpath-0.13.old/killrpath.c chrpath-0.13/killrpath.c
|
||||
--- chrpath-0.13.old/killrpath.c 2003-06-24 00:46:15.000000000 +0200
|
||||
+++ chrpath-0.13/killrpath.c 2009-07-19 23:05:11.000000000 +0200
|
||||
@@ -73,8 +73,11 @@
|
||||
if ( ! elf_dynpath_tag(dyns[i].d_tag) )
|
||||
dynpos++;
|
||||
}
|
||||
- for (; dynpos < i; dynpos++)
|
||||
+ for (; dynpos < i; dynpos++) {
|
||||
dyns[dynpos].d_tag = DT_NULL;
|
||||
+ dyns[dynpos].d_un.d_val = 0x0;
|
||||
+ }
|
||||
+
|
||||
|
||||
if (lseek(fd, phdr.p_offset, SEEK_SET) == -1
|
||||
|| write(fd, dyns, phdr.p_filesz) != (int)phdr.p_filesz)
|
@ -1,32 +0,0 @@
|
||||
diff -urN chrpath-0.13/config.guess chrpath-0.13-aarch64/config.guess
|
||||
--- chrpath-0.13/config.guess 2002-04-01 06:18:37.000000000 -0600
|
||||
+++ chrpath-0.13-aarch64/config.guess 2013-03-07 21:01:24.604531606 -0600
|
||||
@@ -637,6 +705,9 @@
|
||||
i*86:Minix:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-minix
|
||||
exit 0 ;;
|
||||
+ aarch64:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
arm*:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit 0 ;;
|
||||
diff -urN chrpath-0.13/config.sub chrpath-0.13-aarch64/config.sub
|
||||
--- chrpath-0.13/config.sub 2002-04-01 06:18:37.000000000 -0600
|
||||
+++ chrpath-0.13-aarch64/config.sub 2013-03-07 21:01:24.647526709 -0600
|
||||
@@ -226,6 +255,7 @@
|
||||
# Some are omitted here because they have special meanings below.
|
||||
1750a | 580 \
|
||||
| a29k \
|
||||
+ | aarch64 | aarch64_be \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
||||
@@ -278,6 +367,7 @@
|
||||
# Recognize the basic CPU types with company name.
|
||||
580-* \
|
||||
| a29k-* \
|
||||
+ | aarch64-* | aarch64_be-* \
|
||||
| alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
@ -1,13 +0,0 @@
|
||||
diff -up ./main.c~ ./main.c
|
||||
--- ./main.c~ 2004-09-19 10:33:37.000000000 +0200
|
||||
+++ ./main.c 2012-10-22 12:10:03.795745769 +0200
|
||||
@@ -31,7 +31,8 @@ static struct option long_options[] =
|
||||
{"keepgoing", 0, 0, 'k'},
|
||||
{"list", 0, 0, 'l'},
|
||||
{"replace", 1, 0, 'r'},
|
||||
- {"version", 0, 0, 'v'}
|
||||
+ {"version", 0, 0, 'v'},
|
||||
+ {0, 0, 0, 0}
|
||||
};
|
||||
|
||||
#else /* not HAVE_GETOPT_LONG */
|
@ -1,13 +0,0 @@
|
||||
diff -up chrpath-0.13/main.c\~ chrpath-0.13/main.c
|
||||
--- chrpath-0.13/main.c~ 2013-04-04 18:01:29.519912735 +0200
|
||||
+++ chrpath-0.13/main.c 2013-04-08 10:34:19.332766127 +0200
|
||||
@@ -52,6 +52,7 @@ usage(char *progname)
|
||||
printf(" -r <path>|--replace <path> Replace current rpath/runpath setting\n");
|
||||
printf(" with the path given\n");
|
||||
printf(" -l|--list List the current rpath/runpath (default)\n");
|
||||
+ printf(" -k|--keepgoing Do not fail on first error\n");
|
||||
printf(" -h|--help Show this usage information.\n");
|
||||
#ifndef HAVE_GETOPT_LONG
|
||||
printf("\n *** The long options are not available on this platform");
|
||||
|
||||
Diff finished. Mon Apr 8 10:34:27 2013
|
22
chrpath.spec
22
chrpath.spec
@ -1,23 +1,13 @@
|
||||
Summary: Modify rpath of compiled programs
|
||||
Name: chrpath
|
||||
Version: 0.13
|
||||
Release: 15%{?dist}
|
||||
Version: 0.16
|
||||
Release: 1%{?dist}
|
||||
License: GPL+
|
||||
Group: Development/Tools
|
||||
URL: ftp://ftp.hungry.com/pub/hungry/chrpath/
|
||||
Source0: ftp://ftp.hungry.com/pub/hungry/chrpath/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
Patch0: chrpath-0.13-NULL-entry.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=868611
|
||||
Patch1: chrpath-0.13-getopt_long.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=925224
|
||||
Patch2: chrpath-0.13-aarch64.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=948858
|
||||
Patch3: chrpath-0.13-help.patch
|
||||
|
||||
%description
|
||||
chrpath allows you to modify the dynamic library load path (rpath) of
|
||||
@ -26,10 +16,7 @@ is supported.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .NULL
|
||||
%patch1 -p1 -b .getopt_long
|
||||
%patch2 -p1 -b .aarch64
|
||||
%patch3 -p1 -b .help
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -51,6 +38,9 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man1/chrpath.1*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 25 2015 David King <amigadave@amigadave.com> - 0.16-1
|
||||
- Update to 0.16 (#1144863)
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user