Update config.sub and config.guess to support aarch64
This commit is contained in:
parent
7ed0260f88
commit
29c605d24d
32
chrpath-0.13-aarch64.patch
Normal file
32
chrpath-0.13-aarch64.patch
Normal file
@ -0,0 +1,32 @@
|
||||
diff -urN chrpath-0.13/config.guess chrpath-0.13-aarch64/config.guess
|
||||
--- chrpath-0.13/config.guess 2002-04-01 06:18:37.000000000 -0600
|
||||
+++ chrpath-0.13-aarch64/config.guess 2013-03-07 21:01:24.604531606 -0600
|
||||
@@ -637,6 +705,9 @@
|
||||
i*86:Minix:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-minix
|
||||
exit 0 ;;
|
||||
+ aarch64:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
arm*:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit 0 ;;
|
||||
diff -urN chrpath-0.13/config.sub chrpath-0.13-aarch64/config.sub
|
||||
--- chrpath-0.13/config.sub 2002-04-01 06:18:37.000000000 -0600
|
||||
+++ chrpath-0.13-aarch64/config.sub 2013-03-07 21:01:24.647526709 -0600
|
||||
@@ -226,6 +255,7 @@
|
||||
# Some are omitted here because they have special meanings below.
|
||||
1750a | 580 \
|
||||
| a29k \
|
||||
+ | aarch64 | aarch64_be \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
||||
@@ -278,6 +367,7 @@
|
||||
# Recognize the basic CPU types with company name.
|
||||
580-* \
|
||||
| a29k-* \
|
||||
+ | aarch64-* | aarch64_be-* \
|
||||
| alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
17
chrpath.spec
17
chrpath.spec
@ -5,11 +5,17 @@ Release: 11%{?dist}
|
||||
License: GPL+
|
||||
Group: Development/Tools
|
||||
URL: ftp://ftp.hungry.com/pub/hungry/chrpath/
|
||||
Patch0: chrpath-0.13-NULL-entry.patch
|
||||
Patch1: chrpath-0.13-getopt_long.patch
|
||||
Source0: ftp://ftp.hungry.com/pub/hungry/chrpath/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
Patch0: chrpath-0.13-NULL-entry.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=868611
|
||||
Patch1: chrpath-0.13-getopt_long.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=925224
|
||||
Patch2: chrpath-0.13-aarch64.patch
|
||||
|
||||
%description
|
||||
chrpath allows you to modify the dynamic library load path (rpath) of
|
||||
compiled programs. Currently, only removing and modifying the rpath
|
||||
@ -19,6 +25,7 @@ is supported.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .NULL
|
||||
%patch1 -p1 -b .getopt_long
|
||||
%patch2 -p1 -b .aarch64
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -40,9 +47,11 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man1/chrpath.1*
|
||||
|
||||
%changelog
|
||||
* Mon Oct 22 2012 Petr Machata <pmachata@redhat.com> - 0.13-11
|
||||
* Thu Apr 4 2013 Petr Machata <pmachata@redhat.com> - 0.13-11
|
||||
- Add missing last entry in long options array
|
||||
- Resolves: #868611
|
||||
(chrpath-0.13-getopt_long.patch)
|
||||
- Update config.sub and config.guess to support aarch64
|
||||
(chrpath-0.13-aarch64.patch)
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user