update to 3.2-pre1
This commit is contained in:
parent
3f9c9e5a2a
commit
4cd6554f04
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
/chrony-3.1.tar.gz
|
/chrony-3.2-pre1.tar.gz
|
||||||
/clknetsim-ce89a1.tar.gz
|
/clknetsim-71dbbc.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
commit abb09418b16993ecd8289dd459dff91701f4f971
|
|
||||||
Author: Miroslav Lichvar <mlichvar@redhat.com>
|
|
||||||
Date: Wed Apr 19 12:20:14 2017 +0200
|
|
||||||
|
|
||||||
sys_linux: don't drop PHC samples with zero delay
|
|
||||||
|
|
||||||
When processing data from the PTP_SYS_OFFSET ioctl, the sample is
|
|
||||||
dropped when an interval between two consecutive readings of the system
|
|
||||||
clock is negative or zero, assuming the clock has been stepped between
|
|
||||||
the two readings.
|
|
||||||
|
|
||||||
With a real PHC the interval is normally expected to be at least a
|
|
||||||
microsecond, but with a virtual PHC and a low-resolution system clock
|
|
||||||
it's possible to get two readings with the same system time. Modify the
|
|
||||||
check to drop only samples with a negative delay.
|
|
||||||
|
|
||||||
diff --git a/sys_linux.c b/sys_linux.c
|
|
||||||
index c06112a..649afb0 100644
|
|
||||||
--- a/sys_linux.c
|
|
||||||
+++ b/sys_linux.c
|
|
||||||
@@ -705,9 +705,11 @@ get_phc_sample(int phc_fd, double precision, struct timespec *phc_ts,
|
|
||||||
phc_tss[i] = ts2;
|
|
||||||
delays[i] = UTI_DiffTimespecsToDouble(&ts3, &ts1);
|
|
||||||
|
|
||||||
- if (delays[i] <= 0.0)
|
|
||||||
+ if (delays[i] < 0.0) {
|
|
||||||
/* Step in the middle of a PHC reading? */
|
|
||||||
+ DEBUG_LOG(LOGF_SysLinux, "Bad PTP_SYS_OFFSET sample delay=%e", delays[i]);
|
|
||||||
return 0;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (!i || delays[i] < min_delay)
|
|
||||||
min_delay = delays[i];
|
|
@ -1,47 +0,0 @@
|
|||||||
commit 768bce799bfe009e7dbaad5742738f7d05280d6d
|
|
||||||
Author: Miroslav Lichvar <mlichvar@redhat.com>
|
|
||||||
Date: Mon Mar 13 14:26:12 2017 +0100
|
|
||||||
|
|
||||||
sys_linux: allow getpid in seccomp filter
|
|
||||||
|
|
||||||
It seems to be used by syslog() in latest glibc.
|
|
||||||
|
|
||||||
diff --git a/sys_linux.c b/sys_linux.c
|
|
||||||
index 3dd411f..c06112a 100644
|
|
||||||
--- a/sys_linux.c
|
|
||||||
+++ b/sys_linux.c
|
|
||||||
@@ -467,9 +467,10 @@ SYS_Linux_EnableSystemCallFilter(int level)
|
|
||||||
SCMP_SYS(adjtimex), SCMP_SYS(clock_gettime), SCMP_SYS(gettimeofday),
|
|
||||||
SCMP_SYS(settimeofday), SCMP_SYS(time),
|
|
||||||
/* Process */
|
|
||||||
- SCMP_SYS(clone), SCMP_SYS(exit), SCMP_SYS(exit_group), SCMP_SYS(getrlimit),
|
|
||||||
- SCMP_SYS(rt_sigaction), SCMP_SYS(rt_sigreturn), SCMP_SYS(rt_sigprocmask),
|
|
||||||
- SCMP_SYS(set_tid_address), SCMP_SYS(sigreturn), SCMP_SYS(wait4),
|
|
||||||
+ SCMP_SYS(clone), SCMP_SYS(exit), SCMP_SYS(exit_group), SCMP_SYS(getpid),
|
|
||||||
+ SCMP_SYS(getrlimit), SCMP_SYS(rt_sigaction), SCMP_SYS(rt_sigreturn),
|
|
||||||
+ SCMP_SYS(rt_sigprocmask), SCMP_SYS(set_tid_address), SCMP_SYS(sigreturn),
|
|
||||||
+ SCMP_SYS(wait4),
|
|
||||||
/* Memory */
|
|
||||||
SCMP_SYS(brk), SCMP_SYS(madvise), SCMP_SYS(mmap), SCMP_SYS(mmap2),
|
|
||||||
SCMP_SYS(mprotect), SCMP_SYS(mremap), SCMP_SYS(munmap), SCMP_SYS(shmdt),
|
|
||||||
commit 653d70ec4e567b33b917f6784a68dfb254aa8984
|
|
||||||
Author: Miroslav Lichvar <mlichvar@redhat.com>
|
|
||||||
Date: Wed Apr 19 14:38:51 2017 +0200
|
|
||||||
|
|
||||||
sys_linux: allow sysinfo in seccomp filter
|
|
||||||
|
|
||||||
It may be used by glob() in latest glibc.
|
|
||||||
|
|
||||||
diff --git a/sys_linux.c b/sys_linux.c
|
|
||||||
index 649afb0..2cd178a 100644
|
|
||||||
--- a/sys_linux.c
|
|
||||||
+++ b/sys_linux.c
|
|
||||||
@@ -490,7 +490,7 @@ SYS_Linux_EnableSystemCallFilter(int level)
|
|
||||||
SCMP_SYS(poll), SCMP_SYS(read), SCMP_SYS(futex), SCMP_SYS(select),
|
|
||||||
SCMP_SYS(set_robust_list), SCMP_SYS(write),
|
|
||||||
/* Miscellaneous */
|
|
||||||
- SCMP_SYS(uname),
|
|
||||||
+ SCMP_SYS(sysinfo), SCMP_SYS(uname),
|
|
||||||
};
|
|
||||||
|
|
||||||
const int socket_domains[] = {
|
|
13
chrony.spec
13
chrony.spec
@ -1,9 +1,10 @@
|
|||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
%global clknetsim_ver ce89a1
|
%global prerelease -pre1
|
||||||
|
%global clknetsim_ver 71dbbc
|
||||||
%bcond_without debug
|
%bcond_without debug
|
||||||
|
|
||||||
Name: chrony
|
Name: chrony
|
||||||
Version: 3.1
|
Version: 3.2
|
||||||
Release: 5%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: An NTP client/server
|
Summary: An NTP client/server
|
||||||
|
|
||||||
@ -21,10 +22,6 @@ Source10: https://github.com/mlichvar/clknetsim/archive/%{clknetsim_ver}/c
|
|||||||
|
|
||||||
# add NTP servers from DHCP when starting service
|
# add NTP servers from DHCP when starting service
|
||||||
Patch1: chrony-service-helper.patch
|
Patch1: chrony-service-helper.patch
|
||||||
# fix seccomp filter for new glibc
|
|
||||||
Patch2: chrony-seccomp.patch
|
|
||||||
# don't drop PHC samples with zero delay
|
|
||||||
Patch3: chrony-phcdelay.patch
|
|
||||||
|
|
||||||
BuildRequires: libcap-devel libedit-devel nss-devel pps-tools-devel
|
BuildRequires: libcap-devel libedit-devel nss-devel pps-tools-devel
|
||||||
%ifarch %{ix86} x86_64 %{arm} aarch64 mipsel mips64el ppc64 ppc64le s390 s390x
|
%ifarch %{ix86} x86_64 %{arm} aarch64 mipsel mips64el ppc64 ppc64le s390 s390x
|
||||||
@ -61,8 +58,6 @@ clocks, system real-time clock or manual input as time references.
|
|||||||
%setup -q -n %{name}-%{version}%{?prerelease} -a 10
|
%setup -q -n %{name}-%{version}%{?prerelease} -a 10
|
||||||
%{?gitpatch:%patch0 -p1}
|
%{?gitpatch:%patch0 -p1}
|
||||||
%patch1 -p1 -b .service-helper
|
%patch1 -p1 -b .service-helper
|
||||||
%patch2 -p1 -b .seccomp
|
|
||||||
%patch3 -p1 -b .phcdelay
|
|
||||||
|
|
||||||
%{?gitpatch: echo %{version}-%{gitpatch} > version.txt}
|
%{?gitpatch: echo %{version}-%{gitpatch} > version.txt}
|
||||||
|
|
||||||
@ -145,7 +140,7 @@ echo 'chronyd.service' > \
|
|||||||
# set random seed to get deterministic results
|
# set random seed to get deterministic results
|
||||||
export CLKNETSIM_RANDOM_SEED=24502
|
export CLKNETSIM_RANDOM_SEED=24502
|
||||||
make %{?_smp_mflags} -C test/simulation/clknetsim
|
make %{?_smp_mflags} -C test/simulation/clknetsim
|
||||||
make check
|
make quickcheck
|
||||||
|
|
||||||
%pre
|
%pre
|
||||||
getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
|
getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (chrony-3.1.tar.gz) = 4ba3a75c3634050bb63ba9ee80d9be7a295f44ce4d195a050e4be4738bd7dd807fe37f2289d7ead4a75272bd5ebadbd03c233c67f859e9b68871fca5a6671427
|
SHA512 (chrony-3.2-pre1.tar.gz) = 8ce54f246c3e11e72d90ba03e6f39894445eed314b26113c4a98b5746a00c1886291bf1bb20db68318c3310350b36ea6c88fe05607ae82e551ee93aea6e3fcb6
|
||||||
SHA512 (clknetsim-ce89a1.tar.gz) = 88888559439c570099bf66aff86d7260402b3110514da1c27b5620a97716c2eed416ba12e43e63705d7abd08d0f3f926df28730addd0e7ccb97f36b6a6480fd7
|
SHA512 (clknetsim-71dbbc.tar.gz) = 626175a3e97b33eaa462cd8416d5da18f44750d74a73dc824b591573a30613e956275951fd9d5bc52e1092284b0d7a67a85179e89532fa41d4a74c97aa0c78ba
|
||||||
|
Loading…
Reference in New Issue
Block a user