import chrome-gnome-shell-10.1-6.el8

This commit is contained in:
CentOS Sources 2019-11-05 16:26:53 -05:00 committed by Andrew Lukoshko
commit ff72729547
4 changed files with 181 additions and 0 deletions

View File

@ -0,0 +1,2 @@
f8c05bd58302c6b0ad3220f9e82df4a43b4ea4f3 SOURCES/chrome-gnome-shell-10.1.tar.xz
73bcbdc45be4db907a864e829b06cd869f77f4f7 SOURCES/jq-1.6.tar.gz

2
.gitignore vendored Normal file
View File

@ -0,0 +1,2 @@
SOURCES/chrome-gnome-shell-10.1.tar.xz
SOURCES/jq-1.6.tar.gz

View File

@ -0,0 +1,39 @@
From bb1755043ce4b859406766dd2cdcb34b6fb300da Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Fri, 12 Jul 2019 16:13:27 +0200
Subject: [PATCH] build: Install icons in hicolor theme
This is the theme that will always be used as fallback regardless of the
icon-theme setting, and the expected location for application icons[0].
[0] https://wiki.gnome.org/HowDoI/ThemedIcons
https://gitlab.gnome.org/GNOME/chrome-gnome-shell/merge_requests/4
---
CMakeLists.txt | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f41ed4a..170c9f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,13 +202,13 @@ if(BUILD_CONNECTOR)
install(FILES "${CMAKE_BINARY_DIR}/org.gnome.ChromeGnomeShell.service" DESTINATION "${CMAKE_INSTALL_DATADIR}/dbus-1/services/")
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-16.png"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/16x16/apps/"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/16x16/apps/"
RENAME org.gnome.ChromeGnomeShell.png)
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-48.png"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/48x48/apps/"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/48x48/apps/"
RENAME org.gnome.ChromeGnomeShell.png)
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-128.png"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/128x128/apps/"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/128x128/apps/"
RENAME org.gnome.ChromeGnomeShell.png)
endif(BUILD_CONNECTOR)
--
2.21.0

View File

@ -0,0 +1,138 @@
%global debug_package %{nil}
Name: chrome-gnome-shell
Version: 10.1
Release: 6%{?dist}
Summary: Support for managing GNOME Shell Extensions through web browsers
License: GPLv3+
URL: https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome
Source0: https://download.gnome.org/sources/%{name}/%{version}/%{name}-%{version}.tar.xz
Source1: https://github.com/stedolan/jq/releases/download/jq-1.6/jq-1.6.tar.gz
Patch1: 0001-build-Install-icons-in-hicolor-theme.patch
BuildRequires: cmake
BuildRequires: desktop-file-utils
BuildRequires: python3-devel
BuildRequires: /usr/bin/base64
BuildRequires: /usr/bin/head
BuildRequires: /usr/bin/sha256sum
BuildRequires: /usr/bin/tr
Requires: dbus
Requires: gnome-shell
Requires: hicolor-icon-theme
Requires: mozilla-filesystem
Requires: python3-gobject-base
Requires: python3-requests
%description
Browser extension for Google Chrome/Chromium, Firefox, Vivaldi, Opera (and
other Browser Extension, Chrome Extension or WebExtensions capable browsers)
and native host messaging connector that provides integration with GNOME Shell
and the corresponding extensions repository https://extensions.gnome.org.
%prep
%setup -q -n jq-1.6 -b1 -T
%autosetup
%build
(cd ../jq-1.6
./configure --with-oniguruma=no \
--prefix=$PWD
make %{?_smp_mflags}
make install)
export PATH=$PWD/../jq-1.6/bin:$PATH
mkdir build
pushd build
%cmake -DBUILD_EXTENSION=OFF \
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
-DPython_ADDITIONAL_VERSIONS=3 \
..
%make_build
popd
%install
pushd build
%make_install
popd
%check
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.ChromeGnomeShell.desktop
%files
%license LICENSE
%{_sysconfdir}/chromium/
%{_sysconfdir}/opt/chrome/
%{_bindir}/chrome-gnome-shell
%{_libdir}/mozilla/native-messaging-hosts/
%{python3_sitelib}/chrome_gnome_shell-*.egg-info
%{_datadir}/applications/org.gnome.ChromeGnomeShell.desktop
%{_datadir}/dbus-1/services/org.gnome.ChromeGnomeShell.service
%{_datadir}/icons/hicolor/*/apps/org.gnome.ChromeGnomeShell.png
%changelog
* Fri Jul 12 2019 Florian Müllner <fmuellner@redhat.com> - 10.1-6
- Install icons in 'hicolor' instead of 'gnome'
Related: #1694203
* Thu Jul 12 2019 Tomas Pelka <tpelka@redhat.com> - 10.1-5
- bump release num to correctly start gating process
Related: #1694203
* Thu Jul 11 2019 Florian Müllner <fmuellner@redhat.com> - 10.1-4
- Adjust Fedora spec to build on RHEL:
- build missing BuildRequire
Related: #1694203
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 10.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 10.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 10.1-2
- Rebuilt for Python 3.7
* Wed Apr 04 2018 Pete Walter <pwalter@fedoraproject.org> - 10.1-1
- Update to 10.1
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 9-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Thu Jun 22 2017 Pete Walter <pwalter@fedoraproject.org> - 9-1
- Update to 9
* Fri Mar 10 2017 Pete Walter <pwalter@fedoraproject.org> - 8.2-2
- Package review fixes (#1343710)
- Validate the desktop file
- Don't own /etc/opt directory
- Depend on mozilla-filesystem instead of co-owning mozilla directories
- Depend on dbus and gnome-icon-theme/hicolor-icon-theme for directory
ownership
* Fri Mar 03 2017 Pete Walter <pwalter@fedoraproject.org> - 8.2-1
- Update to 8.2
- Simplify files list
- Build with Python 3 (#1343710)
- Add missing python3-requests dependency (#1343710)
- Update package description
* Tue Jun 07 2016 Pete Walter <pwalter@fedoraproject.org> - 6.1-1
- Update to 6.1
* Sat May 14 2016 Maxim Orlov <murmansksity@gmail.com> - 6-1
- Update to Ver.6
- Fix "orphaned directory"
* Mon Apr 11 2016 Maxim Orlov <murmansksity@gmail.com> - 5.2-1
- Initial package.