Update to gnome-browser-connector 42.1

The website now requires a newer version of the host connector,
so update to the latest version.

For now we are keeping the existing package name, even though the
upstream project was renamed to "gnome-browser-connector".

Resolves: #2204484
This commit is contained in:
Florian Müllner 2023-05-17 14:51:54 +02:00
parent 459778010f
commit ce663323d9
4 changed files with 25 additions and 66 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/chrome-gnome-shell-8.2.tar.xz
/chrome-gnome-shell-9.tar.xz
/chrome-gnome-shell-10.1.tar.xz
/gnome-browser-connector-42.1.tar.xz

View File

@ -1,39 +0,0 @@
From bb1755043ce4b859406766dd2cdcb34b6fb300da Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Fri, 12 Jul 2019 16:13:27 +0200
Subject: [PATCH] build: Install icons in hicolor theme
This is the theme that will always be used as fallback regardless of the
icon-theme setting, and the expected location for application icons[0].
[0] https://wiki.gnome.org/HowDoI/ThemedIcons
https://gitlab.gnome.org/GNOME/chrome-gnome-shell/merge_requests/4
---
CMakeLists.txt | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f41ed4a..170c9f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,13 +202,13 @@ if(BUILD_CONNECTOR)
install(FILES "${CMAKE_BINARY_DIR}/org.gnome.ChromeGnomeShell.service" DESTINATION "${CMAKE_INSTALL_DATADIR}/dbus-1/services/")
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-16.png"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/16x16/apps/"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/16x16/apps/"
RENAME org.gnome.ChromeGnomeShell.png)
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-48.png"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/48x48/apps/"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/48x48/apps/"
RENAME org.gnome.ChromeGnomeShell.png)
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-128.png"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/128x128/apps/"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/128x128/apps/"
RENAME org.gnome.ChromeGnomeShell.png)
endif(BUILD_CONNECTOR)
--
2.29.2

View File

@ -1,32 +1,25 @@
%global debug_package %{nil}
%global source_name gnome-browser-connector
Name: chrome-gnome-shell
Version: 10.1
Release: 14%{?dist}
Version: 42.1
Release: 1%{?dist}
Summary: Support for managing GNOME Shell Extensions through web browsers
License: GPLv3+
URL: https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome
Source0: https://download.gnome.org/sources/%{name}/%{version}/%{name}-%{version}.tar.xz
URL: https://gitlab.gnome.org/GNOME/%{source_name}
Source0: https://download.gnome.org/sources/%{source_name}/42/%{source_name}-%{version}.tar.xz
# Backported from upstream
Patch0: 0001-build-Install-icons-in-hicolor-theme.patch
BuildRequires: cmake
BuildRequires: desktop-file-utils
BuildRequires: meson
BuildRequires: python3-devel
BuildRequires: /usr/bin/base64
BuildRequires: /usr/bin/head
BuildRequires: /usr/bin/jq
BuildRequires: /usr/bin/sha256sum
BuildRequires: /usr/bin/tr
BuildRequires: python3-gobject-base
Requires: dbus
Requires: gnome-shell
Requires: hicolor-icon-theme
Requires: mozilla-filesystem
Requires: python3-gobject-base
Requires: python3-requests
%description
Browser extension for Google Chrome/Chromium, Firefox, Vivaldi, Opera (and
@ -35,32 +28,36 @@ and native host messaging connector that provides integration with GNOME Shell
and the corresponding extensions repository https://extensions.gnome.org.
%prep
%autosetup -p1
%autosetup -p1 -n %{source_name}-%{version}
%build
%cmake -DBUILD_EXTENSION=OFF \
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
-DPython_ADDITIONAL_VERSIONS=3
%cmake_build
%meson
%meson_build
%install
%cmake_install
%meson_install
%check
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.ChromeGnomeShell.desktop
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.BrowserConnector.desktop
%files
%license LICENSE
%doc NEWS README.md
%{_sysconfdir}/chromium/
%{_sysconfdir}/opt/chrome/
%{_bindir}/chrome-gnome-shell
%{_bindir}/gnome-browser-connector
%{_bindir}/gnome-browser-connector-host
%{python3_sitelib}/gnome_browser_connector/
%{_libdir}/mozilla/native-messaging-hosts/
%{python3_sitelib}/chrome_gnome_shell-*.egg-info
%{_datadir}/applications/org.gnome.ChromeGnomeShell.desktop
%{_datadir}/dbus-1/services/org.gnome.ChromeGnomeShell.service
%{_datadir}/icons/hicolor/*/apps/org.gnome.ChromeGnomeShell.png
%{_datadir}/applications/org.gnome.BrowserConnector.desktop
%{_datadir}/dbus-1/services/org.gnome.BrowserConnector.service
%{_datadir}/icons/hicolor/*/apps/org.gnome.BrowserConnector.png
%changelog
* Wed May 17 2023 Florian Müllner <fmuellner@redhat.com> - 42.1-1
- Update to gnome-browser-connector-42.1
Resolves: #2204484
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 10.1-14
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688

View File

@ -1 +1 @@
SHA512 (chrome-gnome-shell-10.1.tar.xz) = f92e98a167e9031cc691d68c668471bf2a9d40b99d740119c7833211b82f33250ea80def912c7725e0b454c1637e9a18c44d0c6f2afd1912ba66bf8f088ec204
SHA512 (gnome-browser-connector-42.1.tar.xz) = f8f7c0e7f3fb6bd50eddc674c48f521d07aa03b5b36674e8dfcb6b6d8203bbdf4fc4de1f7cbbcc805a3da3cf098a27bda281b7a0ac5b98d7144dffe85698b7d7