Import from AlmaLinux stable repository
This commit is contained in:
parent
55fb6a86a8
commit
6ca679a655
@ -1,2 +0,0 @@
|
||||
f8c05bd58302c6b0ad3220f9e82df4a43b4ea4f3 SOURCES/chrome-gnome-shell-10.1.tar.xz
|
||||
73bcbdc45be4db907a864e829b06cd869f77f4f7 SOURCES/jq-1.6.tar.gz
|
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,2 +1 @@
|
||||
SOURCES/chrome-gnome-shell-10.1.tar.xz
|
||||
SOURCES/jq-1.6.tar.gz
|
||||
SOURCES/gnome-browser-connector-42.1.tar.xz
|
||||
|
37
SOURCES/0001-Don-t-use-enhanced-annotations.patch
Normal file
37
SOURCES/0001-Don-t-use-enhanced-annotations.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From f9b10b97246f723cde725d77001308f9e6ed56d8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 24 May 2023 12:13:20 +0200
|
||||
Subject: [PATCH] Don't use enhanced annotations
|
||||
|
||||
---
|
||||
gnome_browser_connector/application.py | 2 --
|
||||
gnome_browser_connector/connector.py | 2 --
|
||||
2 files changed, 4 deletions(-)
|
||||
|
||||
diff --git a/gnome_browser_connector/application.py b/gnome_browser_connector/application.py
|
||||
index 8e57ef1..2069a34 100644
|
||||
--- a/gnome_browser_connector/application.py
|
||||
+++ b/gnome_browser_connector/application.py
|
||||
@@ -1,7 +1,5 @@
|
||||
# SPDX-License-Identifer: GPL-3.0-or-later
|
||||
|
||||
-from __future__ import annotations
|
||||
-
|
||||
import signal
|
||||
import sys
|
||||
import traceback
|
||||
diff --git a/gnome_browser_connector/connector.py b/gnome_browser_connector/connector.py
|
||||
index e72c432..a81b5ed 100644
|
||||
--- a/gnome_browser_connector/connector.py
|
||||
+++ b/gnome_browser_connector/connector.py
|
||||
@@ -1,7 +1,5 @@
|
||||
# SPDX-License-Identifer: GPL-3.0-or-later
|
||||
|
||||
-from __future__ import annotations
|
||||
-
|
||||
import json
|
||||
import struct
|
||||
import sys
|
||||
--
|
||||
2.40.0
|
||||
|
@ -1,39 +0,0 @@
|
||||
From bb1755043ce4b859406766dd2cdcb34b6fb300da Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 12 Jul 2019 16:13:27 +0200
|
||||
Subject: [PATCH] build: Install icons in hicolor theme
|
||||
|
||||
This is the theme that will always be used as fallback regardless of the
|
||||
icon-theme setting, and the expected location for application icons[0].
|
||||
|
||||
[0] https://wiki.gnome.org/HowDoI/ThemedIcons
|
||||
|
||||
https://gitlab.gnome.org/GNOME/chrome-gnome-shell/merge_requests/4
|
||||
---
|
||||
CMakeLists.txt | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index f41ed4a..170c9f7 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -202,13 +202,13 @@ if(BUILD_CONNECTOR)
|
||||
install(FILES "${CMAKE_BINARY_DIR}/org.gnome.ChromeGnomeShell.service" DESTINATION "${CMAKE_INSTALL_DATADIR}/dbus-1/services/")
|
||||
|
||||
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-16.png"
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/16x16/apps/"
|
||||
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/16x16/apps/"
|
||||
RENAME org.gnome.ChromeGnomeShell.png)
|
||||
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-48.png"
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/48x48/apps/"
|
||||
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/48x48/apps/"
|
||||
RENAME org.gnome.ChromeGnomeShell.png)
|
||||
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/extension/icons/GnomeLogo-128.png"
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/gnome/128x128/apps/"
|
||||
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/icons/hicolor/128x128/apps/"
|
||||
RENAME org.gnome.ChromeGnomeShell.png)
|
||||
endif(BUILD_CONNECTOR)
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,137 +0,0 @@
|
||||
From c8bff2cb5f2b3f01dd3f98adb7e8358d604b3c47 Mon Sep 17 00:00:00 2001
|
||||
From: Yuri Konotopov <ykonotopov@gnome.org>
|
||||
Date: Sun, 10 May 2020 14:22:47 +0400
|
||||
Subject: [PATCH] connector: drop updates support in favour of Shell 3.36
|
||||
default behavior
|
||||
|
||||
Closes: https://gitlab.gnome.org/GNOME/chrome-gnome-shell/-/issues/19
|
||||
---
|
||||
connector/chrome-gnome-shell.py | 91 +--------------------------------
|
||||
1 file changed, 1 insertion(+), 90 deletions(-)
|
||||
|
||||
diff --git a/connector/chrome-gnome-shell.py b/connector/chrome-gnome-shell.py
|
||||
index 0bde4dd..6c84ba9 100755
|
||||
--- a/connector/chrome-gnome-shell.py
|
||||
+++ b/connector/chrome-gnome-shell.py
|
||||
@@ -23,12 +23,6 @@ import struct
|
||||
import sys
|
||||
import traceback
|
||||
|
||||
-REQUESTS_IMPORTED = True
|
||||
-try:
|
||||
- import requests
|
||||
-except ImportError:
|
||||
- REQUESTS_IMPORTED = False
|
||||
-
|
||||
CONNECTOR_VERSION = 10
|
||||
DEBUG_ENABLED = False
|
||||
|
||||
@@ -371,9 +365,7 @@ class ChromeGNOMEShell(Gio.Application):
|
||||
else:
|
||||
disable_version_check = False
|
||||
|
||||
- supports = ['notifications', "update-enabled"]
|
||||
- if REQUESTS_IMPORTED:
|
||||
- supports.append('update-check')
|
||||
+ supports = ['notifications']
|
||||
|
||||
self.send_message(
|
||||
{
|
||||
@@ -474,16 +466,6 @@ class ChromeGNOMEShell(Gio.Application):
|
||||
GLib.Variant.new_tuple(GLib.Variant.new_string(request['uuid'])),
|
||||
"status")
|
||||
|
||||
- elif request['execute'] == 'checkUpdate':
|
||||
- update_url = 'https://extensions.gnome.org/update-info/'
|
||||
- enabled_only = True
|
||||
- if 'url' in request:
|
||||
- update_url = request['url']
|
||||
-
|
||||
- if 'enabledOnly' in request:
|
||||
- enabled_only = request['enabledOnly']
|
||||
-
|
||||
- self.check_update(update_url, enabled_only)
|
||||
|
||||
elif request['execute'] == 'createNotification':
|
||||
Gio.DBusActionGroup.get(
|
||||
@@ -502,77 +484,6 @@ class ChromeGNOMEShell(Gio.Application):
|
||||
|
||||
debug('Execute: from %s' % request['execute'])
|
||||
|
||||
- def check_update(self, update_url, enabled_only):
|
||||
- result = self.shell_proxy.call_sync(
|
||||
- "ListExtensions",
|
||||
- None,
|
||||
- Gio.DBusCallFlags.NONE,
|
||||
- -1,
|
||||
- None
|
||||
- )
|
||||
-
|
||||
- extensions = result.unpack()[0]
|
||||
- settings = Gio.Settings.new(SHELL_SCHEMA)
|
||||
- enabled_extensions = settings.get_strv(ENABLED_EXTENSIONS_KEY)
|
||||
-
|
||||
- if extensions:
|
||||
- http_request = {
|
||||
- 'shell_version': self.shell_proxy.get_cached_property("ShellVersion").unpack(),
|
||||
- 'installed': {}
|
||||
- }
|
||||
-
|
||||
- for uuid in extensions:
|
||||
- # gnome-shell/js/misc/extensionUtils.js
|
||||
- # EXTENSION_TYPE.PER_USER = 2
|
||||
- if is_uuid(uuid) and extensions[uuid]['type'] == 2 and (not enabled_only or uuid in enabled_extensions):
|
||||
- try:
|
||||
- http_request['installed'][uuid] = {
|
||||
- 'version': int(extensions[uuid]['version'])
|
||||
- }
|
||||
- except (ValueError, KeyError):
|
||||
- http_request['installed'][uuid] = {
|
||||
- 'version': 1
|
||||
- }
|
||||
-
|
||||
- http_request['installed'] = json.dumps(http_request['installed'])
|
||||
-
|
||||
- proxies = Gio.ProxyResolver.get_default().lookup(update_url)
|
||||
- if proxies is not None:
|
||||
- proxy = proxies[0]
|
||||
- if proxy.startswith('direct'):
|
||||
- proxies = None
|
||||
- else:
|
||||
- proxies = {}
|
||||
- for scheme in ('http', 'https'):
|
||||
- proxies[scheme] = proxy
|
||||
-
|
||||
- try:
|
||||
- response = requests.get(
|
||||
- update_url,
|
||||
- params=http_request,
|
||||
- proxies=proxies,
|
||||
- timeout=5
|
||||
- )
|
||||
- response.raise_for_status()
|
||||
- self.send_message({
|
||||
- 'success': True,
|
||||
- 'extensions': extensions,
|
||||
- 'upgrade': response.json()}
|
||||
- )
|
||||
- except (
|
||||
- requests.ConnectionError, requests.HTTPError, requests.Timeout,
|
||||
- requests.TooManyRedirects, requests.RequestException, ValueError
|
||||
- ) as ex:
|
||||
- error_message = str(ex.message) if hasattr(ex, 'message') else str(ex)
|
||||
- log_error('Unable to check extensions updates: %s' % error_message)
|
||||
-
|
||||
- request_url = ex.response.url if ex.response is not None else ex.request.url
|
||||
- if request_url:
|
||||
- url_parameters = request_url.replace(update_url, "")
|
||||
- error_message = error_message.replace(url_parameters, "…")
|
||||
-
|
||||
- self.send_message({'success': False, 'message': error_message})
|
||||
-
|
||||
|
||||
if __name__ == '__main__':
|
||||
debug('Main. Use Ctrl+D to quit.')
|
||||
--
|
||||
2.29.2
|
||||
|
@ -1,33 +1,27 @@
|
||||
%global debug_package %{nil}
|
||||
%global source_name gnome-browser-connector
|
||||
|
||||
Name: chrome-gnome-shell
|
||||
Version: 10.1
|
||||
Release: 7%{?dist}
|
||||
Version: 42.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Support for managing GNOME Shell Extensions through web browsers
|
||||
|
||||
License: GPLv3+
|
||||
URL: https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome
|
||||
Source0: https://download.gnome.org/sources/%{name}/%{version}/%{name}-%{version}.tar.xz
|
||||
Source1: https://github.com/stedolan/jq/releases/download/jq-1.6/jq-1.6.tar.gz
|
||||
URL: https://gitlab.gnome.org/GNOME/%{source_name}
|
||||
Source0: https://download.gnome.org/sources/%{source_name}/42/%{source_name}-%{version}.tar.xz
|
||||
|
||||
Patch1: 0001-build-Install-icons-in-hicolor-theme.patch
|
||||
Patch2: 0001-connector-drop-updates-support-in-favour-of-Shell-3..patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: git
|
||||
BuildRequires: meson
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: /usr/bin/base64
|
||||
BuildRequires: /usr/bin/head
|
||||
BuildRequires: /usr/bin/sha256sum
|
||||
BuildRequires: /usr/bin/tr
|
||||
BuildRequires: python3-gobject-base
|
||||
|
||||
Requires: dbus
|
||||
Requires: gnome-shell
|
||||
Requires: hicolor-icon-theme
|
||||
Requires: mozilla-filesystem
|
||||
Requires: python3-gobject-base
|
||||
Requires: python3-requests
|
||||
|
||||
Patch1: 0001-Don-t-use-enhanced-annotations.patch
|
||||
|
||||
%description
|
||||
Browser extension for Google Chrome/Chromium, Firefox, Vivaldi, Opera (and
|
||||
@ -36,45 +30,36 @@ and native host messaging connector that provides integration with GNOME Shell
|
||||
and the corresponding extensions repository https://extensions.gnome.org.
|
||||
|
||||
%prep
|
||||
%setup -q -n jq-1.6 -b1 -T
|
||||
%autosetup -S git
|
||||
%autosetup -p1 -n %{source_name}-%{version}
|
||||
|
||||
%build
|
||||
(cd ../jq-1.6
|
||||
./configure --with-oniguruma=no \
|
||||
--prefix=$PWD
|
||||
make %{?_smp_mflags}
|
||||
make install)
|
||||
export PATH=$PWD/../jq-1.6/bin:$PATH
|
||||
mkdir build
|
||||
pushd build
|
||||
%cmake -DBUILD_EXTENSION=OFF \
|
||||
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
|
||||
-DPython_ADDITIONAL_VERSIONS=3 \
|
||||
..
|
||||
%make_build
|
||||
popd
|
||||
%meson
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
pushd build
|
||||
%make_install
|
||||
popd
|
||||
%meson_install
|
||||
|
||||
%check
|
||||
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.ChromeGnomeShell.desktop
|
||||
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.BrowserConnector.desktop
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc NEWS README.md
|
||||
%{_sysconfdir}/chromium/
|
||||
%{_sysconfdir}/opt/chrome/
|
||||
%{_bindir}/chrome-gnome-shell
|
||||
%{_bindir}/gnome-browser-connector
|
||||
%{_bindir}/gnome-browser-connector-host
|
||||
%{python3_sitelib}/gnome_browser_connector/
|
||||
%{_libdir}/mozilla/native-messaging-hosts/
|
||||
%{python3_sitelib}/chrome_gnome_shell-*.egg-info
|
||||
%{_datadir}/applications/org.gnome.ChromeGnomeShell.desktop
|
||||
%{_datadir}/dbus-1/services/org.gnome.ChromeGnomeShell.service
|
||||
%{_datadir}/icons/hicolor/*/apps/org.gnome.ChromeGnomeShell.png
|
||||
%{_datadir}/applications/org.gnome.BrowserConnector.desktop
|
||||
%{_datadir}/dbus-1/services/org.gnome.BrowserConnector.service
|
||||
%{_datadir}/icons/hicolor/*/apps/org.gnome.BrowserConnector.png
|
||||
|
||||
%changelog
|
||||
* Wed May 17 2023 Florian Müllner <fmuellner@redhat.com> - 42.1-1
|
||||
- Update to gnome-browser-connector-42.1
|
||||
Resolves: #2209628
|
||||
|
||||
* Mon Jan 25 2021 Florian Müllner <fmuellner@redhat.com> - 10.1-7
|
||||
- Disable updates support
|
||||
Resolves: #1802105
|
||||
|
Loading…
Reference in New Issue
Block a user