use an existing icon
This commit is contained in:
parent
ec9fd4381b
commit
6d5cda13fd
10
cheese.spec
10
cheese.spec
@ -1,13 +1,15 @@
|
|||||||
Name: cheese
|
Name: cheese
|
||||||
Version: 2.29.92
|
Version: 2.29.92
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Application for taking pictures and movies from a webcam
|
Summary: Application for taking pictures and movies from a webcam
|
||||||
|
|
||||||
Group: Amusements/Graphics
|
Group: Amusements/Graphics
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://projects.gnome.org/cheese/
|
URL: http://projects.gnome.org/cheese/
|
||||||
|
#VCS: git:git://git.gnome.org/cheese
|
||||||
Source0: http://download.gnome.org/sources/cheese/2.29/%{name}-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/cheese/2.29/%{name}-%{version}.tar.bz2
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
# https://bugzilla.gnome.org/show_bug.cgi?id=613067
|
||||||
|
Patch0: no-webcam.patch
|
||||||
|
|
||||||
BuildRequires: gtk2-devel >= 2.19.1
|
BuildRequires: gtk2-devel >= 2.19.1
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
@ -61,6 +63,7 @@ for writing applications that require a webcam display widget.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .no-webcam
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
@ -164,6 +167,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/cheese-gtk.pc
|
%{_libdir}/pkgconfig/cheese-gtk.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 16 2010 Matthias Clasen <mclasen@redhat.com> 2.29.92-2
|
||||||
|
- Use an existing icon
|
||||||
|
|
||||||
* Tue Mar 09 2010 Bastien Nocera <bnocera@redhat.com> 2.29.92-1
|
* Tue Mar 09 2010 Bastien Nocera <bnocera@redhat.com> 2.29.92-1
|
||||||
- Update to 2.29.92
|
- Update to 2.29.92
|
||||||
|
|
||||||
|
14
no-webcam.patch
Normal file
14
no-webcam.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up cheese-2.29.92/libcheese/cheese-widget.c.no-webcam cheese-2.29.92/libcheese/cheese-widget.c
|
||||||
|
--- cheese-2.29.92/libcheese/cheese-widget.c.no-webcam 2010-03-16 13:51:03.281478874 -0400
|
||||||
|
+++ cheese-2.29.92/libcheese/cheese-widget.c 2010-03-16 13:51:07.649806018 -0400
|
||||||
|
@@ -75,8 +75,8 @@ cheese_widget_load_pixbuf (GtkWidget *w
|
||||||
|
theme = gtk_icon_theme_get_for_screen (gtk_widget_get_screen (widget));
|
||||||
|
|
||||||
|
/* FIXME special case "no-webcam" and actually use the icon_name */
|
||||||
|
- pixbuf = gtk_icon_theme_load_icon (theme, "error",
|
||||||
|
- size, 0, error);
|
||||||
|
+ pixbuf = gtk_icon_theme_load_icon (theme, "dialog-error",
|
||||||
|
+ size, GTK_ICON_LOOKUP_USE_BUILTIN | GTK_ICON_LOOKUP_FORCE_SIZE, error);
|
||||||
|
return pixbuf;
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in New Issue
Block a user