Fix missing images on buttons, also fixes the "Gtk-WARNING **: Attempting to
add a widget with type GtkImage to a GtkButton ..." warnings (gnome#677543) - Fix cheese crashing when started on machines with v4l2 radio or vbi devices (rhbz#810429, gnome#677544)
This commit is contained in:
parent
79f231d22f
commit
4c3b6761de
@ -0,0 +1,50 @@
|
|||||||
|
From 8a707dacf8615f88615a53ffe6eeb1ad65d94967 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Hans de Goede <hdegoede@redhat.com>
|
||||||
|
Date: Wed, 6 Jun 2012 11:23:47 +0200
|
||||||
|
Subject: [PATCH 3/4] main-window-ui: Fix images missing from effect buttons
|
||||||
|
|
||||||
|
Commit 4cb11731e62b51c684993e43000c933ea97785c2 fixed the images missing from
|
||||||
|
the photo / video / burst buttons, but the same problem also affects the
|
||||||
|
previous effects-page, effects, next effects-page buttons. This patch fixes
|
||||||
|
them too.
|
||||||
|
|
||||||
|
Note that unlike the commit message of commit 4cb11731 suggest this
|
||||||
|
not only fixes the printing of warnings to the console, it also fixes
|
||||||
|
the pixmaps actually missing from the buttons.
|
||||||
|
|
||||||
|
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||||
|
---
|
||||||
|
data/cheese-main-window.ui | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/data/cheese-main-window.ui b/data/cheese-main-window.ui
|
||||||
|
index bdc84c5..b0760bd 100644
|
||||||
|
--- a/data/cheese-main-window.ui
|
||||||
|
+++ b/data/cheese-main-window.ui
|
||||||
|
@@ -126,6 +126,7 @@
|
||||||
|
<property name="column-spacing">0</property>
|
||||||
|
<child>
|
||||||
|
<object class="GtkButton" id="effects_prev_page_button">
|
||||||
|
+ <property name="use-action-appearance">False</property>
|
||||||
|
<property name="related-action">effects_page_prev</property>
|
||||||
|
<property name="width-request">32</property>
|
||||||
|
<property name="relief">GTK_RELIEF_NONE</property>
|
||||||
|
@@ -141,6 +142,7 @@
|
||||||
|
<object class="GtkToggleButton" id="effects_toggle_button">
|
||||||
|
<property name="vexpand">False</property>
|
||||||
|
<property name="hexpand">False</property>
|
||||||
|
+ <property name="use-action-appearance">False</property>
|
||||||
|
<property name="related-action">effects_toggle</property>
|
||||||
|
<property name="tooltip_text" translatable="yes">Effects</property>
|
||||||
|
<child>
|
||||||
|
@@ -165,6 +167,7 @@
|
||||||
|
</child>
|
||||||
|
<child>
|
||||||
|
<object class="GtkButton" id="effects_next_page_button">
|
||||||
|
+ <property name="use-action-appearance">False</property>
|
||||||
|
<property name="related-action">effects_page_next</property>
|
||||||
|
<property name="width-request">32</property>
|
||||||
|
<property name="relief">GTK_RELIEF_NONE</property>
|
||||||
|
--
|
||||||
|
1.7.10.2
|
||||||
|
|
@ -0,0 +1,35 @@
|
|||||||
|
From ab319f83cd02e1a75c4d546deaefb27da70b51e6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Hans de Goede <hdegoede@redhat.com>
|
||||||
|
Date: Tue, 5 Jun 2012 14:54:13 +0200
|
||||||
|
Subject: [PATCH 4/4] camera-device-monitor: Don't add NULL devices to the
|
||||||
|
camera list
|
||||||
|
|
||||||
|
cheese_camera_device_monitor_set_up_device() will return NULL for non
|
||||||
|
video devices (ie vbi & radio devices). Emitting the added signal with
|
||||||
|
such a NULL device, causes it to get added to the camera list, which later
|
||||||
|
on causes cheese to crash.
|
||||||
|
|
||||||
|
This patch fixes this by not emitting the added signal for non camera devices.
|
||||||
|
|
||||||
|
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||||
|
---
|
||||||
|
libcheese/cheese-camera-device-monitor.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/libcheese/cheese-camera-device-monitor.c b/libcheese/cheese-camera-device-monitor.c
|
||||||
|
index d8b5a10..aa723c7 100644
|
||||||
|
--- a/libcheese/cheese-camera-device-monitor.c
|
||||||
|
+++ b/libcheese/cheese-camera-device-monitor.c
|
||||||
|
@@ -214,7 +214,8 @@ cheese_camera_device_monitor_added (CheeseCameraDeviceMonitor *monitor,
|
||||||
|
GUdevDevice *udevice)
|
||||||
|
{
|
||||||
|
CheeseCameraDevice *device = cheese_camera_device_monitor_set_up_device (udevice);
|
||||||
|
- g_signal_emit (monitor, monitor_signals[ADDED], 0, device);
|
||||||
|
+ if (device)
|
||||||
|
+ g_signal_emit (monitor, monitor_signals[ADDED], 0, device);
|
||||||
|
}
|
||||||
|
|
||||||
|
/*
|
||||||
|
--
|
||||||
|
1.7.10.2
|
||||||
|
|
14
cheese.spec
14
cheese.spec
@ -1,7 +1,7 @@
|
|||||||
Name: cheese
|
Name: cheese
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 3.5.1
|
Version: 3.5.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Application for taking pictures and movies from a webcam
|
Summary: Application for taking pictures and movies from a webcam
|
||||||
|
|
||||||
Group: Amusements/Graphics
|
Group: Amusements/Graphics
|
||||||
@ -9,6 +9,10 @@ License: GPLv2+
|
|||||||
URL: http://projects.gnome.org/cheese/
|
URL: http://projects.gnome.org/cheese/
|
||||||
#VCS: git:git://git.gnome.org/cheese
|
#VCS: git:git://git.gnome.org/cheese
|
||||||
Source0: http://download.gnome.org/sources/cheese/3.5/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/cheese/3.5/%{name}-%{version}.tar.xz
|
||||||
|
# https://bugzilla.gnome.org/show_bug.cgi?id=677543
|
||||||
|
Patch3: 0003-main-window-ui-Fix-images-missing-from-effect-button.patch
|
||||||
|
# https://bugzilla.gnome.org/show_bug.cgi?id=677544
|
||||||
|
Patch4: 0004-camera-device-monitor-Don-t-add-NULL-devices-to-the-.patch
|
||||||
|
|
||||||
BuildRequires: gtk3-devel >= 3.0.0
|
BuildRequires: gtk3-devel >= 3.0.0
|
||||||
BuildRequires: gstreamer-devel >= 0.10.23
|
BuildRequires: gstreamer-devel >= 0.10.23
|
||||||
@ -66,6 +70,8 @@ for writing applications that require a webcam display widget.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
@ -140,6 +146,12 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/gir-1.0/Cheese-3.0.gir
|
%{_datadir}/gir-1.0/Cheese-3.0.gir
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 5 2012 Hans de Goede <hdegoede@redhat.com> - 2:3.5.1-2
|
||||||
|
- Fix missing images on buttons, also fixes the "Gtk-WARNING **: Attempting to
|
||||||
|
add a widget with type GtkImage to a GtkButton ..." warnings (gnome#677543)
|
||||||
|
- Fix cheese crashing when started on machines with v4l2 radio or vbi devices
|
||||||
|
(rhbz#810429, gnome#677544)
|
||||||
|
|
||||||
* Sun May 06 2012 Kalev Lember <kalevlember@gmail.com> - 2:3.5.1-1
|
* Sun May 06 2012 Kalev Lember <kalevlember@gmail.com> - 2:3.5.1-1
|
||||||
- Update to 3.5.1
|
- Update to 3.5.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user