09820226ae
Rebase on upstream commit 32611aea6543 See $ cd SELinuxProject/selinux $ git log --pretty=oneline checkpolicy-3.2..32611aea6543 -- checkpolicy
50 lines
1.7 KiB
Diff
50 lines
1.7 KiB
Diff
From 02678b9d40f7de5cae1840f3d7ceedf1499c84a8 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Christian=20G=C3=B6ttsche?= <cgzones@googlemail.com>
|
|
Date: Tue, 6 Jul 2021 19:54:22 +0200
|
|
Subject: [PATCH] checkpolicy: drop -pipe compile option
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
The compiler option -pipe does not affect the generated code; it affects
|
|
whether the compiler uses temporary files or pipes. As the benefit might
|
|
vary from system to system usually its up to the packager or build
|
|
framework to set it.
|
|
Also these are the only places where the flag is used.
|
|
|
|
Signed-off-by: Christian Göttsche <cgzones@googlemail.com>
|
|
---
|
|
checkpolicy/Makefile | 2 +-
|
|
checkpolicy/test/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/checkpolicy/Makefile b/checkpolicy/Makefile
|
|
index be63c0182682..f9e1fc7cecd4 100644
|
|
--- a/checkpolicy/Makefile
|
|
+++ b/checkpolicy/Makefile
|
|
@@ -10,7 +10,7 @@ TARGETS = checkpolicy checkmodule
|
|
LEX = flex
|
|
YACC = bison -y
|
|
|
|
-CFLAGS ?= -g -Wall -Werror -Wshadow -O2 -pipe -fno-strict-aliasing
|
|
+CFLAGS ?= -g -Wall -Werror -Wshadow -O2 -fno-strict-aliasing
|
|
|
|
# If no specific libsepol.a is specified, fall back on LDFLAGS search path
|
|
# Otherwise, as $(LIBSEPOLA) already appears in the dependencies, there
|
|
diff --git a/checkpolicy/test/Makefile b/checkpolicy/test/Makefile
|
|
index e2a332b5a079..8e5d16b3c5f0 100644
|
|
--- a/checkpolicy/test/Makefile
|
|
+++ b/checkpolicy/test/Makefile
|
|
@@ -1,7 +1,7 @@
|
|
#
|
|
# Makefile for building the dispol program
|
|
#
|
|
-CFLAGS ?= -g -Wall -W -Werror -O2 -pipe
|
|
+CFLAGS ?= -g -Wall -W -Werror -O2
|
|
|
|
# If no specific libsepol.a is specified, fall back on LDFLAGS search path
|
|
# Otherwise, as $(LIBSEPOLA) already appears in the dependencies, there
|
|
--
|
|
2.32.0
|
|
|