diff --git a/.cvsignore b/.cvsignore
index 2b3f2bb..513fba8 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -73,3 +73,4 @@ checkpolicy-2.0.18.tgz
 checkpolicy-2.0.19.tgz
 checkpolicy-2.0.20.tgz
 checkpolicy-2.0.21.tgz
+checkpolicy-2.0.22.tgz
diff --git a/checkpolicy-rhat.patch b/checkpolicy-rhat.patch
index 13ff43c..135b82a 100644
--- a/checkpolicy-rhat.patch
+++ b/checkpolicy-rhat.patch
@@ -1,13 +1,12 @@
-diff --exclude-from=exclude -N -u -r nsacheckpolicy/module_compiler.c checkpolicy-2.0.18/module_compiler.c
---- nsacheckpolicy/module_compiler.c	2008-10-14 13:57:54.000000000 -0400
-+++ checkpolicy-2.0.18/module_compiler.c	2008-10-28 10:10:03.000000000 -0400
-@@ -904,8 +904,7 @@
- 			return -1;
- 		}
- 	case -2:{
--			yyerror("duplicate declaration of type/attribute");
--			return -1;
-+			return 0;
- 		}
- 	case -1:{
- 			yyerror("could not require type/attribute here");
+diff --exclude-from=exclude -N -u -r nsacheckpolicy/policy_parse.y checkpolicy-2.0.22/policy_parse.y
+--- nsacheckpolicy/policy_parse.y	2010-05-19 14:45:51.000000000 -0400
++++ checkpolicy-2.0.22/policy_parse.y	2010-06-16 08:08:37.000000000 -0400
+@@ -755,6 +755,8 @@
+                         ;
+ version_identifier      : VERSION_IDENTIFIER
+                         { if (insert_id(yytext,0)) return -1; }
++			| number
++                        { if (insert_id(yytext,0)) return -1; }
+                         | ipv4_addr_def /* version can look like ipv4 address */
+                         ;
+ avrules_block           : avrule_decls avrule_user_defs
diff --git a/checkpolicy.spec b/checkpolicy.spec
index 622f2ff..e7ed3c3 100644
--- a/checkpolicy.spec
+++ b/checkpolicy.spec
@@ -1,7 +1,7 @@
 %define libsepolver 2.0.39-1
 Summary: SELinux policy compiler
 Name: checkpolicy
-Version: 2.0.21
+Version: 2.0.22
 Release: 1%{?dist}
 License: GPLv2
 Group: Development/System
@@ -55,6 +55,14 @@ rm -rf ${RPM_BUILD_ROOT}
 %{_bindir}/sedispol
 
 %changelog
+* Mon Jun 16 2010 Dan Walsh <dwalsh@redhat.com> - 2.0.22-1
+- Latest update from NSA
+	* Update checkmodule man page and usage by Daniel Walsh and Steve Lawrence
+- Allow policy version to be one number
+
+* Mon May 3 2010 Dan Walsh <dwalsh@redhat.com> - 2.0.21-2
+- Fix checkmodule man page and usage statements
+
 * Tue Nov 1 2009 Dan Walsh <dwalsh@redhat.com> - 2.0.21-1
 - Latest update from NSA
 	* Add support for building Xen policies from Paul Nuzzi.
diff --git a/sources b/sources
index 397517f..8a4631d 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-c95a8fd53be09715f6652cc93fcd646d  checkpolicy-2.0.21.tgz
+b144f4049d87a32027e29d11a144427b  checkpolicy-2.0.22.tgz