Allow ~ in a filename
This commit is contained in:
parent
1e7f3c93f0
commit
e9ff6dfd95
@ -1,3 +1,16 @@
|
|||||||
|
diff --git a/checkpolicy/policy_scan.l b/checkpolicy/policy_scan.l
|
||||||
|
index 5ee27f8..b4b9066 100644
|
||||||
|
--- a/checkpolicy/policy_scan.l
|
||||||
|
+++ b/checkpolicy/policy_scan.l
|
||||||
|
@@ -222,7 +222,7 @@ POLICYCAP { return(POLICYCAP); }
|
||||||
|
permissive |
|
||||||
|
PERMISSIVE { return(PERMISSIVE); }
|
||||||
|
"/"({alnum}|[_\.\-/])* { return(PATH); }
|
||||||
|
-\"({alnum}|[_\.\-])+\" { return(FILENAME); }
|
||||||
|
+\"({alnum}|[_\.\-\~])+\" { return(FILENAME); }
|
||||||
|
{letter}({alnum}|[_\-])*([\.]?({alnum}|[_\-]))* { return(IDENTIFIER); }
|
||||||
|
{alnum}*{letter}{alnum}* { return(FILESYSTEM); }
|
||||||
|
{digit}+|0x{hexval}+ { return(NUMBER); }
|
||||||
diff --git a/checkpolicy/test/Makefile b/checkpolicy/test/Makefile
|
diff --git a/checkpolicy/test/Makefile b/checkpolicy/test/Makefile
|
||||||
index 65cf901..0731e89 100644
|
index 65cf901..0731e89 100644
|
||||||
--- a/checkpolicy/test/Makefile
|
--- a/checkpolicy/test/Makefile
|
||||||
|
@ -3,7 +3,7 @@
|
|||||||
Summary: SELinux policy compiler
|
Summary: SELinux policy compiler
|
||||||
Name: checkpolicy
|
Name: checkpolicy
|
||||||
Version: 2.1.6
|
Version: 2.1.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
||||||
@ -56,6 +56,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_bindir}/sedispol
|
%{_bindir}/sedispol
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 14 2011 Dan Walsh <dwalsh@redhat.com> - 2.1.6-2
|
||||||
|
- Allow ~ in a filename
|
||||||
|
|
||||||
* Fri Nov 4 2011 Dan Walsh <dwalsh@redhat.com> - 2.1.6-1
|
* Fri Nov 4 2011 Dan Walsh <dwalsh@redhat.com> - 2.1.6-1
|
||||||
- Upgrade to upstream
|
- Upgrade to upstream
|
||||||
* Revert "checkpolicy: Redo filename/filesystem syntax to support filename trans rules"
|
* Revert "checkpolicy: Redo filename/filesystem syntax to support filename trans rules"
|
||||||
|
Loading…
Reference in New Issue
Block a user