Update to 0.12.0.

This commit is contained in:
Jerry James 2018-01-29 21:00:56 -07:00
parent 93d9ef3bee
commit eaa27a7f7b
4 changed files with 22 additions and 24 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/check-0.10.0.tar.gz
/0.10.0.tar.gz
/0.11.0.tar.gz
/check-0.12.0.tar.gz

View File

@ -1,17 +1,17 @@
--- tests/check_check_master.c.orig 2016-12-17 16:35:40.000000000 -0700
+++ tests/check_check_master.c 2016-12-23 11:54:11.764383535 -0700
@@ -191,7 +191,7 @@ static master_test_t master_tests[] = {
{ "Simple Tests", "test_ck_assert_ldouble_ge", CK_FAILURE, "Assertion 'x >= y' failed: x == 2.5, y == 3" },
{ "Simple Tests", "test_ck_assert_ldouble_ge_with_mod", CK_FAILURE, "Assertion '2%d >= 3%f' failed: 2%d == 0, 3%f == 1" },
{ "Simple Tests", "test_ck_assert_ldouble_with_expr", CK_PASS, "Passed" },
- { "Simple Tests", "test_ck_assert_ldouble_eq_tol", CK_FAILURE, "Assertion 'fabsl(y - x) < t' failed: x == 0.001, y == 0.002, t == 0.001" },
+ { "Simple Tests", "test_ck_assert_ldouble_eq_tol", CK_FAILURE, "Assertion 'fabsl(y - x) < t' failed: x == 0.001, y == 0.002, t == 0.0009" },
{ "Simple Tests", "test_ck_assert_ldouble_eq_tol_with_mod", CK_FAILURE, "Assertion 'fabsl(2%f - 3%d) < 2%p' failed: 3%d == 1, 2%f == 0, 2%p == 0" },
{ "Simple Tests", "test_ck_assert_ldouble_ne_tol", CK_FAILURE, "Assertion 'fabsl(y - x) >= t' failed: x == 0.001, y == 0.002, t == 0.01" },
{ "Simple Tests", "test_ck_assert_ldouble_ne_tol_with_mod", CK_FAILURE, "Assertion 'fabsl(3%f - 3%d) >= 3%p' failed: 3%d == 1, 3%f == 1, 3%p == 1" },
--- tests/check_check_sub.c.orig 2016-12-17 16:35:40.000000000 -0700
+++ tests/check_check_sub.c 2016-12-23 11:53:46.643534215 -0700
@@ -1634,7 +1634,7 @@ START_TEST(test_ck_assert_ldouble_eq_tol
--- tests/check_check_master.c.orig 2018-01-29 20:33:55.033001412 -0700
+++ tests/check_check_master.c 2018-01-29 20:34:31.501879454 -0700
@@ -214,7 +214,7 @@ static master_test_t master_tests[] = {
{ "Simple Tests", "test_ck_assert_ldouble_ge", CK_FAILURE, CK_MSG_TEXT, "Assertion 'x >= y' failed: x == 2.5, y == 3" },
{ "Simple Tests", "test_ck_assert_ldouble_ge_with_mod", CK_FAILURE, CK_MSG_TEXT, "Assertion '2%d >= 3%f' failed: 2%d == 0, 3%f == 1" },
{ "Simple Tests", "test_ck_assert_ldouble_with_expr", CK_PASS, CK_MSG_TEXT, "Passed" },
- { "Simple Tests", "test_ck_assert_ldouble_eq_tol", CK_FAILURE, CK_MSG_TEXT, "Assertion 'fabsl(y - x) < t' failed: x == 0.001, y == 0.002, t == 0.001" },
+ { "Simple Tests", "test_ck_assert_ldouble_eq_tol", CK_FAILURE, CK_MSG_TEXT, "Assertion 'fabsl(y - x) < t' failed: x == 0.001, y == 0.002, t == 0.0009" },
{ "Simple Tests", "test_ck_assert_ldouble_eq_tol_with_mod", CK_FAILURE, CK_MSG_TEXT, "Assertion 'fabsl(2%f - 3%d) < 2%p' failed: 3%d == 1, 2%f == 0, 2%p == 0" },
{ "Simple Tests", "test_ck_assert_ldouble_ne_tol", CK_FAILURE, CK_MSG_TEXT, "Assertion 'fabsl(y - x) >= t' failed: x == 0.001, y == 0.002, t == 0.01" },
{ "Simple Tests", "test_ck_assert_ldouble_ne_tol_with_mod", CK_FAILURE, CK_MSG_TEXT, "Assertion 'fabsl(3%f - 3%d) >= 3%p' failed: 3%d == 1, 3%f == 1, 3%p == 1" },
--- tests/check_check_sub.c.orig 2017-10-20 06:44:10.000000000 -0600
+++ tests/check_check_sub.c 2018-01-29 20:33:55.034001409 -0700
@@ -1812,7 +1812,7 @@ START_TEST(test_ck_assert_ldouble_eq_tol
y*=10.0l;
t*=10.0l;
ck_assert_ldouble_eq_tol(x, y, t);

View File

@ -1,8 +1,8 @@
Name: check
Version: 0.11.0
Release: 4%{?dist}
Version: 0.12.0
Release: 1%{?dist}
Summary: A unit test framework for C
Source0: https://github.com/libcheck/%{name}/archive/%{version}.tar.gz
Source0: https://github.com/libcheck/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
License: LGPLv2+
URL: http://libcheck.github.io/check/
# Only needed for autotools in Fedora
@ -60,7 +60,6 @@ programs suitable for use with the Check unit test framework.
# Fix detection of various time-related function declarations
sed -e '/DECLS(\[a/s|)|,,,[AC_INCLUDES_DEFAULT\n[#include <time.h>\n #include <sys/time.h>]]&|' \
-e '/DECLS(\[a/s/\(getline\)\( gettimeofday\)/\1,\2/' \
-i configure.ac
# Get rid of version control files
@ -69,9 +68,6 @@ find . -name .cvsignore -exec rm {} +
# Regenerate configure due to patch 0
autoreconf -ivf
# Fix a broken prototype
sed -i.orig 's/tcase_name()/tcase_name(void)/' src/check.h.in
%build
%configure
@ -88,8 +84,6 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
rm -f doc/example/.cvsignore
%check
export LD_LIBRARY_PATH=$PWD/src/.libs
@ -141,6 +135,9 @@ fi
%{_mandir}/man1/checkmk.1*
%changelog
* Mon Jan 29 2018 Jerry James <loganjerry@gmail.com> - 0.12.0-1
- Update to 0.12.0
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (0.11.0.tar.gz) = 829adee2a5793dda6ac88162e355268019dd82e7a8ad95f1287bd262c3a7764425fba6a8347f1aeebdad642a972043b70aa59d54c87b3c46e1b5b569290dc359
SHA512 (check-0.12.0.tar.gz) = f7b6452b69f999a90e86a8582d980c0c1b74ba5629ee34455724463ba62bfe3501ad0415aa771170f5c638a7a253f123bf87cbef25aadc6569a7a3a4d10fce90