Add -volatile patch to fix test failure.
Update time-related configure fix.
This commit is contained in:
parent
f9eec9c12b
commit
b80917974b
11
check-0.9.13-volatile.patch
Normal file
11
check-0.9.13-volatile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./src/check_run.c.orig 2014-05-29 21:58:32.000000000 -0600
|
||||
+++ ./src/check_run.c 2014-06-09 09:32:10.644294320 -0600
|
||||
@@ -230,7 +230,7 @@ static int srunner_run_unchecked_setup(S
|
||||
TestResult *tr;
|
||||
List *l;
|
||||
Fixture *f;
|
||||
- int rval = 1;
|
||||
+ volatile int rval = 1;
|
||||
|
||||
set_fork_status(CK_NOFORK);
|
||||
|
11
check.spec
11
check.spec
@ -7,7 +7,9 @@ Group: Development/Tools
|
||||
License: LGPLv2+
|
||||
URL: http://check.sourceforge.net/
|
||||
# Only needed for autotools in Fedora 21+
|
||||
Patch0: check-0.9.11-info-in-builddir.patch
|
||||
Patch0: %{name}-0.9.11-info-in-builddir.patch
|
||||
# Result variable might be clobbered by longjmp()
|
||||
Patch1: %{name}-0.9.13-volatile.patch
|
||||
BuildRequires: pkgconfig, libtool, autoconf, automake, subunit-devel
|
||||
BuildRequires: texinfo
|
||||
Requires(post): info
|
||||
@ -51,10 +53,11 @@ programs suitable for use with the Check unit test framework.
|
||||
%if 0%{?fedora} >= 21
|
||||
%patch0 -p1 -b .info-in-builddir
|
||||
%endif
|
||||
%patch1
|
||||
autoreconf -ivf
|
||||
|
||||
# Fix detection of various time-related function declarations
|
||||
sed -i '/"ac_cv_have_decl_clock_gettime"/iac_includes_default="$ac_includes_default\n#include <time.h>"' configure
|
||||
sed -i '/"ac_cv_have_decl_clock_gettime"/iac_includes_default="$ac_includes_default\n#include <time.h>\n#include <sys/time.h>"' configure
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -116,6 +119,10 @@ fi
|
||||
%{_mandir}/man1/checkmk.1*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 9 2014 Jerry James <loganjerry@gmail.com> - 0.9.13-2
|
||||
- Add -volatile patch to fix test failure
|
||||
- Update time-related configure fix
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.13-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user