0.9.5 for devel, license fix for all.
This commit is contained in:
parent
a37235b6bb
commit
b3fc97ee26
12
check-0.9.5-fPIC.patch
Normal file
12
check-0.9.5-fPIC.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up check-0.9.5/configure.BAD check-0.9.5/configure
|
||||
--- check-0.9.5/configure.BAD 2007-08-02 14:41:44.000000000 -0400
|
||||
+++ check-0.9.5/configure 2007-08-02 14:41:59.000000000 -0400
|
||||
@@ -18718,7 +18718,7 @@ LIBTOOL='$(SHELL) $(top_builddir)/libtoo
|
||||
|
||||
|
||||
if test -n "$GCC"; then
|
||||
- CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
|
||||
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
|
||||
fi
|
||||
for ac_prog in gcov
|
||||
do
|
65
check.spec
65
check.spec
@ -1,14 +1,16 @@
|
||||
Name: check
|
||||
Version: 0.9.3
|
||||
Release: 5%{?dist}
|
||||
Version: 0.9.5
|
||||
Release: 1%{?dist}
|
||||
Summary: A unit test framework for C
|
||||
Source0: http://download.sourceforge.net/check/%{name}-%{version}.tar.gz
|
||||
Group: Development/Tools
|
||||
License: LGPL
|
||||
License: LGPLv2+
|
||||
URL: http://check.sourceforge.net/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: docbook-utils
|
||||
Patch0: check-0.9.2-fPIC.patch
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
Patch0: check-0.9.5-fPIC.patch
|
||||
|
||||
%description
|
||||
Check is a unit test framework for C. It features a simple interface for
|
||||
@ -20,40 +22,77 @@ The output from unit tests can be used within source code editors and IDEs.
|
||||
%package devel
|
||||
Summary: Libraries and headers for developing programs with check
|
||||
Group: Development/Libraries
|
||||
Provides: %{name} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Check is a unit test framework for C. It features a simple interface for
|
||||
defining unit tests, putting little in the way of the developer. Tests
|
||||
are run in a separate address space, so Check can catch both assertion
|
||||
failures and code errors that cause segmentation faults or other signals.
|
||||
The output from unit tests can be used within source code editors and IDEs.
|
||||
Libraries and headers for developing programs with check
|
||||
|
||||
%package static
|
||||
Summary: Static libraries of check
|
||||
Group: Development/Libraries
|
||||
|
||||
%description static
|
||||
Static libraries of check.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# check prefers to be static linked, do not remove
|
||||
%configure
|
||||
make
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
# redundant files
|
||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/COPYING.LESSER
|
||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/ChangeLog*
|
||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/NEWS
|
||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
|
||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/SVNChangeLog
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
|
||||
%{_libdir}/libcheck.so.*
|
||||
%{_infodir}/check*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/check.h
|
||||
# check prefers to be static linked, do not remove
|
||||
%{_libdir}/libcheck.a
|
||||
%{_defaultdocdir}/%{name}/example/
|
||||
%{_libdir}/libcheck.so
|
||||
%{_libdir}/pkgconfig/check.pc
|
||||
%{_datadir}/doc/%{name}-%{version}
|
||||
%{_datadir}/aclocal/check.m4
|
||||
|
||||
#check used to be static only, hence this.
|
||||
%files static
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libcheck.a
|
||||
|
||||
%changelog
|
||||
* Thu Aug 2 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.5-1
|
||||
- 0.9.5 bump
|
||||
|
||||
* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3-5
|
||||
- rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user