- Fix unowned directory (bz 473635)
- Drop unnecessary BuildRequires - Replace patches with addition of -fPIC to CFLAGS in the spec file - Add some more documentation files
This commit is contained in:
parent
bb2f5e49d9
commit
b111f2ebcf
@ -1 +1 @@
|
|||||||
check-0.9.3.tar.gz
|
check-0.9.5.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- check-0.9.2/configure.BAD 2005-08-14 16:01:27.000000000 -0500
|
|
||||||
+++ check-0.9.2/configure 2005-08-14 16:01:41.000000000 -0500
|
|
||||||
@@ -1181,7 +1181,7 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
if test -n "$GCC"; then
|
|
||||||
- CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
|
|
||||||
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
|
|
||||||
fi
|
|
||||||
# Extract the first word of "docbook2html", so it can be a program name with args.
|
|
||||||
set dummy docbook2html; ac_word=$2
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up check-0.9.5/configure.BAD check-0.9.5/configure
|
|
||||||
--- check-0.9.5/configure.BAD 2007-08-02 14:41:44.000000000 -0400
|
|
||||||
+++ check-0.9.5/configure 2007-08-02 14:41:59.000000000 -0400
|
|
||||||
@@ -18718,7 +18718,7 @@ LIBTOOL='$(SHELL) $(top_builddir)/libtoo
|
|
||||||
|
|
||||||
|
|
||||||
if test -n "$GCC"; then
|
|
||||||
- CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
|
|
||||||
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
|
|
||||||
fi
|
|
||||||
for ac_prog in gcov
|
|
||||||
do
|
|
53
check.spec
53
check.spec
@ -1,16 +1,14 @@
|
|||||||
Name: check
|
Name: check
|
||||||
Version: 0.9.5
|
Version: 0.9.5
|
||||||
Release: 2%{?dist}.1
|
Release: 3%{?dist}
|
||||||
Summary: A unit test framework for C
|
Summary: A unit test framework for C
|
||||||
Source0: http://download.sourceforge.net/check/%{name}-%{version}.tar.gz
|
Source0: http://download.sourceforge.net/check/%{name}-%{version}.tar.gz
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://check.sourceforge.net/
|
URL: http://check.sourceforge.net/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: docbook-utils
|
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
Patch0: check-0.9.5-fPIC.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Check is a unit test framework for C. It features a simple interface for
|
Check is a unit test framework for C. It features a simple interface for
|
||||||
@ -20,27 +18,26 @@ failures and code errors that cause segmentation faults or other signals.
|
|||||||
The output from unit tests can be used within source code editors and IDEs.
|
The output from unit tests can be used within source code editors and IDEs.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Libraries and headers for developing programs with check
|
Summary: Libraries and headers for developing programs with check
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: pkgconfig
|
Requires: pkgconfig
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
Libraries and headers for developing programs with check
|
Libraries and headers for developing programs with check
|
||||||
|
|
||||||
%package static
|
%package static
|
||||||
Summary: Static libraries of check
|
Summary: Static libraries of check
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
|
|
||||||
%description static
|
%description static
|
||||||
Static libraries of check.
|
Static libraries of check.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure CFLAGS="${RPM_OPT_FLAGS} -fPIC"
|
||||||
make
|
make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -48,13 +45,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
|
rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
|
rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}
|
||||||
# redundant files
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/COPYING.LESSER
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/ChangeLog*
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/NEWS
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/SVNChangeLog
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -72,17 +63,17 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
|
%doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
|
||||||
|
%doc THANKS TODO
|
||||||
%{_libdir}/libcheck.so.*
|
%{_libdir}/libcheck.so.*
|
||||||
%{_infodir}/check*
|
%{_infodir}/check*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
%doc COPYING.LESSER doc/example
|
||||||
%{_includedir}/check.h
|
%{_includedir}/check.h
|
||||||
%{_defaultdocdir}/%{name}/example/
|
|
||||||
%{_libdir}/libcheck.so
|
%{_libdir}/libcheck.so
|
||||||
%{_libdir}/pkgconfig/check.pc
|
%{_libdir}/pkgconfig/check.pc
|
||||||
%{_datadir}/doc/%{name}-%{version}
|
|
||||||
%{_datadir}/aclocal/check.m4
|
%{_datadir}/aclocal/check.m4
|
||||||
|
|
||||||
#check used to be static only, hence this.
|
#check used to be static only, hence this.
|
||||||
@ -91,6 +82,12 @@ fi
|
|||||||
%{_libdir}/libcheck.a
|
%{_libdir}/libcheck.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 1 2008 Jerry James <loganjerry@gmail.com> - 0.9.5-3
|
||||||
|
- Fix unowned directory (bz 473635)
|
||||||
|
- Drop unnecessary BuildRequires
|
||||||
|
- Replace patches with addition of -fPIC to CFLAGS in the spec file
|
||||||
|
- Add some more documentation files
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.5-2.1
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.5-2.1
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user