Version 0.15.2. Drop upstreamed -fail-macros patch.
This commit is contained in:
parent
dcf59af98a
commit
585eed1ed2
@ -1,32 +0,0 @@
|
|||||||
--- check-0.15.1/src/check.h.in.orig 2020-07-22 08:19:48.000000000 -0600
|
|
||||||
+++ check-0.15.1/src/check.h.in 2020-08-03 11:41:08.131406149 -0600
|
|
||||||
@@ -466,7 +466,10 @@ static void __testname ## _fn (int _i CK
|
|
||||||
*
|
|
||||||
* This call is deprecated.
|
|
||||||
*/
|
|
||||||
-#define fail_unless ck_assert_msg
|
|
||||||
+#define fail_unless(expr, ...) \
|
|
||||||
+ (expr) ? \
|
|
||||||
+ _mark_point(__FILE__, __LINE__) : \
|
|
||||||
+ _ck_assert_failed(__FILE__, __LINE__, "Assertion '"#expr"' failed" , ## __VA_ARGS__, NULL)
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Fail the test case if expr is false
|
|
||||||
@@ -480,7 +483,7 @@ static void __testname ## _fn (int _i CK
|
|
||||||
*/
|
|
||||||
#define fail_if(expr, ...)\
|
|
||||||
(expr) ? \
|
|
||||||
- _ck_assert_failed(__FILE__, __LINE__, "Failure '"#expr"' occurred" , ## __VA_ARGS__) \
|
|
||||||
+ _ck_assert_failed(__FILE__, __LINE__, "Failure '"#expr"' occurred" , ## __VA_ARGS__, NULL) \
|
|
||||||
: _mark_point(__FILE__, __LINE__)
|
|
||||||
|
|
||||||
/*
|
|
||||||
@@ -488,7 +491,7 @@ static void __testname ## _fn (int _i CK
|
|
||||||
*
|
|
||||||
* This call is deprecated.
|
|
||||||
*/
|
|
||||||
-#define fail ck_abort_msg
|
|
||||||
+#define fail(...) _ck_assert_failed(__FILE__, __LINE__, "Failed" , ## __VA_ARGS__, NULL)
|
|
||||||
|
|
||||||
/*
|
|
||||||
* This is called whenever an assertion fails.
|
|
12
check.spec
12
check.spec
@ -1,6 +1,6 @@
|
|||||||
Name: check
|
Name: check
|
||||||
Version: 0.15.1
|
Version: 0.15.2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A unit test framework for C
|
Summary: A unit test framework for C
|
||||||
Source0: https://github.com/libcheck/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/libcheck/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
@ -9,9 +9,6 @@ URL: http://libcheck.github.io/check/
|
|||||||
Patch0: %{name}-0.11.0-info-in-builddir.patch
|
Patch0: %{name}-0.11.0-info-in-builddir.patch
|
||||||
# Fix test failures due to varying floating point behavior across platforms
|
# Fix test failures due to varying floating point behavior across platforms
|
||||||
Patch1: %{name}-0.11.0-fp.patch
|
Patch1: %{name}-0.11.0-fp.patch
|
||||||
# Add an extra NULL argument to the deprecated fail* macros
|
|
||||||
# https://github.com/libcheck/check/commit/82540c5428d3818b64d6a8aefb601e722520651f
|
|
||||||
Patch2: %{name}-0.15.1-fail-macros.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -57,7 +54,6 @@ programs suitable for use with the Check unit test framework.
|
|||||||
%patch0 -p1 -b .info-in-builddir
|
%patch0 -p1 -b .info-in-builddir
|
||||||
%endif
|
%endif
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
# Fix detection of various time-related function declarations
|
# Fix detection of various time-related function declarations
|
||||||
sed -e '/DECLS(\[a/s|)|,,,[AC_INCLUDES_DEFAULT\n[#include <time.h>\n #include <sys/time.h>]]&|' \
|
sed -e '/DECLS(\[a/s|)|,,,[AC_INCLUDES_DEFAULT\n[#include <time.h>\n #include <sys/time.h>]]&|' \
|
||||||
@ -143,6 +139,10 @@ cd -
|
|||||||
%{_mandir}/man1/checkmk.1*
|
%{_mandir}/man1/checkmk.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Aug 9 2020 Jerry James <loganjerry@gmail.com> - 0.15.2-1
|
||||||
|
- Version 0.15.2
|
||||||
|
- Drop upstreamed -fail-macros patch
|
||||||
|
|
||||||
* Mon Aug 3 2020 Jerry James <loganjerry@gmail.com> - 0.15.1-3
|
* Mon Aug 3 2020 Jerry James <loganjerry@gmail.com> - 0.15.1-3
|
||||||
- Add -fail-macros patch
|
- Add -fail-macros patch
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (check-0.15.1.tar.gz) = e8f9cf21797457b1c29f68792a53321a19ae0f5af51ad1c4c5bfc350ba60d474c90545782bccade56350ced992b26872b1ef2bd0628863691bb95009ddacd30e
|
SHA512 (check-0.15.2.tar.gz) = cf81ca63142f33779df2e3542e049b9034d30bc502a663a4379bbfe85c7ee8fd80ce382583e781651d99fe830895122dab5b6793f87425b571c3927f0ba3b60e
|
||||||
|
Loading…
Reference in New Issue
Block a user