Initial import of cglib
This commit is contained in:
parent
5cbd5b7260
commit
71d0e343ee
@ -0,0 +1 @@
|
|||||||
|
cglib-src-2.2.jar
|
17
cglib-build_xml.patch
Normal file
17
cglib-build_xml.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
--- cglib/build.xml.orig 2008-08-14 13:37:22.000000000 +0200
|
||||||
|
+++ cglib/build.xml 2008-08-14 13:35:51.000000000 +0200
|
||||||
|
@@ -124,14 +124,6 @@
|
||||||
|
<exclude name="samples/**" />
|
||||||
|
</jar>
|
||||||
|
|
||||||
|
- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpathref="compile.classpath"/>
|
||||||
|
- <jarjar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-nodep-${component.version}.jar" >
|
||||||
|
- <zipfileset dir="lib" includes="asm*.txt"/>
|
||||||
|
- <zipfileset src="lib/asm-3.1.jar" excludes="META-INF"/>
|
||||||
|
- <rule pattern="org.objectweb.asm.**" result="net.sf.cglib.asm.@1"/>
|
||||||
|
- <include name="**/*"/>
|
||||||
|
- <exclude name="samples/**"/>
|
||||||
|
- </jarjar>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<target depends="compile,javadoc" description="Create docs and source distribution" name="srcjar">
|
89
cglib.spec
Normal file
89
cglib.spec
Normal file
@ -0,0 +1,89 @@
|
|||||||
|
Name: cglib
|
||||||
|
Version: 2.2
|
||||||
|
Release: 5%{?dist}
|
||||||
|
Summary: Code Generation Library for Java
|
||||||
|
License: ASL 2.0
|
||||||
|
Group: Development/Tools
|
||||||
|
Url: http://cglib.sourceforge.net/
|
||||||
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-src-%{version}.jar
|
||||||
|
# Remove the repackaging step that includes other jars into the final thing
|
||||||
|
Patch0: %{name}-build_xml.patch
|
||||||
|
|
||||||
|
Requires: java >= 0:1.6.0
|
||||||
|
Requires: objectweb-asm
|
||||||
|
|
||||||
|
BuildRequires: ant
|
||||||
|
BuildRequires: jpackage-utils >= 0:1.5
|
||||||
|
BuildRequires: java-devel >= 0:1.6.0
|
||||||
|
BuildRequires: objectweb-asm
|
||||||
|
BuildArch: noarch
|
||||||
|
Requires(post): jpackage-utils
|
||||||
|
Requires(postun): jpackage-utils
|
||||||
|
|
||||||
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
|
%description
|
||||||
|
cglib is a powerful, high performance and quality code generation library
|
||||||
|
for Java. It is used to extend Java classes and implements interfaces
|
||||||
|
at runtime.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
Group: Documentation
|
||||||
|
%description javadoc
|
||||||
|
Documentation for the cglib code generation library.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -c %{name}-%{version}
|
||||||
|
rm lib/*.jar
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
export CLASSPATH=`build-classpath objectweb-asm`
|
||||||
|
ant jar javadoc
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
mkdir -p ${RPM_BUILD_ROOT}%{_javadocdir}/
|
||||||
|
cp -r docs ${RPM_BUILD_ROOT}%{_javadocdir}/%{name}-%{version}
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||||
|
cp -p dist/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}
|
||||||
|
ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
|
||||||
|
%add_to_maven_depmap net.sf.cglib %{name} %{version} JPP %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%post
|
||||||
|
%update_maven_depmap
|
||||||
|
|
||||||
|
%postun
|
||||||
|
%update_maven_depmap
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc LICENSE NOTICE
|
||||||
|
%{_javadir}/*.jar
|
||||||
|
%config(noreplace) %{_mavendepmapfragdir}/%{name}
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_javadocdir}/%{name}-%{version}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Dec 9 2008 Mary Ellen Foster <mefoster at gmail.com> - 2.2-5
|
||||||
|
- Add dist to version
|
||||||
|
- Fix BuildRoot to follow the latest guidelines
|
||||||
|
|
||||||
|
* Mon Nov 24 2008 Mary Ellen Foster <mefoster at gmail.com> - 2.2-4
|
||||||
|
- Add a comment explaining the patch
|
||||||
|
|
||||||
|
* Thu Nov 6 2008 Mary Ellen Foster <mefoster at gmail.com> - 2.2-3
|
||||||
|
- Flag Maven depmap as "config"
|
||||||
|
|
||||||
|
* Wed Nov 5 2008 Mary Ellen Foster <mefoster at gmail.com> - 2.2-2
|
||||||
|
- Explicitly require Java > 1.6 because it won't compile with gcj
|
||||||
|
- Fix cosmetic issues in spec file
|
||||||
|
|
||||||
|
* Tue Nov 4 2008 Mary Ellen Foster <mefoster at gmail.com> - 2.2-1
|
||||||
|
- Initial package (based on previous JPP version)
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
|||||||
|
cglib-2_2-5_fc10:devel:cglib-2.2-5.fc10.src.rpm:1258155327
|
Loading…
Reference in New Issue
Block a user