diff --git a/.gitignore b/.gitignore
index 6a71757..f3ea516 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
cglib-src-2.2.jar
+/cglib-src-3.0.jar
+/cglib-3.0.pom
diff --git a/cglib-2.2.pom b/cglib-2.2.pom
deleted file mode 100644
index f017fb8..0000000
--- a/cglib-2.2.pom
+++ /dev/null
@@ -1,38 +0,0 @@
-
-
- 4.0.0
- cglib
- cglib
- Code Generation Library
- 2.2
- http://cglib.sourceforge.net/
-
-
- ASF 2.0
- http://www.apache.org/licenses/LICENSE-2.0.txt
- repo
-
-
-
- http://cglib.cvs.sourceforge.net/cglib
-
-
-
- asm
- asm
- 3.1
-
-
- asm
- asm-util
- 3.1
- true
-
-
- ant
- ant
- 1.6.2
- true
-
-
-
diff --git a/cglib-44.patch b/cglib-44.patch
new file mode 100644
index 0000000..6a2806f
--- /dev/null
+++ b/cglib-44.patch
@@ -0,0 +1,11 @@
+--- src/proxy/net/sf/cglib/core/DebuggingClassWriter.java~ 2012-05-25 13:21:20.000000000 +0200
++++ src/proxy/net/sf/cglib/core/DebuggingClassWriter.java 2013-11-12 10:36:50.707147437 +0100
+@@ -46,7 +46,7 @@
+ }
+
+ public DebuggingClassWriter(int flags) {
+- super(flags, new ClassWriter(flags));
++ super(Opcodes.ASM4, new ClassWriter(flags));
+ }
+
+ public void visit(int version,
diff --git a/cglib-build_xml.patch b/cglib-build_xml.patch
deleted file mode 100644
index f3e591a..0000000
--- a/cglib-build_xml.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- cglib/build.xml.orig 2008-08-14 13:37:22.000000000 +0200
-+++ cglib/build.xml 2008-08-14 13:35:51.000000000 +0200
-@@ -124,14 +124,6 @@
-
-
-
--
--
--
--
--
--
--
--
-
-
-
diff --git a/cglib.spec b/cglib.spec
index bc59154..5ff3bba 100644
--- a/cglib.spec
+++ b/cglib.spec
@@ -1,6 +1,6 @@
Name: cglib
-Version: 2.2
-Release: 17%{?dist}
+Version: 3.0
+Release: 1%{?dist}
Summary: Code Generation Library for Java
License: ASL 2.0 and BSD
Group: Development/Tools
@@ -8,16 +8,17 @@ Url: http://cglib.sourceforge.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-src-%{version}.jar
Source1: http://mirrors.ibiblio.org/pub/mirrors/maven2/%{name}/%{name}/%{version}/%{name}-%{version}.pom
Source2: bnd.properties
-# Remove the repackaging step that includes other jars into the final thing
-Patch0: %{name}-build_xml.patch
+# Incorrect usage of ASM library
+# Forwarded upstream: https://sourceforge.net/p/cglib/bugs/44/
+Patch0: cglib-44.patch
Requires: java >= 0:1.6.0
-Requires: objectweb-asm
+Requires: objectweb-asm4
BuildRequires: ant
BuildRequires: jpackage-utils >= 0:1.5
BuildRequires: java-devel >= 0:1.6.0
-BuildRequires: objectweb-asm
+BuildRequires: objectweb-asm4
BuildRequires: unzip
BuildRequires: aqute-bnd
BuildArch: noarch
@@ -35,11 +36,16 @@ Documentation for the cglib code generation library.
%prep
%setup -q -c %{name}-%{version}
+cp -p %{SOURCE1} pom.xml
rm lib/*.jar
-%patch0 -p1
+# Remove the repackaging step that includes other jars into the final thing
+sed -i "//d" build.xml
+
+%patch0
+%pom_xpath_remove "pom:dependency[pom:artifactId = 'asm-util']/pom:optional"
%build
-export CLASSPATH=`build-classpath objectweb-asm`
+export OPT_JAR_LIST=objectweb-asm4
ant jar javadoc
# Convert to OSGi bundle
pushd dist
@@ -52,12 +58,10 @@ install -d -m 755 %{buildroot}%{_javadir}
install -d -m 755 %{buildroot}%{_mavenpomdir}
install -d -m 755 %{buildroot}%{_javadocdir}/%{name}
mkdir -p %{buildroot}%{_mavenpomdir}
-cp %{SOURCE1} %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
# yes, this is really *.bar - aqute bnd created it
install -p -m 644 dist/%{name}-%{version}.bar %{buildroot}%{_javadir}/%{name}.jar
-install -p -m 644 %{SOURCE1} %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
-%add_maven_depmap -a net.sf.cglib:cglib
-%add_maven_depmap -a cglib:cglib-full
+install -p -m 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
+%add_maven_depmap -a net.sf.cglib:cglib,cglib:cglib-full,org.sonatype.sisu.inject:cglib
cp -rp docs/* %{buildroot}%{_javadocdir}/%{name}
@@ -72,6 +76,10 @@ cp -rp docs/* %{buildroot}%{_javadocdir}/%{name}
%{_javadocdir}/%{name}
%changelog
+* Mon Nov 11 2013 Mikolaj Izdebski - 3.0-1
+- Update to upstream version 3.0
+- Add alias for org.sonatype.sisu.inject:cglib
+
* Mon Aug 05 2013 Severin Gehwolf 2.2-17
- Remove old call to %add_to_maven_depmap macro.
- Fixes RHBZ#992051.
diff --git a/sources b/sources
index 2b2ef43..96ebfd0 100644
--- a/sources
+++ b/sources
@@ -1 +1,2 @@
-b1e6ebfb76ec7071b6a3f5f9d7df2e57 cglib-src-2.2.jar
+314e056fc64152ca692974e0b57ff4d4 cglib-src-3.0.jar
+b3c6d777899123ab7b6e2bf9780a1485 cglib-3.0.pom