diff --git a/.gitignore b/.gitignore
index b7a4ed0..7574232 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@ cglib-src-2.2.jar
/cglib-3.0.pom
/cglib-src-3.1.jar
/cglib-3.1.pom
+/RELEASE_3_2_4.tar.gz
+/cglib-RELEASE_3_2_4
diff --git a/bnd.properties b/bnd.properties
deleted file mode 100644
index 261dbe1..0000000
--- a/bnd.properties
+++ /dev/null
@@ -1,4 +0,0 @@
-Bundle-Name= Java code generation library
-Bundle-SymbolicName= net.sf.cglib.core
-Export-Package=net.*
-Import-Package=org.apache.tools.*;resolution:=optional,*
diff --git a/cglib.spec b/cglib.spec
index 8c76b4e..b1c0f8a 100644
--- a/cglib.spec
+++ b/cglib.spec
@@ -1,18 +1,20 @@
+%global tarball_name RELEASE_3_2_4
+
Name: cglib
-Version: 3.1
-Release: 10%{?dist}
+Version: 3.2.4
+Release: 1%{?dist}
Summary: Code Generation Library for Java
License: ASL 2.0 and BSD
-Url: http://cglib.sourceforge.net/
-Source0: http://downloads.sourceforge.net/%{name}/%{name}-src-%{version}.jar
-Source1: https://repo1.maven.org/maven2/cglib/cglib/%{version}/cglib-%{version}.pom
-Source2: bnd.properties
+Url: https://github.com/cglib/cglib
+Source0: https://github.com/cglib/cglib/archive/%{tarball_name}.tar.gz
-BuildRequires: ant
+BuildRequires: maven-local
+BuildRequires: maven-plugin-bundle
BuildRequires: javapackages-local
-BuildRequires: objectweb-asm
-BuildRequires: unzip
-BuildRequires: aqute-bnd
+BuildRequires: mvn(org.apache.ant:ant)
+BuildRequires: mvn(org.ow2.asm:asm)
+BuildRequires: mvn(junit:junit)
+BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:)
BuildArch: noarch
%description
@@ -27,33 +29,35 @@ Summary: Javadoc for %{name}
Documentation for the cglib code generation library.
%prep
-%setup -q -c %{name}-%{version}
-cp -p %{SOURCE1} pom.xml
+%setup -q -n %{name}-%{tarball_name}
-rm lib/*.jar
-build-jar-repository -s lib objectweb-asm ant
+%pom_disable_module cglib-nodep
+%pom_disable_module cglib-integration-test
+%pom_disable_module cglib-jmh
+%pom_xpath_set pom:packaging 'bundle' cglib
+%pom_xpath_inject pom:build/pom:plugins '
+ org.apache.felix
+ maven-bundle-plugin
+ 1.4.0
+ true
+
+
+ net.sf.cglib.core
+ net.*
+ org.apache.tools.*;resolution:=optional,*
+
+
+ ' cglib
+%pom_remove_plugin org.apache.maven.plugins:maven-gpg-plugin
+%pom_remove_plugin org.apache.maven.plugins:maven-jarsigner-plugin cglib-sample
-# Remove the repackaging step that includes other jars into the final thing
-sed -i "//d" build.xml
-sed -i '/doctitle/a additionalparam="-Xdoclint:none"' build.xml
-
-%pom_xpath_remove "pom:dependency[pom:artifactId = 'asm-util']/pom:optional"
-%pom_xpath_set "pom:dependency[pom:groupId = 'ant']/pom:groupId" "org.apache.ant"
-
-%mvn_file :cglib cglib
%mvn_alias :cglib "net.sf.cglib:cglib" "cglib:cglib-full" "cglib:cglib-nodep" "org.sonatype.sisu.inject:cglib"
%build
-ant jar javadoc
-# Convert to OSGi bundle
-bnd wrap --output dist/cglib-%{version}.bar --properties %{SOURCE2} \
- --version %{version} dist/cglib-%{version}.jar
-
-mv dist/cglib-%{version}.bar dist/cglib-%{version}.jar
-%mvn_artifact pom.xml dist/cglib-%{version}.jar
+%mvn_build
%install
-%mvn_install -J docs
+%mvn_install
%files -f .mfiles
%license LICENSE NOTICE
@@ -62,6 +66,10 @@ mv dist/cglib-%{version}.bar dist/cglib-%{version}.jar
%license LICENSE NOTICE
%changelog
+* Thu Jul 07 2016 Severin Gehwolf - 3.2.4-1
+- Upgrade to latest 3.2.4 release.
+- Resolves RHBZ#1352315
+
* Mon Feb 22 2016 Mat Booth - 3.1-10
- Make ant an optional dependency
diff --git a/sources b/sources
index 7c25de6..e4f4c0e 100644
--- a/sources
+++ b/sources
@@ -1,2 +1 @@
-d050c54409bcd21d2dd4703879b8c3b2 cglib-src-3.1.jar
-cdcb12866a7e341e89ad7c3bf9c19b71 cglib-3.1.pom
+c070bfb4037b37d0334c1f4af447872f RELEASE_3_2_4.tar.gz