Update to upstream version 3.1
- Remove patch for upstream bug 44 (fixed upstream)
This commit is contained in:
parent
67bb797e74
commit
2e6b5de4cb
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,3 +1,5 @@
|
||||
cglib-src-2.2.jar
|
||||
/cglib-src-3.0.jar
|
||||
/cglib-3.0.pom
|
||||
/cglib-src-3.1.jar
|
||||
/cglib-3.1.pom
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/proxy/net/sf/cglib/core/DebuggingClassWriter.java~ 2012-05-25 13:21:20.000000000 +0200
|
||||
+++ src/proxy/net/sf/cglib/core/DebuggingClassWriter.java 2013-11-12 10:36:50.707147437 +0100
|
||||
@@ -46,7 +46,7 @@
|
||||
}
|
||||
|
||||
public DebuggingClassWriter(int flags) {
|
||||
- super(flags, new ClassWriter(flags));
|
||||
+ super(Opcodes.ASM4, new ClassWriter(flags));
|
||||
}
|
||||
|
||||
public void visit(int version,
|
16
cglib.spec
16
cglib.spec
@ -1,5 +1,5 @@
|
||||
Name: cglib
|
||||
Version: 3.0
|
||||
Version: 3.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Code Generation Library for Java
|
||||
License: ASL 2.0 and BSD
|
||||
@ -8,17 +8,14 @@ Url: http://cglib.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-src-%{version}.jar
|
||||
Source1: http://mirrors.ibiblio.org/pub/mirrors/maven2/%{name}/%{name}/%{version}/%{name}-%{version}.pom
|
||||
Source2: bnd.properties
|
||||
# Incorrect usage of ASM library
|
||||
# Forwarded upstream: https://sourceforge.net/p/cglib/bugs/44/
|
||||
Patch0: cglib-44.patch
|
||||
|
||||
Requires: java >= 0:1.6.0
|
||||
Requires: objectweb-asm4
|
||||
Requires: objectweb-asm
|
||||
|
||||
BuildRequires: ant
|
||||
BuildRequires: jpackage-utils >= 0:1.5
|
||||
BuildRequires: java-devel >= 0:1.6.0
|
||||
BuildRequires: objectweb-asm4
|
||||
BuildRequires: objectweb-asm
|
||||
BuildRequires: unzip
|
||||
BuildRequires: aqute-bnd
|
||||
BuildArch: noarch
|
||||
@ -41,11 +38,10 @@ rm lib/*.jar
|
||||
# Remove the repackaging step that includes other jars into the final thing
|
||||
sed -i "/<taskdef name=.jarjar/,/<.jarjar>/d" build.xml
|
||||
|
||||
%patch0
|
||||
%pom_xpath_remove "pom:dependency[pom:artifactId = 'asm-util']/pom:optional"
|
||||
|
||||
%build
|
||||
export OPT_JAR_LIST=objectweb-asm4
|
||||
export OPT_JAR_LIST=objectweb-asm
|
||||
ant jar javadoc
|
||||
# Convert to OSGi bundle
|
||||
pushd dist
|
||||
@ -76,6 +72,10 @@ cp -rp docs/* %{buildroot}%{_javadocdir}/%{name}
|
||||
%{_javadocdir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Mon Jan 13 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1-1
|
||||
- Update to upstream version 3.1
|
||||
- Remove patch for upstream bug 44 (fixed upstream)
|
||||
|
||||
* Mon Nov 11 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.0-1
|
||||
- Update to upstream version 3.0
|
||||
- Add alias for org.sonatype.sisu.inject:cglib
|
||||
|
Loading…
Reference in New Issue
Block a user