37cd032951
The updated NSS crypto-policy enables all tokens which broke requesting certificates due to the way that tokens were managed.
31 lines
854 B
Diff
31 lines
854 B
Diff
From 697dd085e7b2ce15eefc454509987270131d7f1e Mon Sep 17 00:00:00 2001
|
|
From: Rob Crittenden <rcritten@redhat.com>
|
|
Date: Tue, 4 Sep 2018 16:59:28 -0400
|
|
Subject: [PATCH 5/7] Ensure that an OpenSSL random seed file exists when
|
|
testing
|
|
|
|
Otherwise some openssl command-line invocations will fail and
|
|
because of the way the tests are done the error message is not
|
|
shown.
|
|
---
|
|
tests/Makefile.am | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index 4e407434..fe368dc0 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -433,6 +433,9 @@ subdirs += \
|
|
endif
|
|
|
|
check: all
|
|
+ if [ ! -e $$HOME/.rnd ] ; then \
|
|
+ openssl rand -writerand $$HOME/.rnd; \
|
|
+ fi
|
|
for required in certutil cmsutil pk12util openssl diff cmp mktemp \
|
|
dos2unix unix2dos dbus-launch ; do \
|
|
which $$required || exit 1; \
|
|
--
|
|
2.14.4
|
|
|