acada8c281
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/certmonger#efe9c7e6bb83d2d967fc27037dd373ea21c471bf
39 lines
1.0 KiB
Diff
39 lines
1.0 KiB
Diff
From 94dfc2f31b439db37b67d58e635169c29a4f8dde Mon Sep 17 00:00:00 2001
|
|
From: Rob Crittenden <rcritten@redhat.com>
|
|
Date: Wed, 16 Sep 2020 11:29:41 -0400
|
|
Subject: [PATCH 10/11] Add a local-srpm target to build an srpm from the
|
|
current checkout
|
|
|
|
The srpm target will pull the origin master branch and build from
|
|
that so it isn't useful for testing local changes.
|
|
---
|
|
Makefile.am | 12 ++++++++++++
|
|
1 file changed, 12 insertions(+)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 16d103ec..883c5932 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -29,6 +29,18 @@ ARCHIVEOUTDIR=$(shell cd $(top_srcdir) && pwd)
|
|
local-archive:
|
|
$(MAKE) archive ORIGIN=$(ARCHIVEOUTDIR)
|
|
|
|
+local-srpm:
|
|
+ repo=`pwd`; \
|
|
+ tmpdir=`mktemp -d /tmp/make_archive_XXXXXX`; \
|
|
+ if test -d "$$tmpdir" ; then \
|
|
+ git clone . $$tmpdir;\
|
|
+ cd $$tmpdir;\
|
|
+ ./make-srpm.sh;\
|
|
+ cp -v $(distdir)-*.src.rpm $(ARCHIVEOUTDIR)/;\
|
|
+ chmod -R u+rw $$tmpdir;\
|
|
+ rm -fr $$tmpdir;\
|
|
+ fi
|
|
+
|
|
srpm:
|
|
repo=`pwd`; \
|
|
tmpdir=`mktemp -d /tmp/make_archive_XXXXXX`; \
|
|
--
|
|
2.25.4
|
|
|