- Change python2-dbus build dependency to python3 - Convert tests to pass under python 3 - Skip DSA tests because it is disabled by default crypto policy
35 lines
749 B
Diff
35 lines
749 B
Diff
From 0b1ad4df8d7eefc35061d9f82b102c6f06f31acd Mon Sep 17 00:00:00 2001
|
|
From: Rob Crittenden <rcrit@localhost.localdomain>
|
|
Date: Tue, 29 Oct 2019 17:15:54 -0400
|
|
Subject: [PATCH 2/2] Disable DSA tests because it is disabled in default
|
|
crypto policy
|
|
|
|
certutil will fail to generate DSA keys with a cryptic hash
|
|
error.
|
|
---
|
|
tests/Makefile.am | 8 --------
|
|
1 file changed, 8 deletions(-)
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index fe368dc..4c2b0d3 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -416,14 +416,6 @@ subdirs += \
|
|
034-perms-sql
|
|
endif
|
|
|
|
-if HAVE_DSA
|
|
-subdirs += \
|
|
- 001-keyiread-dsa \
|
|
- 002-keygen-dsa \
|
|
- 003-csrgen-dsa \
|
|
- 004-selfsign-dsa
|
|
-endif
|
|
-
|
|
if HAVE_EC
|
|
subdirs += \
|
|
001-keyiread-ec \
|
|
--
|
|
2.24.0.rc1
|
|
|