Rename DBus service and conf files to match canonical name
See also https://gitlab.freedesktop.org/dbus/dbus/-/issues/168 Resolves: #2151243
This commit is contained in:
parent
3c3ee59a21
commit
cb673ccb7d
137
0001-Rename-DBus-service-and-conf-files-to-match-canonica.patch
Normal file
137
0001-Rename-DBus-service-and-conf-files-to-match-canonica.patch
Normal file
@ -0,0 +1,137 @@
|
|||||||
|
From d7deb47302c497742025863fb00cf1e62faa823a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Rob Crittenden <rcritten@redhat.com>
|
||||||
|
Date: Tue, 6 Dec 2022 11:11:38 -0500
|
||||||
|
Subject: [PATCH] Rename DBus service and conf files to match canonical name
|
||||||
|
|
||||||
|
See also https://gitlab.freedesktop.org/dbus/dbus/-/issues/168
|
||||||
|
|
||||||
|
BZ 2151243
|
||||||
|
|
||||||
|
Signed-off-by: Rob Crittenden <rcritten@redhat.com>
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
dbus/Makefile.am | 4 +--
|
||||||
|
dbus/certmonger.conf.in | 28 ---------------------
|
||||||
|
dbus/certmonger.service.in | 3 ---
|
||||||
|
dbus/org.fedorahosted.certmonger.conf.in | 28 +++++++++++++++++++++
|
||||||
|
dbus/org.fedorahosted.certmonger.service.in | 3 +++
|
||||||
|
7 files changed, 36 insertions(+), 36 deletions(-)
|
||||||
|
delete mode 100644 dbus/certmonger.conf.in
|
||||||
|
delete mode 100644 dbus/certmonger.service.in
|
||||||
|
create mode 100644 dbus/org.fedorahosted.certmonger.conf.in
|
||||||
|
create mode 100644 dbus/org.fedorahosted.certmonger.service.in
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 9b7209b7..3ede40e8 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -884,4 +884,4 @@ else
|
||||||
|
fi
|
||||||
|
|
||||||
|
AC_CONFIG_COMMANDS(src_introspect_sh,[chmod +x src/introspect.sh])
|
||||||
|
-AC_OUTPUT(Makefile src/Makefile dbus/Makefile systemd/Makefile sysvinit/Makefile sysvinit/certmonger tests/Makefile tests/tools/Makefile dbus/certmonger.conf dbus/certmonger.service src/introspect.sh src/certmonger.8 src/getcert.1 src/getcert-request.1 src/getcert-list.1 src/getcert-list-cas.1 src/getcert-start-tracking.1 src/getcert-stop-tracking.1 src/selfsign-getcert.1 src/ipa-getcert.1 src/getcert-resubmit.1 src/certmonger-certmaster-submit.8 src/certmonger-ipa-submit.8 src/certmonger-dogtag-ipa-renew-agent-submit.8 src/certmaster-getcert.1 src/certmonger.conf.5 po/Makefile.in src/certmonger.conf systemd/certmonger.service systemd/certmonger.conf systemd/org.fedorahosted.certmonger.service src/getcert-refresh.1 src/getcert-refresh-ca.1 src/local-getcert.1 src/certmonger-local-submit.8 src/getcert-status.1 src/certmonger-dogtag-submit.8 src/certmonger-scep-submit.8 src/getcert-add-ca.1 src/getcert-add-scep-ca.1 src/getcert-modify-ca.1 src/getcert-remove-ca.1 src/getcert-rekey.1)
|
||||||
|
+AC_OUTPUT(Makefile src/Makefile dbus/Makefile systemd/Makefile sysvinit/Makefile sysvinit/certmonger tests/Makefile tests/tools/Makefile dbus/org.fedorahosted.certmonger.conf dbus/org.fedorahosted.certmonger.service src/introspect.sh src/certmonger.8 src/getcert.1 src/getcert-request.1 src/getcert-list.1 src/getcert-list-cas.1 src/getcert-start-tracking.1 src/getcert-stop-tracking.1 src/selfsign-getcert.1 src/ipa-getcert.1 src/getcert-resubmit.1 src/certmonger-certmaster-submit.8 src/certmonger-ipa-submit.8 src/certmonger-dogtag-ipa-renew-agent-submit.8 src/certmaster-getcert.1 src/certmonger.conf.5 po/Makefile.in src/certmonger.conf systemd/certmonger.service systemd/certmonger.conf systemd/org.fedorahosted.certmonger.service src/getcert-refresh.1 src/getcert-refresh-ca.1 src/local-getcert.1 src/certmonger-local-submit.8 src/getcert-status.1 src/certmonger-dogtag-submit.8 src/certmonger-scep-submit.8 src/getcert-add-ca.1 src/getcert-add-scep-ca.1 src/getcert-modify-ca.1 src/getcert-remove-ca.1 src/getcert-rekey.1)
|
||||||
|
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
|
||||||
|
index 036a1ef2..9fd84ac9 100644
|
||||||
|
--- a/dbus/Makefile.am
|
||||||
|
+++ b/dbus/Makefile.am
|
||||||
|
@@ -1,8 +1,8 @@
|
||||||
|
if SESSIONBUS
|
||||||
|
servicedir = @SESSIONBUSSERVICESDIR@
|
||||||
|
-service_DATA = certmonger.service
|
||||||
|
+service_DATA = org.fedorahosted.certmonger.service
|
||||||
|
endif
|
||||||
|
if SYSTEMBUS
|
||||||
|
systemdbusdir = $(sysconfdir)/dbus-1/system.d
|
||||||
|
-systemdbus_DATA = certmonger.conf
|
||||||
|
+systemdbus_DATA = org.fedorahosted.certmonger.conf
|
||||||
|
endif
|
||||||
|
diff --git a/dbus/certmonger.conf.in b/dbus/certmonger.conf.in
|
||||||
|
deleted file mode 100644
|
||||||
|
index 37f1a8e1..00000000
|
||||||
|
--- a/dbus/certmonger.conf.in
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,28 +0,0 @@
|
||||||
|
-<!DOCTYPE busconfig PUBLIC
|
||||||
|
- "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
|
||||||
|
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
|
||||||
|
-<busconfig>
|
||||||
|
-
|
||||||
|
- <!-- Only root can own and communicate with the service -->
|
||||||
|
-
|
||||||
|
- <policy context="default">
|
||||||
|
- <deny own="@CM_DBUS_NAME@"/>
|
||||||
|
- <deny send_destination="@CM_DBUS_NAME@"/>
|
||||||
|
- </policy>
|
||||||
|
-
|
||||||
|
- <policy user="root">
|
||||||
|
- <allow own="@CM_DBUS_NAME@"/>
|
||||||
|
-
|
||||||
|
- <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
- send_interface="@CM_DBUS_NAME@"/>
|
||||||
|
- <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
- send_interface="@CM_DBUS_NAME@.ca"/>
|
||||||
|
- <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
- send_interface="@CM_DBUS_NAME@.request"/>
|
||||||
|
- <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
- send_interface="org.freedesktop.DBus.Introspectable"/>
|
||||||
|
- <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
- send_interface="org.freedesktop.DBus.Properties"/>
|
||||||
|
- </policy>
|
||||||
|
-
|
||||||
|
-</busconfig>
|
||||||
|
diff --git a/dbus/certmonger.service.in b/dbus/certmonger.service.in
|
||||||
|
deleted file mode 100644
|
||||||
|
index 74a8c55e..00000000
|
||||||
|
--- a/dbus/certmonger.service.in
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,3 +0,0 @@
|
||||||
|
-[D-BUS Service]
|
||||||
|
-Name=@CM_DBUS_NAME@
|
||||||
|
-Exec=@mylibexecdir@/certmonger-session
|
||||||
|
diff --git a/dbus/org.fedorahosted.certmonger.conf.in b/dbus/org.fedorahosted.certmonger.conf.in
|
||||||
|
new file mode 100644
|
||||||
|
index 00000000..37f1a8e1
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/dbus/org.fedorahosted.certmonger.conf.in
|
||||||
|
@@ -0,0 +1,28 @@
|
||||||
|
+<!DOCTYPE busconfig PUBLIC
|
||||||
|
+ "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
|
||||||
|
+ "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
|
||||||
|
+<busconfig>
|
||||||
|
+
|
||||||
|
+ <!-- Only root can own and communicate with the service -->
|
||||||
|
+
|
||||||
|
+ <policy context="default">
|
||||||
|
+ <deny own="@CM_DBUS_NAME@"/>
|
||||||
|
+ <deny send_destination="@CM_DBUS_NAME@"/>
|
||||||
|
+ </policy>
|
||||||
|
+
|
||||||
|
+ <policy user="root">
|
||||||
|
+ <allow own="@CM_DBUS_NAME@"/>
|
||||||
|
+
|
||||||
|
+ <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
+ send_interface="@CM_DBUS_NAME@"/>
|
||||||
|
+ <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
+ send_interface="@CM_DBUS_NAME@.ca"/>
|
||||||
|
+ <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
+ send_interface="@CM_DBUS_NAME@.request"/>
|
||||||
|
+ <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
+ send_interface="org.freedesktop.DBus.Introspectable"/>
|
||||||
|
+ <allow send_destination="@CM_DBUS_NAME@"
|
||||||
|
+ send_interface="org.freedesktop.DBus.Properties"/>
|
||||||
|
+ </policy>
|
||||||
|
+
|
||||||
|
+</busconfig>
|
||||||
|
diff --git a/dbus/org.fedorahosted.certmonger.service.in b/dbus/org.fedorahosted.certmonger.service.in
|
||||||
|
new file mode 100644
|
||||||
|
index 00000000..74a8c55e
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/dbus/org.fedorahosted.certmonger.service.in
|
||||||
|
@@ -0,0 +1,3 @@
|
||||||
|
+[D-BUS Service]
|
||||||
|
+Name=@CM_DBUS_NAME@
|
||||||
|
+Exec=@mylibexecdir@/certmonger-session
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
@ -28,7 +28,7 @@
|
|||||||
|
|
||||||
Name: certmonger
|
Name: certmonger
|
||||||
Version: 0.79.17
|
Version: 0.79.17
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Certificate status monitor and PKI enrollment client
|
Summary: Certificate status monitor and PKI enrollment client
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -36,6 +36,8 @@ URL: http://pagure.io/certmonger/
|
|||||||
Source0: http://releases.pagure.org/certmonger/certmonger-%{version}.tar.gz
|
Source0: http://releases.pagure.org/certmonger/certmonger-%{version}.tar.gz
|
||||||
#Source1: http://releases.pagure.org/certmonger/certmonger-%%{version}.tar.gz.sig
|
#Source1: http://releases.pagure.org/certmonger/certmonger-%%{version}.tar.gz.sig
|
||||||
|
|
||||||
|
Patch0001: 0001-Rename-DBus-service-and-conf-files-to-match-canonica.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
@ -264,6 +266,9 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 6 2022 Rob Crittenden <rcritten@redhat.com> - 0.79.17-2
|
||||||
|
- Rename DBus service and conf files to match canonical name (#2151243)
|
||||||
|
|
||||||
* Wed Nov 30 2022 Rob Crittenden <rcritten@redhat.com> - 0.79.17-1
|
* Wed Nov 30 2022 Rob Crittenden <rcritten@redhat.com> - 0.79.17-1
|
||||||
- Update to upstream 0.79.17
|
- Update to upstream 0.79.17
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user