Update to 0.79.2-2
- update to 0.79.2: - update %%docs list because README is now README.md - update to 0.79.1: - update translations - fix 'make archive' target - update to 0.79: - getcert now offers an option (-X) for requesting processing by a particular CA if the server we're contacting is running more than one - getcert also offers options (--for-ca, --not-for-ca, --ca-path-length) for requesting BasicConstraints values - getcert now displays times in local time instead of UTC, which was previously the only way they were displayed; the --utc option can often be used to switch back to its previous behavior - the SCEP enrollment helper now correctly issues GetCACertChain requests to SCEP servers, instead of issuing a GetCAChain request, which isn't part of the protocol; from report by Jason Garland - when issuing SCEP requests, the ID of the CA included in the HTTP request is now URL-encoded, as it should be - renewal or notification-of-impending-expiration logic is now triggered closer to TTL thresholds rather than waiting for a periodic check to pass a threshold - properly builds with OpenSSL 1.1, thanks to Lukas Slebodnik and Tomas Mraz for a lot of the legwork - resync .spec file with Fedora - upstream project migrated from fedorahosted.org to pagure.io Signed-off-by: Nalin Dahyabhai <nalin@redhat.com>
This commit is contained in:
parent
a4236fbbbc
commit
c68c5e7f21
2
.gitignore
vendored
2
.gitignore
vendored
@ -116,3 +116,5 @@ certmonger-0.28.tar.gz
|
||||
/certmonger-0.78.5.tar.gz.sig
|
||||
/certmonger-0.78.6.tar.gz
|
||||
/certmonger-0.78.6.tar.gz.sig
|
||||
/certmonger-0.79.2.tar.gz
|
||||
/certmonger-0.79.2.tar.gz.sig
|
||||
|
@ -1,59 +0,0 @@
|
||||
From 4f72c02d0f432519f9d5606bd99007fd685482a7 Mon Sep 17 00:00:00 2001
|
||||
From: Nalin Dahyabhai <nalin@redhat.com>
|
||||
Date: Wed, 29 Jun 2016 17:37:09 -0400
|
||||
Subject: [PATCH] Fix a flakiness in the 028-dbus test
|
||||
|
||||
When walking all of the exposed APIs from python, we were calling the
|
||||
'resubmit' method on a certificate, and not waiting for the churn in
|
||||
state that doing so would create to settle down before continuing.
|
||||
|
||||
This meant that the test script might have exited before the certmonger
|
||||
process that was waiting on it finished saving the new certificate that
|
||||
it obtained from resubmitting the rquest, so the process wouldn't
|
||||
reliably log that it had obtained a new certificate.
|
||||
|
||||
Spotted by Jan Cholasta.
|
||||
---
|
||||
tests/028-dbus/expected.out | 1 +
|
||||
tests/028-dbus/walk.py | 8 ++++++++
|
||||
2 files changed, 9 insertions(+)
|
||||
|
||||
diff --git a/tests/028-dbus/expected.out b/tests/028-dbus/expected.out
|
||||
index b2660317b3102373f2a5a877a7224f727929412c..93cc4d184524c4b1aeba02a650c94d832462c236 100644
|
||||
--- a/tests/028-dbus/expected.out
|
||||
+++ b/tests/028-dbus/expected.out
|
||||
@@ -1,4 +1,5 @@
|
||||
Certificate in file "${tmpdir}/test.crt" issued by CA and saved.
|
||||
+Certificate in file "${tmpdir}/test.crt" issued by CA and saved.
|
||||
[[ getcert ]]
|
||||
State MONITORING, stuck: no.
|
||||
Number of certificates and requests being tracked: 1.
|
||||
diff --git a/tests/028-dbus/walk.py b/tests/028-dbus/walk.py
|
||||
index 0bf54b477220aef901340c1d24100391348226a7..f60ca934fd934e21cec027bad5c53e0f12ccb36d 100644
|
||||
--- a/tests/028-dbus/walk.py
|
||||
+++ b/tests/028-dbus/walk.py
|
||||
@@ -3,6 +3,7 @@ import dbus
|
||||
import xml.etree.ElementTree
|
||||
import os
|
||||
import sys
|
||||
+import time
|
||||
|
||||
bus = dbus.SessionBus()
|
||||
|
||||
@@ -110,6 +111,13 @@ def examine_method(objpath, interface, method, idata):
|
||||
# We're in FIXME territory.
|
||||
print('FIXME: need support for "%s"' % method)
|
||||
return False
|
||||
+ # If we caused things to start churning, wait for them to settle.
|
||||
+ if method == 'resubmit':
|
||||
+ props = dbus.Interface(o, 'org.freedesktop.DBus.Properties')
|
||||
+ prop = props.Get(interface, 'status')
|
||||
+ while prop != 'MONITORING':
|
||||
+ time.sleep(1)
|
||||
+ prop = props.Get(interface, 'status')
|
||||
return True
|
||||
|
||||
def iget(child, proxy, interface, prop):
|
||||
--
|
||||
2.7.4
|
||||
|
@ -25,16 +25,15 @@
|
||||
%endif
|
||||
|
||||
Name: certmonger
|
||||
Version: 0.78.6
|
||||
Release: 6%{?dist}
|
||||
Version: 0.79.2
|
||||
Release: 2%{?dist}
|
||||
Summary: Certificate status monitor and PKI enrollment client
|
||||
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv3+
|
||||
URL: http://certmonger.fedorahosted.org
|
||||
Source0: http://fedorahosted.org/released/certmonger/certmonger-%{version}.tar.gz
|
||||
Source1: http://fedorahosted.org/released/certmonger/certmonger-%{version}.tar.gz.sig
|
||||
Patch0: 0009-Fix-a-flakiness-in-the-028-dbus-test.patch
|
||||
URL: http://pagure.io/certmonger/
|
||||
Source0: http://releases.pagure.org/certmonger/certmonger-%{version}.tar.gz
|
||||
Source1: http://releases.pagure.org/certmonger/certmonger-%{version}.tar.gz.sig
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
BuildRequires: openldap-devel
|
||||
@ -115,7 +114,6 @@ system enrolled with a certificate authority (CA) and keeping it enrolled.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .testrace
|
||||
%if 0%{?rhel} > 0
|
||||
# Enabled by default for RHEL for bug #765600, still disabled by default for
|
||||
# Fedora pending a similar bug report there.
|
||||
@ -222,7 +220,7 @@ exit 0
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc README LICENSE STATUS doc/*.txt
|
||||
%doc README.md LICENSE STATUS doc/*.txt
|
||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/*
|
||||
%{_datadir}/dbus-1/services/*
|
||||
%dir %{_sysconfdir}/certmonger
|
||||
@ -245,6 +243,40 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 27 2017 Nalin Dahyabhai <nalin@redhat.com> 0.79.2-2
|
||||
- update %%docs list because README is now README.md
|
||||
|
||||
* Mon Feb 27 2017 Nalin Dahyabhai <nalin@redhat.com> 0.79.2-1
|
||||
- update to 0.79.2:
|
||||
- fix 'make distcheck' target
|
||||
|
||||
* Sun Feb 19 2017 Nalin Dahyabhai <nalin@redhat.com> 0.79.1-1
|
||||
- update to 0.79.1:
|
||||
- update translations
|
||||
- fix 'make archive' target
|
||||
|
||||
* Sun Feb 19 2017 Nalin Dahyabhai <nalin@redhat.com> 0.79-1
|
||||
- update to 0.79:
|
||||
- getcert now offers an option (-X) for requesting processing by a particular
|
||||
CA if the server we're contacting is running more than one
|
||||
- getcert also offers options (--for-ca, --not-for-ca, --ca-path-length) for
|
||||
requesting BasicConstraints values
|
||||
- getcert now displays times in local time instead of UTC, which was
|
||||
previously the only way they were displayed; the --utc option can often be
|
||||
used to switch back to its previous behavior
|
||||
- the SCEP enrollment helper now correctly issues GetCACertChain requests to
|
||||
SCEP servers, instead of issuing a GetCAChain request, which isn't part of
|
||||
the protocol; from report by Jason Garland
|
||||
- when issuing SCEP requests, the ID of the CA included in the HTTP request
|
||||
is now URL-encoded, as it should be
|
||||
- renewal or notification-of-impending-expiration logic is now triggered
|
||||
closer to TTL thresholds rather than waiting for a periodic check to pass a
|
||||
threshold
|
||||
- properly builds with OpenSSL 1.1, thanks to Lukas Slebodnik and Tomas Mraz
|
||||
for a lot of the legwork
|
||||
- resync .spec file with Fedora
|
||||
- upstream project migrated from fedorahosted.org to pagure.io
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.78.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
20da8ea36b1da723c06080a2de482e14 certmonger-0.78.6.tar.gz
|
||||
4b70660736650c59fb7dcf8742de8063 certmonger-0.78.6.tar.gz.sig
|
||||
SHA512 (certmonger-0.79.2.tar.gz) = 1ed50b7f316419913bd938bef31e55adbb7a2dac1c32f310f440863d76c919d940a175023deb567e4c6eb551b85a36fc7e2dfb865fa9ead09c6bce6003e395ce
|
||||
SHA512 (certmonger-0.79.2.tar.gz.sig) = e713a95fdb402a541e38082c83d744c877b7c96b652773b0ecb56a87b8e78634a6a07a23ddf6a5f853c2629bc46d69dc1ae56adddd2569399ae19d60e8584638
|
||||
|
Loading…
Reference in New Issue
Block a user