0.79.14-4
- Fix FTBFS due to change in OpenSSL 3.0.0-beta2 API Resolves: #2008451
This commit is contained in:
parent
496758426b
commit
148ef5cdf6
@ -0,0 +1,46 @@
|
||||
From f6672effea3cf9e50d6d3f29c1fbfbf6b1578e06 Mon Sep 17 00:00:00 2001
|
||||
From: Rob Crittenden <rcritten@redhat.com>
|
||||
Date: Tue, 28 Sep 2021 10:01:35 -0400
|
||||
Subject: [PATCH] Add compile check for EVP_PKEY_get_id along with EVP_PKEY_id
|
||||
|
||||
EVP_PKEY_id is no longer available as a function, only as a preprocessor
|
||||
macro, so AC_CHECK_FUNCS cannot recognize it.
|
||||
|
||||
This was changed in OpenSSL 3.0.0-beta2
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=2008451
|
||||
|
||||
Signed-off-by: Rob Crittenden <rcritten@redhat.com>
|
||||
---
|
||||
configure.ac | 1 +
|
||||
src/util-o.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 8bfa3fa..3b413a1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -374,6 +374,7 @@ if ! ${configure_dist_target_only:-false} ; then
|
||||
AC_CHECK_FUNCS(ASN1_TIME_set)
|
||||
AC_CHECK_FUNCS(EVP_PKEY_base_id)
|
||||
AC_CHECK_FUNCS(EVP_PKEY_id)
|
||||
+ AC_CHECK_FUNCS(EVP_PKEY_get_id)
|
||||
AC_CHECK_FUNCS(OBJ_get0_data)
|
||||
AC_CHECK_FUNCS(OBJ_length)
|
||||
AC_CHECK_FUNCS(X509_ATTRIBUTE_get0_object)
|
||||
diff --git a/src/util-o.c b/src/util-o.c
|
||||
index 2208ab6..db45964 100644
|
||||
--- a/src/util-o.c
|
||||
+++ b/src/util-o.c
|
||||
@@ -329,7 +329,7 @@ util_ASN1_TIME_set(ASN1_TIME *str, time_t t)
|
||||
int
|
||||
util_EVP_PKEY_id(const EVP_PKEY *pkey)
|
||||
{
|
||||
-#ifdef HAVE_EVP_PKEY_ID
|
||||
+#if defined(HAVE_EVP_PKEY_ID) || defined(HAVE_EVP_PKEY_GET_ID)
|
||||
return EVP_PKEY_id(pkey);
|
||||
#else
|
||||
return pkey->type;
|
||||
--
|
||||
2.31.1
|
||||
|
@ -28,7 +28,7 @@
|
||||
|
||||
Name: certmonger
|
||||
Version: 0.79.14
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Certificate status monitor and PKI enrollment client
|
||||
|
||||
License: GPLv3+
|
||||
@ -38,6 +38,7 @@ Source0: http://releases.pagure.org/certmonger/certmonger-%{version}.tar.gz
|
||||
|
||||
Patch0002: 0002-candidate-openssl-3.0-compat-fixes.patch
|
||||
Patch0003: 0003-Temporarily-disable-the-csrgen-tests.patch
|
||||
Patch0004: 0004-Add-compile-check-for-EVP_PKEY_get_id-along-with-EVP.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -266,6 +267,9 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Sep 28 2021 Rob Crittenden <rcritten@redhat.com> - 0.79.14-4
|
||||
- Fix FTBFS due to change in OpenSSL 3.0.0-beta2 API (#2008451)
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.79.14-3
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
Loading…
Reference in New Issue
Block a user