re-import sources as agreed with the maintainer

This commit is contained in:
Adam Samalik 2023-07-10 09:17:54 +02:00
parent 38d5fdeca7
commit 7a3cc29f11
2 changed files with 22 additions and 1 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/ceres-solver-1.13.0.tar.gz /ceres-solver-*.tar.gz

View File

@ -0,0 +1,21 @@
diff -up ./CMakeLists.txt.cmakedir ./CMakeLists.txt
--- ./CMakeLists.txt.cmakedir 2015-10-11 16:57:44.000000000 -0400
+++ ./CMakeLists.txt 2016-02-14 11:01:38.328344701 -0500
@@ -632,7 +632,7 @@ endif (MSVC)
if (UNIX)
# GCC is not strict enough by default, so enable most of the warnings.
set(CMAKE_CXX_FLAGS
- "${CMAKE_CXX_FLAGS} -Werror=all -Werror=extra -Wno-unknown-pragmas -Wno-sign-compare -Wno-unused-parameter -Wno-missing-field-initializers")
+ "${CMAKE_CXX_FLAGS} -Wno-unknown-pragmas -Wno-sign-compare -Wno-unused-parameter -Wno-missing-field-initializers")
endif (UNIX)
# Use a larger inlining threshold for Clang, since it hobbles Eigen,
@@ -762,7 +762,7 @@ configure_file("${CMAKE_SOURCE_DIR}/cmak
if (WIN32)
set(RELATIVE_CMAKECONFIG_INSTALL_DIR CMake)
else ()
- set(RELATIVE_CMAKECONFIG_INSTALL_DIR share/Ceres)
+ set(RELATIVE_CMAKECONFIG_INSTALL_DIR lib${LIB_SUFFIX}/cmake/Ceres)
endif ()
# This "exports" for installation all targets which have been put into the