New release (1:10.2.5-2)
- revert to 10.2.5 for now - include WorkQueue for librbd to avoid build errors
This commit is contained in:
parent
f003c36523
commit
ffa151c1c9
47
0001-Disable-erasure_codelib-neon-build.patch
Normal file
47
0001-Disable-erasure_codelib-neon-build.patch
Normal file
@ -0,0 +1,47 @@
|
||||
From 2a7810f39cb113570efcde5f65e5440ff9587ae0 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Wed, 11 Nov 2015 17:08:06 +0100
|
||||
Subject: [PATCH] Disable erasure_codelib neon build
|
||||
|
||||
---
|
||||
src/erasure-code/jerasure/Makefile.am | 6 +++---
|
||||
src/erasure-code/shec/Makefile.am | 6 +++---
|
||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/erasure-code/jerasure/Makefile.am b/src/erasure-code/jerasure/Makefile.am
|
||||
index 6ffe3ed..01f5112 100644
|
||||
--- a/src/erasure-code/jerasure/Makefile.am
|
||||
+++ b/src/erasure-code/jerasure/Makefile.am
|
||||
@@ -75,9 +75,9 @@ if LINUX
|
||||
libec_jerasure_neon_la_LDFLAGS += -export-symbols-regex '.*__erasure_code_.*'
|
||||
endif
|
||||
|
||||
-if HAVE_NEON
|
||||
-erasure_codelib_LTLIBRARIES += libec_jerasure_neon.la
|
||||
-endif
|
||||
+#if HAVE_NEON
|
||||
+#erasure_codelib_LTLIBRARIES += libec_jerasure_neon.la
|
||||
+#endif
|
||||
|
||||
libec_jerasure_sse3_la_SOURCES = ${jerasure_sources}
|
||||
libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
||||
diff --git a/src/erasure-code/shec/Makefile.am b/src/erasure-code/shec/Makefile.am
|
||||
index cd93132..948979b 100644
|
||||
--- a/src/erasure-code/shec/Makefile.am
|
||||
+++ b/src/erasure-code/shec/Makefile.am
|
||||
@@ -81,9 +81,9 @@ if LINUX
|
||||
libec_shec_neon_la_LDFLAGS += -export-symbols-regex '.*__erasure_code_.*'
|
||||
endif
|
||||
|
||||
-if HAVE_NEON
|
||||
-erasure_codelib_LTLIBRARIES += libec_shec_neon.la
|
||||
-endif
|
||||
+#if HAVE_NEON
|
||||
+#erasure_codelib_LTLIBRARIES += libec_shec_neon.la
|
||||
+#endif
|
||||
|
||||
libec_shec_sse3_la_SOURCES = ${shec_sources}
|
||||
libec_shec_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
||||
--
|
||||
2.7.4
|
||||
|
33
0002-hack-do-not-test-for-libxfs-assume-it-is-present.patch
Normal file
33
0002-hack-do-not-test-for-libxfs-assume-it-is-present.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 69e888fa5c103588ee9f23ac4cec4bfc2285eb08 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Fri, 13 Jan 2017 01:15:42 +0100
|
||||
Subject: [PATCH] hack: do not test for libxfs, assume it is present
|
||||
|
||||
---
|
||||
configure.ac | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 32e273f..050e754 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -882,7 +882,7 @@ AC_ARG_WITH([libxfs],
|
||||
[AS_HELP_STRING([--without-libxfs], [disable libxfs use by FileStore])],
|
||||
[],
|
||||
[with_libxfs=yes])
|
||||
-AS_IF([test "x$with_libxfs" != "xno"], [
|
||||
+AS_IF([test "x$with_libxfs" = "hack..."], [
|
||||
# xfs/xfs.h presence and XFS_XFLAG_EXTSIZE define
|
||||
AC_CHECK_HEADER([xfs/xfs.h], [], AC_MSG_ERROR(
|
||||
[xfs/xfs.h not found (--without-libxfs to disable)]))
|
||||
@@ -900,6 +900,7 @@ AS_IF([test "x$with_libxfs" != "xno"], [
|
||||
AC_MSG_ERROR([XFS_XFLAG_EXTSIZE not found (--without-libxfs to disable)])
|
||||
])
|
||||
])
|
||||
+AC_DEFINE([HAVE_LIBXFS], [1], [Define to 1 if you have libxfs])
|
||||
AM_CONDITIONAL(WITH_LIBXFS, [test "x$with_libxfs" != "xno"])
|
||||
|
||||
# use libzfs
|
||||
--
|
||||
2.7.4
|
||||
|
25
0003-librbd-Journal-include-WorkQueue-since-we-use-it.patch
Normal file
25
0003-librbd-Journal-include-WorkQueue-since-we-use-it.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From b204da4e28a0238547c99ee1bf4080ae4d62ad33 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Wed, 8 Feb 2017 22:38:12 +0100
|
||||
Subject: [PATCH] librbd/Journal: include WorkQueue since we use it
|
||||
|
||||
Signed-off-by: Boris Ranto <branto@redhat.com>
|
||||
---
|
||||
src/librbd/Journal.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/librbd/Journal.h b/src/librbd/Journal.h
|
||||
index 4b70b99..2490975 100644
|
||||
--- a/src/librbd/Journal.h
|
||||
+++ b/src/librbd/Journal.h
|
||||
@@ -11,6 +11,7 @@
|
||||
#include "common/Cond.h"
|
||||
#include "common/Mutex.h"
|
||||
#include "common/Cond.h"
|
||||
+#include "common/WorkQueue.h"
|
||||
#include "journal/Future.h"
|
||||
#include "journal/JournalMetadataListener.h"
|
||||
#include "journal/ReplayEntry.h"
|
||||
--
|
||||
2.9.3
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ceph-11.2.0.tar.bz2) = 2e99ffb23f9b1128cf6f8cb3f7c263a6eb32c4767f83377d69268f1da0b790a527de437d6900c050d32745bc2f50828496beb4ea8a3e9b0f836ddf430585c209
|
||||
SHA512 (ceph-10.2.5.tar.gz) = 4889aff38c8af781c2e3dce8f4ee51864db0a27c6294774345d2c1b047588ec31354ad41f799e2f0d0a966dc372d76c9bdbfb93f30a0718ea9d7c2b7a645d0f8
|
||||
|
Loading…
Reference in New Issue
Block a user