17.1.0 RC1, #rhbz 2063071

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2022-03-11 09:58:39 -05:00
parent 1efbe7fbd6
commit f9fa7d2971
2 changed files with 33 additions and 13 deletions

View File

@ -1,6 +1,32 @@
--- ceph-17.0.0-10335-gfd206722/src/rgw/store/dbstore/CMakeLists.txt.orig 2022-02-12 08:17:16.038116513 -0500
+++ ceph-17.0.0-10335-gfd206722/src/rgw/store/dbstore/CMakeLists.txt 2022-02-12 08:40:43.564440428 -0500
@@ -47,7 +47,7 @@
--- ceph-17.1.0/src/rgw/store/dbstore/sqlite/CMakeLists.txt.orig 2022-03-01 08:19:04.974902872 -0500
+++ ceph-17.1.0/src/rgw/store/dbstore/sqlite/CMakeLists.txt 2022-03-11 07:55:16.236261471 -0500
@@ -12,5 +12,5 @@
set(SQLITE_COMPILE_FLAGS "-DSQLITE_THREADSAFE=1")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${SQLITE_COMPILE_FLAGS}")
-add_library(sqlite_db ${sqlite_db_srcs})
+add_library(sqlite_db STATIC ${sqlite_db_srcs})
target_link_libraries(sqlite_db sqlite3 dbstore_lib rgw_common)
--- ceph-17.1.0/src/rgw/store/dbstore/CMakeLists.txt.orig 2022-02-28 14:11:49.987077811 -0500
+++ ceph-17.1.0/src/rgw/store/dbstore/CMakeLists.txt 2022-03-11 08:40:13.409682698 -0500
@@ -16,7 +16,7 @@
dbstore_mgr.cc
)
-add_library(dbstore_lib ${dbstore_srcs})
+add_library(dbstore_lib STATIC ${dbstore_srcs})
target_include_directories(dbstore_lib PUBLIC "${CMAKE_SOURCE_DIR}/src/fmt/include")
target_include_directories(dbstore_lib PUBLIC "${CMAKE_SOURCE_DIR}/src/rgw")
set(link_targets spawn)
@@ -38,6 +38,7 @@
# add pthread library
set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} pthread)
+set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} global)
find_package(gtest QUIET)
if(WITH_TESTS)
@@ -47,7 +48,7 @@
endif()
include_directories(${CMAKE_INCLUDE_DIR})
@ -9,12 +35,3 @@
target_link_libraries(dbstore ${CMAKE_LINK_LIBRARIES})
# testing purpose
--- ceph-17.0.0-10335-gfd206722/src/rgw/store/dbstore/sqlite/CMakeLists.txt.orig 2022-02-12 08:18:04.843227147 -0500
+++ ceph-17.0.0-10335-gfd206722/src/rgw/store/dbstore/sqlite/CMakeLists.txt 2022-02-12 08:18:17.871989500 -0500
@@ -12,5 +12,5 @@
set(SQLITE_COMPILE_FLAGS "-DSQLITE_THREADSAFE=1")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${SQLITE_COMPILE_FLAGS}")
-add_library(sqlite_db ${sqlite_db_srcs})
+add_library(sqlite_db STATIC ${sqlite_db_srcs})
target_link_libraries(sqlite_db sqlite3 dbstore_lib rgw_common)

View File

@ -151,7 +151,7 @@
#################################################################################
Name: ceph
Version: 17.1.0
Release: 0.1.rc1%{?dist}
Release: 0.2.rc1%{?dist}
%if 0%{?fedora} || 0%{?rhel}
Epoch: 2
%endif
@ -2549,6 +2549,9 @@ exit 0
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
%changelog
* Fri Mar 11 2022 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.1.0-0.2.rc1
- 17.1.0 RC1, #rhbz 2063071
* Mon Feb 28 2022 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.1.0-0.1.rc1
- 17.1.0 RC1