ceph 15.2.8 GA
Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
df3db8be0e
commit
f52ea67e29
10
0004-src-common-ceph-time.h.patch
Normal file
10
0004-src-common-ceph-time.h.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- ceph-15.2.8/src/common/ceph_time.h.orig 2020-12-24 06:23:32.605762289 -0500
|
||||||
|
+++ ceph-15.2.8/src/common/ceph_time.h 2020-12-24 13:50:14.304877611 -0500
|
||||||
|
@@ -18,6 +18,7 @@
|
||||||
|
#include <chrono>
|
||||||
|
#include <iostream>
|
||||||
|
#include <string>
|
||||||
|
+#include <optional>
|
||||||
|
#include <sys/time.h>
|
||||||
|
|
||||||
|
#include "include/ceph_assert.h"
|
21
0005-src-CMakeLists.txt.patch
Normal file
21
0005-src-CMakeLists.txt.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- ceph-15.2.8/src/CMakeLists.txt.orig 2021-01-03 12:47:00.275274985 -0500
|
||||||
|
+++ ceph-15.2.8/src/CMakeLists.txt 2021-01-03 12:51:17.957185433 -0500
|
||||||
|
@@ -23,10 +23,15 @@
|
||||||
|
set(datadir ${CEPH_INSTALL_DATADIR})
|
||||||
|
set(prefix ${CMAKE_INSTALL_PREFIX})
|
||||||
|
|
||||||
|
-add_definitions("-DHAVE_CONFIG_H -D__CEPH__ -D_REENTRANT -D_THREAD_SAFE -D__STDC_FORMAT_MACROS")
|
||||||
|
-add_definitions("-D_FILE_OFFSET_BITS=64")
|
||||||
|
+add_definitions(-DHAVE_CONFIG_H
|
||||||
|
+ -D__CEPH__
|
||||||
|
+ -D_REENTRANT
|
||||||
|
+ -D_THREAD_SAFE
|
||||||
|
+ -D__STDC_FORMAT_MACROS
|
||||||
|
+ -D_FILE_OFFSET_BITS=64
|
||||||
|
+ -DBOOST_ASIO_DISABLE_THREAD_KEYWORD_EXTENSION)
|
||||||
|
if(LINUX)
|
||||||
|
- add_definitions("-D_GNU_SOURCE")
|
||||||
|
+ add_definitions(-D_GNU_SOURCE)
|
||||||
|
endif()
|
||||||
|
|
||||||
|
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
|
64
0006-src-rgw-rgw_asio_frontend.cc.patch
Normal file
64
0006-src-rgw-rgw_asio_frontend.cc.patch
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
--- ceph-15.2.8/src/rgw/rgw_asio_frontend.cc.orig 2020-12-16 12:29:50.000000000 -0500
|
||||||
|
+++ ceph-15.2.8/src/rgw/rgw_asio_frontend.cc 2021-01-04 18:20:49.156104233 -0500
|
||||||
|
@@ -2,6 +2,7 @@
|
||||||
|
// vim: ts=8 sw=2 smarttab ft=cpp
|
||||||
|
|
||||||
|
#include <atomic>
|
||||||
|
+#include <ctime>
|
||||||
|
#include <thread>
|
||||||
|
#include <vector>
|
||||||
|
|
||||||
|
@@ -138,6 +139,29 @@
|
||||||
|
return out << h.quote << p->value() << h.quote;
|
||||||
|
}
|
||||||
|
|
||||||
|
+// log fractional seconds in milliseconds
|
||||||
|
+struct log_ms_remainder {
|
||||||
|
+ ceph::coarse_real_time t;
|
||||||
|
+ log_ms_remainder(ceph::coarse_real_time t) : t(t) {}
|
||||||
|
+};
|
||||||
|
+std::ostream& operator<<(std::ostream& out, const log_ms_remainder& m) {
|
||||||
|
+ using namespace std::chrono;
|
||||||
|
+ return out << std::setfill('0') << std::setw(3)
|
||||||
|
+ << duration_cast<milliseconds>(m.t.time_since_epoch()).count() % 1000;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+// log time in apache format: day/month/year:hour:minute:second zone
|
||||||
|
+struct log_apache_time {
|
||||||
|
+ ceph::coarse_real_time t;
|
||||||
|
+ log_apache_time(ceph::coarse_real_time t) : t(t) {}
|
||||||
|
+};
|
||||||
|
+std::ostream& operator<<(std::ostream& out, const log_apache_time& a) {
|
||||||
|
+ const auto t = ceph::coarse_real_clock::to_time_t(a.t);
|
||||||
|
+ const auto local = std::localtime(&t);
|
||||||
|
+ return out << std::put_time(local, "%d/%b/%Y:%T.") << log_ms_remainder{a.t}
|
||||||
|
+ << std::put_time(local, " %z");
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
using SharedMutex = ceph::async::SharedMutex<boost::asio::io_context::executor_type>;
|
||||||
|
|
||||||
|
template <typename Stream>
|
||||||
|
@@ -228,16 +252,20 @@
|
||||||
|
RGWRestfulIO client(cct, &real_client_io);
|
||||||
|
auto y = optional_yield{context, yield};
|
||||||
|
int http_ret = 0;
|
||||||
|
+ string user = "-";
|
||||||
|
+ const auto started = ceph::coarse_real_clock::now();
|
||||||
|
+
|
||||||
|
process_request(env.store, env.rest, &req, env.uri_prefix,
|
||||||
|
*env.auth_registry, &client, env.olog, y,
|
||||||
|
scheduler, &http_ret);
|
||||||
|
|
||||||
|
if (cct->_conf->subsys.should_gather(dout_subsys, 1)) {
|
||||||
|
// access log line elements begin per Apache Combined Log Format with additions following
|
||||||
|
- const auto now = ceph::coarse_real_clock::now();
|
||||||
|
- using ceph::operator<<; // for coarse_real_time
|
||||||
|
+ // const auto now = ceph::coarse_real_clock::now();
|
||||||
|
+ // using ceph::operator<<; // for coarse_real_time
|
||||||
|
ldout(cct, 1) << "beast: " << hex << &req << dec << ": "
|
||||||
|
- << remote_endpoint.address() << " - - [" << now << "] \""
|
||||||
|
+ // << remote_endpoint.address() << " - - [" << now << "] \""
|
||||||
|
+ << remote_endpoint.address() << " - " << user << " [" << log_apache_time{started} << "] \""
|
||||||
|
<< message.method_string() << ' ' << message.target() << ' '
|
||||||
|
<< http_version{message.version()} << "\" " << http_ret << ' '
|
||||||
|
<< client.get_bytes_sent() + client.get_bytes_received() << ' '
|
@ -121,6 +121,9 @@ Source0: %{?_remote_tarball_prefix}ceph-%{version}.tar.gz
|
|||||||
Patch0001: 0001-src-common-crc32c_intel_fast.patch
|
Patch0001: 0001-src-common-crc32c_intel_fast.patch
|
||||||
Patch0002: 0002-src-common-CMakeLists.txt.patch
|
Patch0002: 0002-src-common-CMakeLists.txt.patch
|
||||||
Patch0003: 0003-src-common-bitstr.h.patch
|
Patch0003: 0003-src-common-bitstr.h.patch
|
||||||
|
Patch0004: 0004-src-common-ceph-time.h.patch
|
||||||
|
Patch0005: 0005-src-CMakeLists.txt.patch
|
||||||
|
Patch0006: 0006-src-rgw-rgw_asio_frontend.cc.patch
|
||||||
Source1: cmake-modules-BuildBoost.cmake.noautopatch
|
Source1: cmake-modules-BuildBoost.cmake.noautopatch
|
||||||
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
||||||
ExcludeArch: i686 armv7hl
|
ExcludeArch: i686 armv7hl
|
||||||
@ -1278,7 +1281,7 @@ cat ./CMakeFiles/CMakeError.log
|
|||||||
|
|
||||||
export VERBOSE=1
|
export VERBOSE=1
|
||||||
export V=1
|
export V=1
|
||||||
%cmake_build "$CEPH_MFLAGS_JOBS"
|
%cmake_build
|
||||||
|
|
||||||
|
|
||||||
%if 0%{with make_check}
|
%if 0%{with make_check}
|
||||||
|
Loading…
Reference in New Issue
Block a user