17.1.0 snapshot 175
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
944b374961
commit
edd18f65bf
@ -0,0 +1,11 @@
|
|||||||
|
--- ceph-17.1.0-175-g086c8f84/src/arrow/cpp/cmake_modules/ThirdpartyToolchain.cmake.orig 2022-04-08 11:27:53.593570634 -0400
|
||||||
|
+++ ceph-17.1.0-175-g086c8f84/src/arrow/cpp/cmake_modules/ThirdpartyToolchain.cmake 2022-04-08 11:28:20.778087653 -0400
|
||||||
|
@@ -1991,7 +1991,7 @@
|
||||||
|
|
||||||
|
if((NOT ARROW_SIMD_LEVEL STREQUAL "NONE") OR (NOT ARROW_RUNTIME_SIMD_LEVEL STREQUAL "NONE"
|
||||||
|
))
|
||||||
|
- set(xsimd_SOURCE "BUNDLED")
|
||||||
|
+ set(xsimd_SOURCE "SYSTEM")
|
||||||
|
resolve_dependency(xsimd)
|
||||||
|
# TODO: Don't use global includes but rather target_include_directories
|
||||||
|
include_directories(SYSTEM ${XSIMD_INCLUDE_DIR})
|
35
ceph.spec
35
ceph.spec
@ -101,6 +101,8 @@
|
|||||||
# distros that do _not_ ship cmd2/colorama
|
# distros that do _not_ ship cmd2/colorama
|
||||||
%bcond_with cephfs_shell
|
%bcond_with cephfs_shell
|
||||||
%endif
|
%endif
|
||||||
|
%bcond_with system_arrow
|
||||||
|
%bcond_without system_utf8proc
|
||||||
%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 8
|
||||||
%global weak_deps 1
|
%global weak_deps 1
|
||||||
%endif
|
%endif
|
||||||
@ -151,7 +153,7 @@
|
|||||||
#################################################################################
|
#################################################################################
|
||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 17.1.0
|
Version: 17.1.0
|
||||||
Release: 0.7.123.g14f44febd%{?dist}
|
Release: 0.9.175.g086c8f84%{?dist}
|
||||||
%if 0%{?fedora} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
%endif
|
%endif
|
||||||
@ -169,7 +171,7 @@ Group: System/Filesystems
|
|||||||
URL: http://ceph.com/
|
URL: http://ceph.com/
|
||||||
#Source0: https://download.ceph.com/tarballs/ceph-%{version}.tar.gz
|
#Source0: https://download.ceph.com/tarballs/ceph-%{version}.tar.gz
|
||||||
#Source0: https://1.chacra.ceph.com/r/ceph/quincy/...
|
#Source0: https://1.chacra.ceph.com/r/ceph/quincy/...
|
||||||
Source0: ceph-17.1.0-123-g14f44feb.tar.bz2
|
Source0: ceph-17.1.0-175-g086c8f84.tar.bz2
|
||||||
Patch0001: 0001-src-common-crc32c_intel_fast.patch
|
Patch0001: 0001-src-common-crc32c_intel_fast.patch
|
||||||
Patch0003: 0003-src-common-bitstr.h.patch
|
Patch0003: 0003-src-common-bitstr.h.patch
|
||||||
Patch0008: 0008-cmake-modules-Finduring.cmake.patch
|
Patch0008: 0008-cmake-modules-Finduring.cmake.patch
|
||||||
@ -180,6 +182,7 @@ Patch0016: 0016-src-tracing-patch
|
|||||||
Patch0017: 0017-gcc-12-omnibus.patch
|
Patch0017: 0017-gcc-12-omnibus.patch
|
||||||
Patch0018: 0018-src-rgw-store-dbstore-CMakeLists.txt.patch
|
Patch0018: 0018-src-rgw-store-dbstore-CMakeLists.txt.patch
|
||||||
Patch0019: 0019-cmake-modules-CheckCxxAtomic.cmake.patch
|
Patch0019: 0019-cmake-modules-CheckCxxAtomic.cmake.patch
|
||||||
|
Patch0020: 0020-src-arrow-cpp-cmake_modules-ThirdpartyToolchain.cmake.patch
|
||||||
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
||||||
ExcludeArch: i686 armv7hl
|
ExcludeArch: i686 armv7hl
|
||||||
%if 0%{?suse_version}
|
%if 0%{?suse_version}
|
||||||
@ -218,6 +221,7 @@ BuildRequires: mold
|
|||||||
# libprofiler did not build on ppc64le until 2.7.90
|
# libprofiler did not build on ppc64le until 2.7.90
|
||||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
BuildRequires: gperftools-devel >= 2.7.90
|
BuildRequires: gperftools-devel >= 2.7.90
|
||||||
|
BuildRequires: libunwind-devel
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||||
BuildRequires: gperftools-devel >= 2.6.1
|
BuildRequires: gperftools-devel >= 2.6.1
|
||||||
@ -292,10 +296,11 @@ BuildRequires: socat
|
|||||||
%if 0%{with zbd}
|
%if 0%{with zbd}
|
||||||
BuildRequires: libzbd-devel
|
BuildRequires: libzbd-devel
|
||||||
%endif
|
%endif
|
||||||
|
BuildRequires: thrift-devel >= 0.13.0
|
||||||
|
BuildRequires: re2-devel
|
||||||
%if 0%{with jaeger}
|
%if 0%{with jaeger}
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: thrift-devel >= 0.13.0
|
|
||||||
%if 0%{?fedora} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
BuildRequires: json-devel
|
BuildRequires: json-devel
|
||||||
%endif
|
%endif
|
||||||
@ -308,6 +313,15 @@ BuildRequires: libevent-devel
|
|||||||
BuildRequires: libpmem-devel
|
BuildRequires: libpmem-devel
|
||||||
BuildRequires: libpmemobj-devel
|
BuildRequires: libpmemobj-devel
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{with system_arrow}
|
||||||
|
BuildRequires: arrow-devel
|
||||||
|
BuildRequires: parquet-devel
|
||||||
|
%else
|
||||||
|
BuildRequires: xsimd-devel
|
||||||
|
%endif
|
||||||
|
%if 0%{with system_utf8proc}
|
||||||
|
BuildRequires: utf8proc-devel
|
||||||
|
%endif
|
||||||
%if 0%{with seastar}
|
%if 0%{with seastar}
|
||||||
BuildRequires: c-ares-devel
|
BuildRequires: c-ares-devel
|
||||||
BuildRequires: gnutls-devel
|
BuildRequires: gnutls-devel
|
||||||
@ -1255,7 +1269,7 @@ This package provides Ceph default alerts for Prometheus.
|
|||||||
# common
|
# common
|
||||||
#################################################################################
|
#################################################################################
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1 -n ceph-17.1.0-123-g14f44feb
|
%autosetup -p1 -n ceph-17.1.0-175-g086c8f84
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Disable lto on systems that do not support symver attribute
|
# Disable lto on systems that do not support symver attribute
|
||||||
@ -1288,6 +1302,9 @@ export LDFLAGS="$RPM_LD_FLAGS"
|
|||||||
%if 0%{with seastar}
|
%if 0%{with seastar}
|
||||||
# seastar uses longjmp() to implement coroutine. and this annoys longjmp_chk()
|
# seastar uses longjmp() to implement coroutine. and this annoys longjmp_chk()
|
||||||
export CXXFLAGS=$(echo $RPM_OPT_FLAGS | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2//g')
|
export CXXFLAGS=$(echo $RPM_OPT_FLAGS | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2//g')
|
||||||
|
# remove from CFLAGS too because it causes the arrow submodule to fail with:
|
||||||
|
# warning _FORTIFY_SOURCE requires compiling with optimization (-O)
|
||||||
|
export CFLAGS=$(echo $RPM_OPT_FLAGS | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2//g')
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
env | sort
|
env | sort
|
||||||
@ -1298,7 +1315,6 @@ env | sort
|
|||||||
%{cmake} \
|
%{cmake} \
|
||||||
-GNinja \
|
-GNinja \
|
||||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
-DCMAKE_COLOR_MAKEFILE:BOOL=OFF \
|
|
||||||
-DBUILD_CONFIG=rpmbuild \
|
-DBUILD_CONFIG=rpmbuild \
|
||||||
-DSYSTEMD_SYSTEM_UNIT_DIR:PATH=%{_unitdir} \
|
-DSYSTEMD_SYSTEM_UNIT_DIR:PATH=%{_unitdir} \
|
||||||
-DCMAKE_INSTALL_SYSCONFDIR:PATH=%{_sysconfdir} \
|
-DCMAKE_INSTALL_SYSCONFDIR:PATH=%{_sysconfdir} \
|
||||||
@ -1381,6 +1397,12 @@ env | sort
|
|||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
-DWITH_FMT_HEADER_ONLY:BOOL=ON \
|
-DWITH_FMT_HEADER_ONLY:BOOL=ON \
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{with system_arrow}
|
||||||
|
-DWITH_SYSTEM_ARROW:BOOL=ON \
|
||||||
|
%endif
|
||||||
|
%if 0%{with system_utf8proc}
|
||||||
|
-DWITH_SYSTEM_UTF8PROC:BOOL=ON \
|
||||||
|
%endif
|
||||||
%ifarch x86_64 aarch64
|
%ifarch x86_64 aarch64
|
||||||
-DCMAKE_LINKER=%{_bindir}/ld.mold \
|
-DCMAKE_LINKER=%{_bindir}/ld.mold \
|
||||||
%endif
|
%endif
|
||||||
@ -2547,6 +2569,9 @@ exit 0
|
|||||||
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
|
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 8 2022 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.1.0-0.9.175.g086c8f84
|
||||||
|
- 17.1.0 snapshot 175
|
||||||
|
|
||||||
* Mon Mar 28 2022 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.1.0-0.7.123.g14f44feb
|
* Mon Mar 28 2022 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.1.0-0.7.123.g14f44feb
|
||||||
- 17.1.0 snapshot 123
|
- 17.1.0 snapshot 123
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (ceph-17.1.0-123-g14f44feb.tar.bz2) = c2ab2c271e140a4aed3de0a8fad490ab8cb666759484199a9c89325cd0d11a2c5b93ec3b59ec47556f21df86a3035ce08838ba3e14062e8b073bb45fe2d6e0a0
|
SHA512 (ceph-17.1.0-175-g086c8f84.tar.bz2) = f40e8e5dbfef6591bcbe084f2c34afc03311dcac12b5dfe3d77d0cc8db9b10632a1bd12145dea579d93f0d6e6e742f53726e12efd544cee1eb6c416d46ac8a28
|
||||||
|
Loading…
Reference in New Issue
Block a user