ceph 15.1.0, rhbz#1809799
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
a09febb7ef
commit
d6834c5aab
13
0001-cmake-modules-BuildBoost.cmake.patch
Normal file
13
0001-cmake-modules-BuildBoost.cmake.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/cmake/modules/BuildBoost.cmake b/cmake/modules/BuildBoost.cmake
|
||||||
|
index 2e92132366..3cb1e3d958 100644
|
||||||
|
--- a/cmake/modules/BuildBoost.cmake
|
||||||
|
+++ b/cmake/modules/BuildBoost.cmake
|
||||||
|
@@ -62,7 +62,7 @@ function(do_build_boost version)
|
||||||
|
else()
|
||||||
|
list(APPEND boost_features "address-model=32")
|
||||||
|
endif()
|
||||||
|
- set(BOOST_CXXFLAGS "-fPIC -w") # check on arm, etc <---XXX
|
||||||
|
+ set(BOOST_CXXFLAGS "-fPIC -w -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -ftemplate-depth-1024 -fno-new-ttp-matching -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free") # check on arm, etc <---XXX
|
||||||
|
list(APPEND boost_features "cxxflags=${BOOST_CXXFLAGS}")
|
||||||
|
|
||||||
|
set(boost_with_libs)
|
@ -56,19 +56,6 @@
|
|||||||
+
|
+
|
||||||
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
|
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
|
||||||
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
|
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
|
||||||
diff --git a/cmake/modules/BuildBoost.cmake b/cmake/modules/BuildBoost.cmake
|
|
||||||
index 2e92132366..3cb1e3d958 100644
|
|
||||||
--- a/cmake/modules/BuildBoost.cmake
|
|
||||||
+++ b/cmake/modules/BuildBoost.cmake
|
|
||||||
@@ -62,7 +62,7 @@ function(do_build_boost version)
|
|
||||||
else()
|
|
||||||
list(APPEND boost_features "address-model=32")
|
|
||||||
endif()
|
|
||||||
- set(BOOST_CXXFLAGS "-fPIC -w") # check on arm, etc <---XXX
|
|
||||||
+ set(BOOST_CXXFLAGS "-fPIC -w -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -ftemplate-depth-1024 -fno-new-ttp-matching -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free") # check on arm, etc <---XXX
|
|
||||||
list(APPEND boost_features "cxxflags=${BOOST_CXXFLAGS}")
|
|
||||||
|
|
||||||
set(boost_with_libs)
|
|
||||||
--- ceph-15.1.0/src/yasm-wrapper.orig 2020-03-09 12:57:37.603837466 -0400
|
--- ceph-15.1.0/src/yasm-wrapper.orig 2020-03-09 12:57:37.603837466 -0400
|
||||||
+++ ceph-15.1.0/src/yasm-wrapper 2020-03-09 13:02:31.496796609 -0400
|
+++ ceph-15.1.0/src/yasm-wrapper 2020-03-09 13:02:31.496796609 -0400
|
||||||
@@ -1,10 +1,11 @@
|
@@ -1,10 +1,11 @@
|
||||||
|
@ -130,6 +130,7 @@ Patch0001: 0001-src-common-crc32c_intel_fast.patch
|
|||||||
Patch0002: 0002-src-common-CMakeLists.txt.patch
|
Patch0002: 0002-src-common-CMakeLists.txt.patch
|
||||||
Patch0003: 0003-src-common-bitstr.h.patch
|
Patch0003: 0003-src-common-bitstr.h.patch
|
||||||
Patch0004: 0004-src-test-rgw-test_rgw_reshart_wait.cc.patch
|
Patch0004: 0004-src-test-rgw-test_rgw_reshart_wait.cc.patch
|
||||||
|
Patch0005: 0001-cmake-modules-BuildBoost.cmake.patch
|
||||||
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
||||||
ExcludeArch: i686 armv7hl
|
ExcludeArch: i686 armv7hl
|
||||||
#################################################################################
|
#################################################################################
|
||||||
|
Loading…
Reference in New Issue
Block a user