Updating to 0.37
Fixing bugs 745462, 745460, 691033, 748930, 747101
This commit is contained in:
parent
b89a3dc9a3
commit
d10f18bd8e
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ ceph-0.20.tar.gz
|
|||||||
/ceph-0.25.1.tar.gz
|
/ceph-0.25.1.tar.gz
|
||||||
/ceph-0.26.tar.gz
|
/ceph-0.26.tar.gz
|
||||||
/ceph-0.31.tar.gz
|
/ceph-0.31.tar.gz
|
||||||
|
/ceph-0.37.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up ceph-0.31/src/rgw/rgw_os.cc.compilefix ceph-0.31/src/rgw/rgw_os.cc
|
|
||||||
--- ceph-0.31/src/rgw/rgw_os.cc.compilefix 2011-07-12 16:33:05.015272759 -0400
|
|
||||||
+++ ceph-0.31/src/rgw/rgw_os.cc 2011-07-12 16:33:11.849133140 -0400
|
|
||||||
@@ -3,7 +3,6 @@
|
|
||||||
#include <unistd.h>
|
|
||||||
|
|
||||||
#include <curl/curl.h>
|
|
||||||
-#include <curl/types.h>
|
|
||||||
#include <curl/easy.h>
|
|
||||||
|
|
||||||
#include "rgw_common.h"
|
|
14
ceph.logrotate.patch
Normal file
14
ceph.logrotate.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- src/logrotate.conf 2011-07-30 16:50:50.000000000 -0400
|
||||||
|
+++ src/logrotate.conf.new 2011-11-05 17:41:02.567151275 -0400
|
||||||
|
@@ -1,9 +1,10 @@
|
||||||
|
/var/log/ceph/*.log {
|
||||||
|
rotate 7
|
||||||
|
daily
|
||||||
|
+ missingok
|
||||||
|
compress
|
||||||
|
sharedscripts
|
||||||
|
postrotate
|
||||||
|
- invoke-rc.d ceph reload >/dev/null || service ceph reload >/dev/null
|
||||||
|
+ service ceph reload >/dev/null 2>/dev/null || true
|
||||||
|
endscript
|
||||||
|
}
|
81
ceph.spec
81
ceph.spec
@ -1,6 +1,6 @@
|
|||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 0.31
|
Version: 0.37
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: User space components of the Ceph file system
|
Summary: User space components of the Ceph file system
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -8,7 +8,7 @@ URL: http://ceph.newdream.net/
|
|||||||
|
|
||||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.gz
|
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.gz
|
||||||
Patch0: ceph-init-fix.patch
|
Patch0: ceph-init-fix.patch
|
||||||
Patch1: ceph-compilefix.patch
|
Patch1: ceph.logrotate.patch
|
||||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm,
|
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm,
|
||||||
# google-perftools is not available on these:
|
# google-perftools is not available on these:
|
||||||
@ -78,7 +78,7 @@ file system.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .init
|
%patch0 -p1 -b .init
|
||||||
%patch1 -p1 -b .compilefix
|
%patch1 -p0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -88,7 +88,7 @@ file system.
|
|||||||
--without-tcmalloc \
|
--without-tcmalloc \
|
||||||
%endif
|
%endif
|
||||||
--without-hadoop --with-radosgw --with-gtk2
|
--without-hadoop --with-radosgw --with-gtk2
|
||||||
make CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -101,7 +101,8 @@ install -m 0644 -D src/logrotate.conf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/
|
|||||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/ceph/tmp/
|
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/ceph/tmp/
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/
|
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/stat
|
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/stat
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/ceph
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -124,61 +125,65 @@ fi
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc README COPYING
|
%doc README COPYING
|
||||||
|
%dir %{_sysconfdir}/ceph
|
||||||
%{_bindir}/ceph
|
%{_bindir}/ceph
|
||||||
%{_bindir}/cephfs
|
%{_bindir}/cephfs
|
||||||
%{_bindir}/cconf
|
%{_bindir}/ceph-conf
|
||||||
%{_bindir}/cclsinfo
|
%{_bindir}/ceph-clsinfo
|
||||||
%{_bindir}/crushtool
|
%{_bindir}/crushtool
|
||||||
%{_bindir}/monmaptool
|
%{_bindir}/monmaptool
|
||||||
%{_bindir}/osdmaptool
|
%{_bindir}/osdmaptool
|
||||||
%{_bindir}/cauthtool
|
%{_bindir}/ceph-authtool
|
||||||
%{_bindir}/csyn
|
%{_bindir}/ceph-syn
|
||||||
%{_bindir}/crun
|
%{_bindir}/ceph-run
|
||||||
%{_bindir}/cmon
|
%{_bindir}/ceph-mon
|
||||||
%{_bindir}/cmds
|
%{_bindir}/ceph-mds
|
||||||
%{_bindir}/cosd
|
%{_bindir}/ceph-osd
|
||||||
%{_bindir}/crbdnamer
|
%{_bindir}/ceph-rbdnamer
|
||||||
%{_bindir}/librados-config
|
%{_bindir}/librados-config
|
||||||
%{_bindir}/rados
|
%{_bindir}/rados
|
||||||
%{_bindir}/rbd
|
%{_bindir}/rbd
|
||||||
%{_bindir}/cdebugpack
|
%{_bindir}/ceph-debugpack
|
||||||
%{_bindir}/ceph-coverage
|
%{_bindir}/ceph-coverage
|
||||||
%{_initrddir}/ceph
|
%{_initrddir}/ceph
|
||||||
%{_libdir}/libceph.so.*
|
%{_libdir}/libcephfs.so.*
|
||||||
%{_libdir}/librados.so.*
|
%{_libdir}/librados.so.*
|
||||||
%{_libdir}/librbd.so.*
|
%{_libdir}/librbd.so.*
|
||||||
%{_libdir}/librgw.so.*
|
%{_libdir}/librgw.so.*
|
||||||
%{_libdir}/rados-classes/libcls_rbd.so.*
|
%{_libdir}/rados-classes/libcls_rbd.so.*
|
||||||
|
%{_libdir}/rados-classes/libcls_rgw.so*
|
||||||
/sbin/mkcephfs
|
/sbin/mkcephfs
|
||||||
/sbin/mount.ceph
|
/sbin/mount.ceph
|
||||||
%{_libdir}/ceph
|
%{_libdir}/ceph
|
||||||
%{_docdir}/ceph/sample.ceph.conf
|
%{_docdir}/ceph/sample.ceph.conf
|
||||||
%{_docdir}/ceph/sample.fetch_config
|
%{_docdir}/ceph/sample.fetch_config
|
||||||
%config(noreplace) %{_sysconfdir}/logrotate.d/ceph
|
%config(noreplace) %{_sysconfdir}/logrotate.d/ceph
|
||||||
%{_mandir}/man8/cmon.8*
|
%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
|
||||||
%{_mandir}/man8/cmds.8*
|
%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
|
||||||
%{_mandir}/man8/cosd.8*
|
%config(noreplace) %{_sysconfdir}/bash_completion.d/rbd
|
||||||
|
%{_mandir}/man8/ceph-mon.8*
|
||||||
|
%{_mandir}/man8/ceph-mds.8*
|
||||||
|
%{_mandir}/man8/ceph-osd.8*
|
||||||
%{_mandir}/man8/mkcephfs.8*
|
%{_mandir}/man8/mkcephfs.8*
|
||||||
%{_mandir}/man8/crun.8*
|
%{_mandir}/man8/ceph-run.8*
|
||||||
%{_mandir}/man8/csyn.8*
|
%{_mandir}/man8/ceph-syn.8*
|
||||||
%{_mandir}/man8/crushtool.8*
|
%{_mandir}/man8/crushtool.8*
|
||||||
%{_mandir}/man8/osdmaptool.8*
|
%{_mandir}/man8/osdmaptool.8*
|
||||||
%{_mandir}/man8/monmaptool.8*
|
%{_mandir}/man8/monmaptool.8*
|
||||||
%{_mandir}/man8/cconf.8*
|
%{_mandir}/man8/ceph-conf.8*
|
||||||
%{_mandir}/man8/ceph.8*
|
%{_mandir}/man8/ceph.8*
|
||||||
%{_mandir}/man8/cephfs.8*
|
%{_mandir}/man8/cephfs.8*
|
||||||
%{_mandir}/man8/mount.ceph.8*
|
%{_mandir}/man8/mount.ceph.8*
|
||||||
%{_mandir}/man8/radosgw.8*
|
%{_mandir}/man8/radosgw.8*
|
||||||
%{_mandir}/man8/radosgw_admin.8*
|
%{_mandir}/man8/radosgw-admin.8*
|
||||||
%{_mandir}/man8/rados.8*
|
%{_mandir}/man8/rados.8*
|
||||||
%{_mandir}/man8/rbd.8*
|
%{_mandir}/man8/rbd.8*
|
||||||
%{_mandir}/man8/cauthtool.8*
|
%{_mandir}/man8/ceph-authtool.8*
|
||||||
%{_mandir}/man8/cdebugpack.8*
|
%{_mandir}/man8/ceph-debugpack.8*
|
||||||
%{_mandir}/man8/cclsinfo.8.gz
|
%{_mandir}/man8/ceph-clsinfo.8.gz
|
||||||
%{python_sitelib}/rados.py
|
%{python_sitelib}/rados.py*
|
||||||
%{python_sitelib}/rados.pyc
|
|
||||||
%{python_sitelib}/rados.pyo
|
|
||||||
%{python_sitelib}/rgw.py*
|
%{python_sitelib}/rgw.py*
|
||||||
|
%{python_sitelib}/rbd.py*
|
||||||
%dir %{_localstatedir}/lib/ceph/
|
%dir %{_localstatedir}/lib/ceph/
|
||||||
%dir %{_localstatedir}/lib/ceph/tmp/
|
%dir %{_localstatedir}/lib/ceph/tmp/
|
||||||
%dir %{_localstatedir}/log/ceph/
|
%dir %{_localstatedir}/log/ceph/
|
||||||
@ -186,13 +191,13 @@ fi
|
|||||||
%files fuse
|
%files fuse
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
%{_bindir}/cfuse
|
%{_bindir}/ceph-fuse
|
||||||
%{_mandir}/man8/cfuse.8*
|
%{_mandir}/man8/ceph-fuse.8*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
%{_includedir}/ceph/libceph.h
|
%{_includedir}/cephfs/libcephfs.h
|
||||||
%{_includedir}/crush/crush.h
|
%{_includedir}/crush/crush.h
|
||||||
%{_includedir}/crush/hash.h
|
%{_includedir}/crush/hash.h
|
||||||
%{_includedir}/crush/mapper.h
|
%{_includedir}/crush/mapper.h
|
||||||
@ -205,7 +210,7 @@ fi
|
|||||||
%{_includedir}/rados/librgw.h
|
%{_includedir}/rados/librgw.h
|
||||||
%{_includedir}/rbd/librbd.h
|
%{_includedir}/rbd/librbd.h
|
||||||
%{_includedir}/rbd/librbd.hpp
|
%{_includedir}/rbd/librbd.hpp
|
||||||
%{_libdir}/libceph.so
|
%{_libdir}/libcephfs.so
|
||||||
%{_libdir}/librados.so
|
%{_libdir}/librados.so
|
||||||
%{_libdir}/librgw.so
|
%{_libdir}/librgw.so
|
||||||
%{_libdir}/librbd.so*
|
%{_libdir}/librbd.so*
|
||||||
@ -220,7 +225,8 @@ fi
|
|||||||
%files radosgw
|
%files radosgw
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/radosgw
|
%{_bindir}/radosgw
|
||||||
%{_bindir}/radosgw_admin
|
%{_bindir}/radosgw-admin
|
||||||
|
%{_sysconfdir}/bash_completion.d/radosgw-admin
|
||||||
|
|
||||||
%files obsync
|
%files obsync
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -228,6 +234,11 @@ fi
|
|||||||
%{_bindir}/boto_tool
|
%{_bindir}/boto_tool
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 05 2011 David Nalley <david@gnsa.us> 0.37-1
|
||||||
|
- create /etc/ceph - bug 745462
|
||||||
|
- upgrading to 0.37, fixing 745460, 691033
|
||||||
|
- fixing various logrotate bugs 748930, 747101
|
||||||
|
|
||||||
* Fri Aug 19 2011 Dan Horák <dan[at]danny.cz> 0.31-4
|
* Fri Aug 19 2011 Dan Horák <dan[at]danny.cz> 0.31-4
|
||||||
- google-perftools not available also on s390(x)
|
- google-perftools not available also on s390(x)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user