Update to 0.21.1.
This commit is contained in:
parent
c87f553439
commit
cf2b700b23
@ -1,9 +1,9 @@
|
|||||||
diff -up ceph-0.20/src/init-ceph.in.init ceph-0.20/src/init-ceph.in
|
--- ceph-0.21.1/src/init-ceph.in.orig 2010-07-29 15:16:49.000000000 -0500
|
||||||
--- ceph-0.20/src/init-ceph.in.init 2010-04-22 16:11:34.000000000 -0400
|
+++ ceph-0.21.1/src/init-ceph.in 2010-08-26 14:58:25.328581937 -0500
|
||||||
+++ ceph-0.20/src/init-ceph.in 2010-05-05 15:37:11.185677759 -0400
|
@@ -1,11 +1,11 @@
|
||||||
@@ -1,10 +1,11 @@
|
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
# Start/stop ceph daemons
|
# Start/stop ceph daemons
|
||||||
|
-# chkconfig: 2345 60 80
|
||||||
+# chkconfig: - 60 80
|
+# chkconfig: - 60 80
|
||||||
|
|
||||||
### BEGIN INIT INFO
|
### BEGIN INIT INFO
|
||||||
@ -15,48 +15,3 @@ diff -up ceph-0.20/src/init-ceph.in.init ceph-0.20/src/init-ceph.in
|
|||||||
# Required-Start: $remote_fs $named $network $time
|
# Required-Start: $remote_fs $named $network $time
|
||||||
# Required-Stop: $remote_fs $named $network $time
|
# Required-Stop: $remote_fs $named $network $time
|
||||||
# Short-Description: Start Ceph distributed file system daemons at boot time
|
# Short-Description: Start Ceph distributed file system daemons at boot time
|
||||||
@@ -28,6 +29,8 @@ else
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
+lockfile=/var/lock/subsys/ceph
|
|
||||||
+
|
|
||||||
usage_exit() {
|
|
||||||
echo "usage: $0 [options] {start|stop|restart} [mon|osd|mds]..."
|
|
||||||
printf "\t-c ceph.conf\n"
|
|
||||||
@@ -244,6 +247,7 @@ for name in $what; do
|
|
||||||
[ -n "$pre_start" ] && do_cmd "$pre_start"
|
|
||||||
do_cmd "$cmd" $runarg
|
|
||||||
[ -n "$post_start" ] && do_cmd "$post_start"
|
|
||||||
+ [ "$?" = 0 ] && touch $lockfile
|
|
||||||
;;
|
|
||||||
|
|
||||||
stop)
|
|
||||||
@@ -252,19 +256,27 @@ for name in $what; do
|
|
||||||
[ -n "$pre_stop" ] && do_cmd "$pre_stop"
|
|
||||||
stop_daemon $name c$type $pid_file
|
|
||||||
[ -n "$post_stop" ] && do_cmd "$post_stop"
|
|
||||||
+ [ "$?" = 0 ] && rm -f $lockfile
|
|
||||||
;;
|
|
||||||
|
|
||||||
+ status)
|
|
||||||
+ pid=`cat $pid_file`
|
|
||||||
+ ps $pid &> /dev/null
|
|
||||||
+ exit $?
|
|
||||||
+ ;;
|
|
||||||
forcestop)
|
|
||||||
get_conf pre_forcestop "" "pre forcestop command"
|
|
||||||
get_conf post_forcestop "" "post forcestop command"
|
|
||||||
[ -n "$pre_forcestop" ] && do_cmd "$pre_forcestop"
|
|
||||||
stop_daemon $name c$type $pid_file -9
|
|
||||||
[ -n "$post_forcestop" ] && do_cmd "$post_forcestop"
|
|
||||||
+ [ "$?" = 0 ] && rm -f $lockfile
|
|
||||||
;;
|
|
||||||
|
|
||||||
killall)
|
|
||||||
echo "killall c$type on $host"
|
|
||||||
do_cmd "pkill ^c$type || true"
|
|
||||||
+ [ "$?" = 0 ] && rm -f $lockfile
|
|
||||||
;;
|
|
||||||
|
|
||||||
force-reload | reload)
|
|
||||||
|
34
ceph.spec
34
ceph.spec
@ -1,5 +1,5 @@
|
|||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 0.20.2
|
Version: 0.21.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: User space components of the Ceph file system
|
Summary: User space components of the Ceph file system
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
@ -52,7 +52,6 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
|||||||
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
||||||
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
|
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
|
||||||
install -D src/init-ceph $RPM_BUILD_ROOT%{_initddir}/ceph
|
install -D src/init-ceph $RPM_BUILD_ROOT%{_initddir}/ceph
|
||||||
chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/ceph/sample.ceph.conf
|
|
||||||
|
|
||||||
# remove debug binaries
|
# remove debug binaries
|
||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/dumpjournal
|
rm -f $RPM_BUILD_ROOT%{_bindir}/dumpjournal
|
||||||
@ -68,6 +67,10 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/testmsgr
|
|||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/testrados
|
rm -f $RPM_BUILD_ROOT%{_bindir}/testrados
|
||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/testradospp
|
rm -f $RPM_BUILD_ROOT%{_bindir}/testradospp
|
||||||
|
|
||||||
|
# Drop rados-classes directory
|
||||||
|
mv -f $RPM_BUILD_ROOT%{_libdir}/rados-classes/* $RPM_BUILD_ROOT%{_libdir}/
|
||||||
|
rmdir $RPM_BUILD_ROOT%{_libdir}/rados-classes
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -101,24 +104,26 @@ fi
|
|||||||
%{_bindir}/cmon
|
%{_bindir}/cmon
|
||||||
%{_bindir}/cmds
|
%{_bindir}/cmds
|
||||||
%{_bindir}/cosd
|
%{_bindir}/cosd
|
||||||
%{_bindir}/mkmonfs
|
|
||||||
%{_bindir}/rados
|
%{_bindir}/rados
|
||||||
%{_bindir}/rbdtool
|
|
||||||
%{_bindir}/psim
|
%{_bindir}/psim
|
||||||
|
%{_bindir}/cclass
|
||||||
|
%{_bindir}/rbd
|
||||||
|
%{_bindir}/cclsinfo
|
||||||
%{_initddir}/ceph
|
%{_initddir}/ceph
|
||||||
%{_libdir}/libceph.so.*
|
%{_libdir}/libceph.so.*
|
||||||
%{_libdir}/libcrush.so.*
|
%{_libdir}/libcrush.so.*
|
||||||
%{_libdir}/librados.so.*
|
%{_libdir}/librados.so.*
|
||||||
%{_sbindir}/mkcephfs
|
%{_libdir}/libcls_rbd.so.*
|
||||||
|
/sbin/mkcephfs
|
||||||
/sbin/mount.ceph
|
/sbin/mount.ceph
|
||||||
%{_libdir}/ceph
|
%{_libdir}/ceph
|
||||||
%config(noreplace) %{_sysconfdir}/ceph/sample.ceph.conf
|
%dir %{_docdir}/ceph
|
||||||
%config(noreplace) %{_sysconfdir}/ceph/sample.fetch_config
|
%{_docdir}/ceph/sample.ceph.conf
|
||||||
|
%{_docdir}/ceph/sample.fetch_config
|
||||||
%{_mandir}/man8/cmon.8*
|
%{_mandir}/man8/cmon.8*
|
||||||
%{_mandir}/man8/cmds.8*
|
%{_mandir}/man8/cmds.8*
|
||||||
%{_mandir}/man8/cosd.8*
|
%{_mandir}/man8/cosd.8*
|
||||||
%{_mandir}/man8/mkcephfs.8*
|
%{_mandir}/man8/mkcephfs.8*
|
||||||
%{_mandir}/man8/mkmonfs.8*
|
|
||||||
%{_mandir}/man8/crun.8*
|
%{_mandir}/man8/crun.8*
|
||||||
%{_mandir}/man8/csyn.8*
|
%{_mandir}/man8/csyn.8*
|
||||||
%{_mandir}/man8/crushtool.8*
|
%{_mandir}/man8/crushtool.8*
|
||||||
@ -130,8 +135,10 @@ fi
|
|||||||
%{_mandir}/man8/radosgw.8*
|
%{_mandir}/man8/radosgw.8*
|
||||||
%{_mandir}/man8/radosgw_admin.8*
|
%{_mandir}/man8/radosgw_admin.8*
|
||||||
%{_mandir}/man8/rados.8*
|
%{_mandir}/man8/rados.8*
|
||||||
%{_mandir}/man8/rbdtool.8*
|
|
||||||
%{_mandir}/man8/cauthtool.8*
|
%{_mandir}/man8/cauthtool.8*
|
||||||
|
%{_mandir}/man8/cclass.8*
|
||||||
|
%{_mandir}/man8/rbd.8*
|
||||||
|
%{_mandir}/man8/cclsinfo.8*
|
||||||
|
|
||||||
%files fuse
|
%files fuse
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -158,8 +165,17 @@ fi
|
|||||||
%{_libdir}/libceph.so
|
%{_libdir}/libceph.so
|
||||||
%{_libdir}/libcrush.so
|
%{_libdir}/libcrush.so
|
||||||
%{_libdir}/librados.so
|
%{_libdir}/librados.so
|
||||||
|
%{_libdir}/libcls_rbd.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 26 2010 Steven Pritchard <steve@kspei.com> 0.21.1-1
|
||||||
|
- Update to 0.21.1.
|
||||||
|
- Sample configs moved to /usr/share/doc/ceph/.
|
||||||
|
- Added cclass, rbd, and cclsinfo.
|
||||||
|
- Dropped mkmonfs and rbdtool.
|
||||||
|
- mkcephfs moved to /sbin.
|
||||||
|
- Add libcls_rbd.so.
|
||||||
|
|
||||||
* Tue Jul 6 2010 Josef Bacik <josef@toxicpanda.com> 0.20.2-1
|
* Tue Jul 6 2010 Josef Bacik <josef@toxicpanda.com> 0.20.2-1
|
||||||
- update to 0.20.2
|
- update to 0.20.2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user