Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/ceph.git#3d9c93f7ab21ee93893b67bda96a70e98a350cf1
This commit is contained in:
DistroBaker 2021-02-04 07:40:18 +00:00
parent d24de38afc
commit c8dccd6468
6 changed files with 1480 additions and 206 deletions

View File

@ -0,0 +1,11 @@
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
@@ -25,7 +25,7 @@
zoned/HMSMRDevice.cc)
endif()
-add_library(blk ${libblk_srcs})
+add_library(blk STATIC ${libblk_srcs})
target_include_directories(blk PRIVATE "./")
if(HAVE_LIBAIO)

View File

@ -1,64 +0,0 @@
--- ceph-15.2.8/src/rgw/rgw_asio_frontend.cc.orig 2020-12-16 12:29:50.000000000 -0500
+++ ceph-15.2.8/src/rgw/rgw_asio_frontend.cc 2021-01-04 18:20:49.156104233 -0500
@@ -2,6 +2,7 @@
// vim: ts=8 sw=2 smarttab ft=cpp
#include <atomic>
+#include <ctime>
#include <thread>
#include <vector>
@@ -138,6 +139,29 @@
return out << h.quote << p->value() << h.quote;
}
+// log fractional seconds in milliseconds
+struct log_ms_remainder {
+ ceph::coarse_real_time t;
+ log_ms_remainder(ceph::coarse_real_time t) : t(t) {}
+};
+std::ostream& operator<<(std::ostream& out, const log_ms_remainder& m) {
+ using namespace std::chrono;
+ return out << std::setfill('0') << std::setw(3)
+ << duration_cast<milliseconds>(m.t.time_since_epoch()).count() % 1000;
+}
+
+// log time in apache format: day/month/year:hour:minute:second zone
+struct log_apache_time {
+ ceph::coarse_real_time t;
+ log_apache_time(ceph::coarse_real_time t) : t(t) {}
+};
+std::ostream& operator<<(std::ostream& out, const log_apache_time& a) {
+ const auto t = ceph::coarse_real_clock::to_time_t(a.t);
+ const auto local = std::localtime(&t);
+ return out << std::put_time(local, "%d/%b/%Y:%T.") << log_ms_remainder{a.t}
+ << std::put_time(local, " %z");
+};
+
using SharedMutex = ceph::async::SharedMutex<boost::asio::io_context::executor_type>;
template <typename Stream>
@@ -228,16 +252,20 @@
RGWRestfulIO client(cct, &real_client_io);
auto y = optional_yield{context, yield};
int http_ret = 0;
+ string user = "-";
+ const auto started = ceph::coarse_real_clock::now();
+
process_request(env.store, env.rest, &req, env.uri_prefix,
*env.auth_registry, &client, env.olog, y,
scheduler, &http_ret);
if (cct->_conf->subsys.should_gather(dout_subsys, 1)) {
// access log line elements begin per Apache Combined Log Format with additions following
- const auto now = ceph::coarse_real_clock::now();
- using ceph::operator<<; // for coarse_real_time
+ // const auto now = ceph::coarse_real_clock::now();
+ // using ceph::operator<<; // for coarse_real_time
ldout(cct, 1) << "beast: " << hex << &req << dec << ": "
- << remote_endpoint.address() << " - - [" << now << "] \""
+ // << remote_endpoint.address() << " - - [" << now << "] \""
+ << remote_endpoint.address() << " - " << user << " [" << log_apache_time{started} << "] \""
<< message.method_string() << ' ' << message.target() << ' '
<< http_version{message.version()} << "\" " << http_ret << ' '
<< client.get_bytes_sent() + client.get_bytes_received() << ' '

View File

@ -0,0 +1,11 @@
--- ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt.orig 2021-02-01 08:25:18.006965821 -0500
+++ ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt 2021-02-01 08:25:34.244407147 -0500
@@ -19,7 +19,7 @@
target_link_libraries(ceph_test_neorados_op_speed
libneorados fmt::fmt ${unittest_libs})
-add_library(neoradostest-support common_tests.cc)
+add_library(neoradostest-support STATIC common_tests.cc)
target_link_libraries(neoradostest-support
libneorados fmt::fmt)

View File

@ -1,10 +0,0 @@
--- ceph-15.2.8/src/tools/rbd/action/Bench.cc.orig 2021-01-25 17:08:06.189223814 -0500
+++ ceph-15.2.8/src/tools/rbd/action/Bench.cc 2021-01-25 17:08:27.297805754 -0500
@@ -10,6 +10,7 @@
#include "include/types.h"
#include "global/signal_handler.h"
#include <iostream>
+#include <atomic>
#include <boost/accumulators/accumulators.hpp>
#include <boost/accumulators/statistics/stats.hpp>
#include <boost/accumulators/statistics/rolling_sum.hpp>

View File

@ -0,0 +1,11 @@
--- ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake.orig 2021-02-01 08:45:39.316108287 -0500
+++ ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake 2021-02-01 08:45:59.813665378 -0500
@@ -5,7 +5,7 @@
# uring_FOUND - True if uring found.
find_path(URING_INCLUDE_DIR liburing.h)
-find_library(URING_LIBRARIES liburing.a liburing)
+find_library(URING_LIBRARIES liburing.so liburing)
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(uring DEFAULT_MSG URING_LIBRARIES URING_INCLUDE_DIR)

1579
ceph.spec

File diff suppressed because it is too large Load Diff