Update to latest stable upstream release
- Use HTTPS for URLs - Submit Automake 1.12 patch upstream - Move unversioned shared libs from ceph-libs into ceph-devel
This commit is contained in:
parent
a69f0258b3
commit
c523b37b4d
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ ceph-0.20.tar.gz
|
|||||||
/ceph-0.56.4.tar.bz2
|
/ceph-0.56.4.tar.bz2
|
||||||
/ceph-0.61.7.tar.bz2
|
/ceph-0.61.7.tar.bz2
|
||||||
/ceph-0.67.3.tar.bz2
|
/ceph-0.67.3.tar.bz2
|
||||||
|
/ceph-0.72.2.tar.bz2
|
||||||
|
@ -1,12 +1,31 @@
|
|||||||
diff -up ceph-0.67.3/src/Makefile.am.sbin-fix ceph-0.67.3/src/Makefile.am
|
From 69baa8948f2d922554e815c572d8339a4a197306 Mon Sep 17 00:00:00 2001
|
||||||
--- ceph-0.67.3/src/Makefile.am.sbin-fix 2013-09-11 13:46:40.061851086 -0400
|
From: Ken Dreyer <ken.dreyer@inktank.com>
|
||||||
+++ ceph-0.67.3/src/Makefile.am 2013-09-11 13:46:51.531735427 -0400
|
Date: Tue, 7 Jan 2014 21:51:14 -0700
|
||||||
@@ -28,7 +28,7 @@ bin_PROGRAMS =
|
Subject: [PATCH] Fedora only: fix sbin path
|
||||||
bin_DEBUGPROGRAMS =
|
|
||||||
sbin_PROGRAMS =
|
On Fedora, /sbin is a symbolic link to /usr/sbin. Install all the sbin
|
||||||
|
binaries into the /usr/sbin location.
|
||||||
|
|
||||||
|
Signed-off-by: Ken Dreyer <ken.dreyer@inktank.com>
|
||||||
|
---
|
||||||
|
src/Makefile-env.am | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/Makefile-env.am b/src/Makefile-env.am
|
||||||
|
index 9bc6ee7..d02f034 100644
|
||||||
|
--- a/src/Makefile-env.am
|
||||||
|
+++ b/src/Makefile-env.am
|
||||||
|
@@ -26,8 +26,8 @@ bin_DEBUGPROGRAMS =
|
||||||
# like sbin_SCRIPTS but can be used to install to e.g. /usr/sbin
|
# like sbin_SCRIPTS but can be used to install to e.g. /usr/sbin
|
||||||
-ceph_sbindir = $(exec_prefix)$(sbindir)
|
ceph_sbindir = $(sbindir)
|
||||||
+ceph_sbindir = $(sbindir)
|
|
||||||
ceph_sbin_SCRIPTS = \
|
-# certain things go straight into /sbin, though!
|
||||||
ceph-disk \
|
-su_sbindir = /sbin
|
||||||
ceph-disk-prepare \
|
+# On Fedora these things also go into /usr/sbin
|
||||||
|
+su_sbindir = $(sbindir)
|
||||||
|
|
||||||
|
# C/C++ tests to build will be appended to this
|
||||||
|
check_PROGRAMS =
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
diff -up ceph-0.67.3/src/common/crc32c-intel.c.secondary ceph-0.67.3/src/common/crc32c-intel.c
|
|
||||||
--- ceph-0.67.3/src/common/crc32c-intel.c.secondary 2013-10-07 10:15:22.000000000 +0200
|
|
||||||
+++ ceph-0.67.3/src/common/crc32c-intel.c 2013-10-07 10:16:00.000000000 +0200
|
|
||||||
@@ -7,8 +7,8 @@
|
|
||||||
#include <sys/wait.h>
|
|
||||||
|
|
||||||
|
|
||||||
-/* this probably isn't specific enough for x86_64? fix me someday */
|
|
||||||
-#ifdef __LP64__
|
|
||||||
+/* this probably is specific enough for x86_64 */
|
|
||||||
+#ifdef __x86_64__
|
|
||||||
|
|
||||||
/*
|
|
||||||
* * Based on a posting to lkml by Austin Zhang <austin.zhang@intel.com>
|
|
||||||
@@ -98,7 +98,7 @@ int ceph_have_crc32c_intel(void)
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
-#else /* __LP64__ */
|
|
||||||
+#else /* __x86_64__ */
|
|
||||||
|
|
||||||
uint32_t ceph_crc32c_le_intel(uint32_t crc, unsigned char const *data, unsigned length)
|
|
||||||
{
|
|
67
ceph.spec
67
ceph.spec
@ -1,16 +1,16 @@
|
|||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 0.67.3
|
Version: 0.72.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: User space components of the Ceph file system
|
Summary: User space components of the Ceph file system
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://ceph.com/
|
URL: https://ceph.com/
|
||||||
|
|
||||||
Source: http://ceph.com/download/%{name}-%{version}.tar.bz2
|
Source: https://ceph.com/download/%{name}-%{version}.tar.bz2
|
||||||
Patch0: ceph-init-fix.patch
|
Patch0: ceph-init-fix.patch
|
||||||
|
# https://github.com/ceph/ceph/pull/1051
|
||||||
Patch1: ceph-build-support-for-automake-1.12.patch
|
Patch1: ceph-build-support-for-automake-1.12.patch
|
||||||
Patch2: ceph-fix-sbin-target.patch
|
Patch2: ceph-fix-sbin-target.patch
|
||||||
Patch3: ceph-non-x86_64.patch
|
|
||||||
|
|
||||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
|
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
|
||||||
@ -78,7 +78,6 @@ conjunction with any FastCGI capable web server.
|
|||||||
%patch0 -p1 -b .init
|
%patch0 -p1 -b .init
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1 -b .non-x86_64
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -145,6 +144,7 @@ fi
|
|||||||
%{_bindir}/cephfs
|
%{_bindir}/cephfs
|
||||||
%{_bindir}/ceph-conf
|
%{_bindir}/ceph-conf
|
||||||
%{_bindir}/ceph-clsinfo
|
%{_bindir}/ceph-clsinfo
|
||||||
|
%{_bindir}/ceph_filestore_tool
|
||||||
%{_bindir}/crushtool
|
%{_bindir}/crushtool
|
||||||
%{_bindir}/monmaptool
|
%{_bindir}/monmaptool
|
||||||
%{_bindir}/osdmaptool
|
%{_bindir}/osdmaptool
|
||||||
@ -216,16 +216,24 @@ fi
|
|||||||
%doc COPYING
|
%doc COPYING
|
||||||
%{_libdir}/librados.so.*
|
%{_libdir}/librados.so.*
|
||||||
%{_libdir}/librbd.so.*
|
%{_libdir}/librbd.so.*
|
||||||
|
%dir %{_libdir}/erasure-code
|
||||||
|
%{_libdir}/erasure-code/libec_example.so.*
|
||||||
|
%{_libdir}/erasure-code/libec_fail_to_initialize.so.*
|
||||||
|
%{_libdir}/erasure-code/libec_fail_to_register.so.*
|
||||||
|
%{_libdir}/erasure-code/libec_hangs.so.*
|
||||||
|
%{_libdir}/erasure-code/libec_jerasure.so.*
|
||||||
|
%{_libdir}/erasure-code/libec_missing_entry_point.so.*
|
||||||
%dir %{_libdir}/rados-classes
|
%dir %{_libdir}/rados-classes
|
||||||
%{_libdir}/rados-classes/libcls_rbd.so*
|
%{_libdir}/rados-classes/libcls_hello.so.*
|
||||||
%{_libdir}/rados-classes/libcls_rgw.so*
|
%{_libdir}/rados-classes/libcls_rbd.so.*
|
||||||
%{_libdir}/rados-classes/libcls_lock*
|
%{_libdir}/rados-classes/libcls_rgw.so.*
|
||||||
%{_libdir}/rados-classes/libcls_kvs*
|
%{_libdir}/rados-classes/libcls_lock.so.*
|
||||||
%{_libdir}/rados-classes/libcls_refcount*
|
%{_libdir}/rados-classes/libcls_kvs.so.*
|
||||||
%{_libdir}/rados-classes/libcls_log*
|
%{_libdir}/rados-classes/libcls_refcount.so.*
|
||||||
%{_libdir}/rados-classes/libcls_replica_log*
|
%{_libdir}/rados-classes/libcls_log.so.*
|
||||||
%{_libdir}/rados-classes/libcls_statelog*
|
%{_libdir}/rados-classes/libcls_replica_log.so.*
|
||||||
%{_libdir}/rados-classes/libcls_version*
|
%{_libdir}/rados-classes/libcls_statelog.so.*
|
||||||
|
%{_libdir}/rados-classes/libcls_version.so.*
|
||||||
|
|
||||||
%files libcephfs
|
%files libcephfs
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
@ -243,11 +251,6 @@ fi
|
|||||||
%doc COPYING
|
%doc COPYING
|
||||||
%dir %{_includedir}/cephfs
|
%dir %{_includedir}/cephfs
|
||||||
%{_includedir}/cephfs/libcephfs.h
|
%{_includedir}/cephfs/libcephfs.h
|
||||||
#%dir %{_includedir}/crush
|
|
||||||
#%{_includedir}/crush/crush.h
|
|
||||||
#%{_includedir}/crush/hash.h
|
|
||||||
#%{_includedir}/crush/mapper.h
|
|
||||||
#%{_includedir}/crush/types.h
|
|
||||||
%dir %{_includedir}/rados
|
%dir %{_includedir}/rados
|
||||||
%{_includedir}/rados/librados.h
|
%{_includedir}/rados/librados.h
|
||||||
%{_includedir}/rados/librados.hpp
|
%{_includedir}/rados/librados.hpp
|
||||||
@ -256,15 +259,29 @@ fi
|
|||||||
%{_includedir}/rados/buffer.h
|
%{_includedir}/rados/buffer.h
|
||||||
%{_includedir}/rados/page.h
|
%{_includedir}/rados/page.h
|
||||||
%{_includedir}/rados/crc32c.h
|
%{_includedir}/rados/crc32c.h
|
||||||
#%{_includedir}/rados/librgw.h
|
|
||||||
%dir %{_includedir}/rbd
|
%dir %{_includedir}/rbd
|
||||||
%{_includedir}/rbd/librbd.h
|
%{_includedir}/rbd/librbd.h
|
||||||
%{_includedir}/rbd/librbd.hpp
|
%{_includedir}/rbd/librbd.hpp
|
||||||
%{_includedir}/rbd/features.h
|
%{_includedir}/rbd/features.h
|
||||||
|
%{_libdir}/erasure-code/libec_example.so
|
||||||
|
%{_libdir}/erasure-code/libec_fail_to_initialize.so
|
||||||
|
%{_libdir}/erasure-code/libec_fail_to_register.so
|
||||||
|
%{_libdir}/erasure-code/libec_hangs.so
|
||||||
|
%{_libdir}/erasure-code/libec_jerasure.so
|
||||||
|
%{_libdir}/erasure-code/libec_missing_entry_point.so
|
||||||
%{_libdir}/libcephfs.so
|
%{_libdir}/libcephfs.so
|
||||||
%{_libdir}/librados.so
|
%{_libdir}/librados.so
|
||||||
#%{_libdir}/librgw.so
|
|
||||||
%{_libdir}/librbd.so
|
%{_libdir}/librbd.so
|
||||||
|
%{_libdir}/rados-classes/libcls_hello.so
|
||||||
|
%{_libdir}/rados-classes/libcls_rbd.so
|
||||||
|
%{_libdir}/rados-classes/libcls_rgw.so
|
||||||
|
%{_libdir}/rados-classes/libcls_lock.so
|
||||||
|
%{_libdir}/rados-classes/libcls_kvs.so
|
||||||
|
%{_libdir}/rados-classes/libcls_refcount.so
|
||||||
|
%{_libdir}/rados-classes/libcls_log.so
|
||||||
|
%{_libdir}/rados-classes/libcls_replica_log.so
|
||||||
|
%{_libdir}/rados-classes/libcls_statelog.so
|
||||||
|
%{_libdir}/rados-classes/libcls_version.so
|
||||||
%{_bindir}/librados-config
|
%{_bindir}/librados-config
|
||||||
%{_mandir}/man8/librados-config.8*
|
%{_mandir}/man8/librados-config.8*
|
||||||
|
|
||||||
@ -275,6 +292,12 @@ fi
|
|||||||
%{_sysconfdir}/bash_completion.d/radosgw-admin
|
%{_sysconfdir}/bash_completion.d/radosgw-admin
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 06 2014 Ken Dreyer <ken.dreyer@inktank.com> 0.72.2-1
|
||||||
|
- Update to latest stable upstream release
|
||||||
|
- Use HTTPS for URLs
|
||||||
|
- Submit Automake 1.12 patch upstream
|
||||||
|
- Move unversioned shared libs from ceph-libs into ceph-devel
|
||||||
|
|
||||||
* Wed Dec 18 2013 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> 0.67.3-4
|
* Wed Dec 18 2013 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> 0.67.3-4
|
||||||
- build without tcmalloc on aarch64 (no gperftools)
|
- build without tcmalloc on aarch64 (no gperftools)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user