New version (1:10.2.4-1)

- Disable erasure_codelib neon build
- Use newer -devel package format
- Sync up the spec file
This commit is contained in:
Boris Ranto 2016-12-08 18:41:24 +01:00
parent 680c925719
commit c342c970d9
5 changed files with 64 additions and 143 deletions

View File

@ -1,4 +1,4 @@
From b0c5f4beca45bcb562c969e1c6b18a192e229c91 Mon Sep 17 00:00:00 2001 From 2a7810f39cb113570efcde5f65e5440ff9587ae0 Mon Sep 17 00:00:00 2001
From: Boris Ranto <branto@redhat.com> From: Boris Ranto <branto@redhat.com>
Date: Wed, 11 Nov 2015 17:08:06 +0100 Date: Wed, 11 Nov 2015 17:08:06 +0100
Subject: [PATCH] Disable erasure_codelib neon build Subject: [PATCH] Disable erasure_codelib neon build
@ -9,7 +9,7 @@ Subject: [PATCH] Disable erasure_codelib neon build
2 files changed, 6 insertions(+), 6 deletions(-) 2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/erasure-code/jerasure/Makefile.am b/src/erasure-code/jerasure/Makefile.am diff --git a/src/erasure-code/jerasure/Makefile.am b/src/erasure-code/jerasure/Makefile.am
index adcb95d..5e47943 100644 index 6ffe3ed..01f5112 100644
--- a/src/erasure-code/jerasure/Makefile.am --- a/src/erasure-code/jerasure/Makefile.am
+++ b/src/erasure-code/jerasure/Makefile.am +++ b/src/erasure-code/jerasure/Makefile.am
@@ -75,9 +75,9 @@ if LINUX @@ -75,9 +75,9 @@ if LINUX
@ -26,7 +26,7 @@ index adcb95d..5e47943 100644
libec_jerasure_sse3_la_SOURCES = ${jerasure_sources} libec_jerasure_sse3_la_SOURCES = ${jerasure_sources}
libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \ libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \
diff --git a/src/erasure-code/shec/Makefile.am b/src/erasure-code/shec/Makefile.am diff --git a/src/erasure-code/shec/Makefile.am b/src/erasure-code/shec/Makefile.am
index 6b658d5..93051f4 100644 index cd93132..948979b 100644
--- a/src/erasure-code/shec/Makefile.am --- a/src/erasure-code/shec/Makefile.am
+++ b/src/erasure-code/shec/Makefile.am +++ b/src/erasure-code/shec/Makefile.am
@@ -81,9 +81,9 @@ if LINUX @@ -81,9 +81,9 @@ if LINUX
@ -42,3 +42,6 @@ index 6b658d5..93051f4 100644
libec_shec_sse3_la_SOURCES = ${shec_sources} libec_shec_sse3_la_SOURCES = ${shec_sources}
libec_shec_sse3_la_CFLAGS = ${AM_CFLAGS} \ libec_shec_sse3_la_CFLAGS = ${AM_CFLAGS} \
--
2.7.4

View File

@ -1,47 +0,0 @@
From c7bf5767279cc5470408ed51dd47d462ea6c225c Mon Sep 17 00:00:00 2001
From: Kefu Chai <kchai@redhat.com>
Date: Sun, 26 Jun 2016 01:02:03 +0800
Subject: [PATCH] common: instantiate strict_si_cast<long> not
strict_si_cast<int64_t>
this fixes the build on armf.
on 32bit platforms, cstdint is very likely to
typedef long long int int64_t;
this results in compilation error like
`common/strtol.cc:190:75: error: duplicate explicit instantiation of 'T
strict_si_cast(const char, std::string) [with T = long long int;
std::string = std::basic_string]'
[-fpermissive]
template int64_t strict_si_cast(const char *str, std::string *err);
^`
we can address this by instantiate the primitive type of `long long`
instead of `in64_t`.
Fixes: http://tracker.ceph.com/issues/16398
Signed-off-by: Kefu Chai <kchai@redhat.com>
---
src/common/strtol.cc | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/common/strtol.cc b/src/common/strtol.cc
index f43d661..04e09b1 100644
--- a/src/common/strtol.cc
+++ b/src/common/strtol.cc
@@ -187,9 +187,9 @@ T strict_si_cast(const char *str, std::string *err)
template int strict_si_cast<int>(const char *str, std::string *err);
-template long long strict_si_cast<long long>(const char *str, std::string *err);
+template long strict_si_cast<long>(const char *str, std::string *err);
-template int64_t strict_si_cast<int64_t>(const char *str, std::string *err);
+template long long strict_si_cast<long long>(const char *str, std::string *err);
template uint64_t strict_si_cast<uint64_t>(const char *str, std::string *err);

View File

@ -1,55 +0,0 @@
From efebb1f5b68372d517e2279159ca5b9eaac30265 Mon Sep 17 00:00:00 2001
From: Matt Benjamin <mbenjamin@redhat.com>
Date: Tue, 23 Aug 2016 14:18:43 -0400
Subject: [PATCH] librgw: add API version defines for librgw and rgw_file
This change borrows the major, minor+extra format used by libcephfs.
The version numbering is starting at 1,1,0 on the theory that the
implicit version at Jewel is 1,0,0.
Signed-off-by: Matt Benjamin <mbenjamin@redhat.com>
(cherry picked from commit 355ccc5ded7f0b459bca24bc8b504b41807c583d)
(cherry picked from commit 2a9233f1fbff38c12d378d5b6528a7e576a62e3e)
Cherry-picking to Fedora to move nfs-ganesha-rgw along, see
https://bugzilla.redhat.com/1388690
---
src/include/rados/librgw.h | 7 +++++++
src/include/rados/rgw_file.h | 6 ++++++
2 files changed, 13 insertions(+)
diff --git a/src/include/rados/librgw.h b/src/include/rados/librgw.h
index 9ba8f3a..c20e96b 100644
--- a/src/include/rados/librgw.h
+++ b/src/include/rados/librgw.h
@@ -18,6 +18,13 @@
extern "C" {
#endif
+#define LIBRGW_VER_MAJOR 1
+#define LIBRGW_VER_MINOR 1
+#define LIBRGW_VER_EXTRA 0
+
+#define LIBRGW_VERSION(maj, min, extra) ((maj << 16) + (min << 8) + extra)
+#define LIBRGW_VERSION_CODE LIBRGW_VERSION(LIBRGW_VER_MAJOR, LIBRGW_VER_MINOR, LIBRGW_VER_EXTRA)
+
typedef void* librgw_t;
int librgw_create(librgw_t *rgw, int argc, char **argv);
void librgw_shutdown(librgw_t rgw);
diff --git a/src/include/rados/rgw_file.h b/src/include/rados/rgw_file.h
index 4bb8a93..69995ca 100644
--- a/src/include/rados/rgw_file.h
+++ b/src/include/rados/rgw_file.h
@@ -24,6 +24,12 @@
extern "C" {
#endif
+#define LIBRGW_FILE_VER_MAJOR 1
+#define LIBRGW_FILE_VER_MINOR 1
+#define LIBRGW_FILE_VER_EXTRA 0
+
+#define LIBRGW_FILE_VERSION(maj, min, extra) ((maj << 16) + (min << 8) + extra)
+#define LIBRGW_FILE_VERSION_CODE LIBRGW_FILE_VERSION(LIBRGW_FILE_VER_MAJOR, LIBRGW_FILE_VER_MINOR, LIBRGW_FILE_VER_EXTRA)
/*
* object types

View File

@ -33,10 +33,12 @@
%bcond_with selinux %bcond_with selinux
%endif %endif
# LTTng-UST enabled on Fedora, RHEL 6+, and SLES 12 # LTTng-UST enabled on Fedora, RHEL 6+, and SLE (not openSUSE)
%if 0%{?fedora} || 0%{?rhel} >= 6 || 0%{?suse_version} == 1315 %if 0%{?fedora} || 0%{?rhel} >= 6 || 0%{?suse_version}
%if ! 0%{?is_opensuse}
%bcond_without lttng %bcond_without lttng
%endif %endif
%endif
%if %{with selinux} %if %{with selinux}
# get selinux policy version # get selinux policy version
@ -54,8 +56,8 @@
# common # common
################################################################################# #################################################################################
Name: ceph Name: ceph
Version: 10.2.3 Version: 10.2.4
Release: 4%{?dist} Release: 1%{?dist}
Epoch: 1 Epoch: 1
Summary: User space components of the Ceph file system Summary: User space components of the Ceph file system
License: LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and GPL-2.0-with-autoconf-exception and BSD-3-Clause and MIT License: LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and GPL-2.0-with-autoconf-exception and BSD-3-Clause and MIT
@ -64,11 +66,7 @@ Group: System/Filesystems
%endif %endif
URL: http://ceph.com/ URL: http://ceph.com/
Source0: http://ceph.com/download/%{name}-%{version}.tar.gz Source0: http://ceph.com/download/%{name}-%{version}.tar.gz
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
Patch0001: 0001-Disable-erasure_codelib-neon-build.patch
Patch0002: 0002-common-instantiate-strict_si_cast-long-not-strict_si.patch
Patch0003: 0003-librgw-add-API-version-defines-for-librgw-and-rgw_fi.patch
%if 0%{?suse_version} %if 0%{?suse_version}
%if 0%{?is_opensuse} %if 0%{?is_opensuse}
ExclusiveArch: x86_64 aarch64 ppc64 ppc64le ExclusiveArch: x86_64 aarch64 ppc64 ppc64le
@ -121,6 +119,7 @@ BuildRequires: python-requests
BuildRequires: python-sphinx BuildRequires: python-sphinx
BuildRequires: python-virtualenv BuildRequires: python-virtualenv
BuildRequires: snappy-devel BuildRequires: snappy-devel
BuildRequires: udev
BuildRequires: util-linux BuildRequires: util-linux
%ifnarch s390 %ifnarch s390
BuildRequires: valgrind-devel BuildRequires: valgrind-devel
@ -377,13 +376,15 @@ developed as part of the Ceph distributed storage system. This is a
shared library allowing applications to access the distributed object shared library allowing applications to access the distributed object
store using a simple file-like interface. store using a simple file-like interface.
%package -n librados2-devel %package -n librados-devel
Summary: RADOS headers Summary: RADOS headers
Group: Development/Libraries Group: Development/Libraries
License: LGPL-2.0 License: LGPL-2.0
Requires: librados2 = %{epoch}:%{version}-%{release} Requires: librados2 = %{epoch}:%{version}-%{release}
Obsoletes: ceph-devel < %{epoch}:%{version}-%{release} Obsoletes: ceph-devel < %{epoch}:%{version}-%{release}
%description -n librados2-devel Provides: librados2-devel = %{epoch}:%{version}-%{release}
Obsoletes: librados2-devel = %{epoch}:%{version}-%{release}
%description -n librados-devel
This package contains libraries and headers needed to develop programs This package contains libraries and headers needed to develop programs
that use RADOS object store. that use RADOS object store.
@ -396,12 +397,14 @@ Requires: librados2 = %{epoch}:%{version}-%{release}
This package provides a library implementation of the RADOS gateway This package provides a library implementation of the RADOS gateway
(distributed object store with S3 and Swift personalities). (distributed object store with S3 and Swift personalities).
%package -n librgw2-devel %package -n librgw-devel
Summary: RADOS gateway client library Summary: RADOS gateway client library
Group: Development/Libraries Group: Development/Libraries
License: LGPL-2.0 License: LGPL-2.0
Requires: librados2 = %{epoch}:%{version}-%{release} Requires: librados2 = %{epoch}:%{version}-%{release}
%description -n librgw2-devel Provides: librgw2-devel = %{epoch}:%{version}-%{release}
Obsoletes: librgw2-devel = %{epoch}:%{version}-%{release}
%description -n librgw-devel
This package contains libraries and headers needed to develop programs This package contains libraries and headers needed to develop programs
that use RADOS gateway client library. that use RADOS gateway client library.
@ -425,14 +428,16 @@ Striping interface built on top of the rados library, allowing
to stripe bigger objects onto several standard rados objects using to stripe bigger objects onto several standard rados objects using
an interface very similar to the rados one. an interface very similar to the rados one.
%package -n libradosstriper1-devel %package -n libradosstriper-devel
Summary: RADOS striping interface headers Summary: RADOS striping interface headers
Group: Development/Libraries Group: Development/Libraries
License: LGPL-2.0 License: LGPL-2.0
Requires: libradosstriper1 = %{epoch}:%{version}-%{release} Requires: libradosstriper1 = %{epoch}:%{version}-%{release}
Requires: librados2-devel = %{epoch}:%{version}-%{release} Requires: librados-devel = %{epoch}:%{version}-%{release}
Obsoletes: ceph-devel < %{epoch}:%{version}-%{release} Obsoletes: ceph-devel < %{epoch}:%{version}-%{release}
%description -n libradosstriper1-devel Provides: libradosstriper1-devel = %{epoch}:%{version}-%{release}
Obsoletes: libradosstriper1-devel = %{epoch}:%{version}-%{release}
%description -n libradosstriper-devel
This package contains libraries and headers needed to develop programs This package contains libraries and headers needed to develop programs
that use RADOS striping interface. that use RADOS striping interface.
@ -450,14 +455,16 @@ RADOS, a reliable, autonomic distributed object storage cluster
developed as part of the Ceph distributed storage system. This is a developed as part of the Ceph distributed storage system. This is a
shared library allowing applications to manage these block devices. shared library allowing applications to manage these block devices.
%package -n librbd1-devel %package -n librbd-devel
Summary: RADOS block device headers Summary: RADOS block device headers
Group: Development/Libraries Group: Development/Libraries
License: LGPL-2.0 License: LGPL-2.0
Requires: librbd1 = %{epoch}:%{version}-%{release} Requires: librbd1 = %{epoch}:%{version}-%{release}
Requires: librados2-devel = %{epoch}:%{version}-%{release} Requires: librados-devel = %{epoch}:%{version}-%{release}
Obsoletes: ceph-devel < %{epoch}:%{version}-%{release} Obsoletes: ceph-devel < %{epoch}:%{version}-%{release}
%description -n librbd1-devel Provides: librbd1-devel = %{epoch}:%{version}-%{release}
Obsoletes: librbd1-devel = %{epoch}:%{version}-%{release}
%description -n librbd-devel
This package contains libraries and headers needed to develop programs This package contains libraries and headers needed to develop programs
that use RADOS block device. that use RADOS block device.
@ -486,14 +493,16 @@ performance, reliability, and scalability. This is a shared library
allowing applications to access a Ceph distributed file system via a allowing applications to access a Ceph distributed file system via a
POSIX-like interface. POSIX-like interface.
%package -n libcephfs1-devel %package -n libcephfs-devel
Summary: Ceph distributed file system headers Summary: Ceph distributed file system headers
Group: Development/Libraries Group: Development/Libraries
License: LGPL-2.0 License: LGPL-2.0
Requires: libcephfs1 = %{epoch}:%{version}-%{release} Requires: libcephfs1 = %{epoch}:%{version}-%{release}
Requires: librados2-devel = %{epoch}:%{version}-%{release} Requires: librados-devel = %{epoch}:%{version}-%{release}
Obsoletes: ceph-devel < %{epoch}:%{version}-%{release} Obsoletes: ceph-devel < %{epoch}:%{version}-%{release}
%description -n libcephfs1-devel Provides: libcephfs1-devel = %{epoch}:%{version}-%{release}
Obsoletes: libcephfs1-devel = %{epoch}:%{version}-%{release}
%description -n libcephfs-devel
This package contains libraries and headers needed to develop programs This package contains libraries and headers needed to develop programs
that use Cephs distributed file system. that use Cephs distributed file system.
@ -529,14 +538,16 @@ Requires: libcephfs1 = %{epoch}:%{version}-%{release}
This package contains the Java Native Interface library for CephFS Java This package contains the Java Native Interface library for CephFS Java
bindings. bindings.
%package -n libcephfs_jni1-devel %package -n libcephfs_jni-devel
Summary: Development files for CephFS Java Native Interface library Summary: Development files for CephFS Java Native Interface library
Group: System Environment/Libraries Group: System Environment/Libraries
License: LGPL-2.0 License: LGPL-2.0
Requires: java Requires: java
Requires: libcephfs_jni1 = %{epoch}:%{version}-%{release} Requires: libcephfs_jni1 = %{epoch}:%{version}-%{release}
Obsoletes: ceph-devel < %{epoch}:%{version}-%{release} Obsoletes: ceph-devel < %{epoch}:%{version}-%{release}
%description -n libcephfs_jni1-devel Provides: libcephfs_jni1-devel = %{epoch}:%{version}-%{release}
Obsoletes: libcephfs_jni1-devel = %{epoch}:%{version}-%{release}
%description -n libcephfs_jni-devel
This package contains the development files for CephFS Java Native Interface This package contains the development files for CephFS Java Native Interface
library. library.
@ -595,12 +606,12 @@ Summary: Compatibility package for Ceph headers
Group: Development/Libraries Group: Development/Libraries
License: LGPL-2.0 License: LGPL-2.0
Obsoletes: ceph-devel Obsoletes: ceph-devel
Requires: librados2-devel = %{epoch}:%{version}-%{release} Requires: librados-devel = %{epoch}:%{version}-%{release}
Requires: libradosstriper1-devel = %{epoch}:%{version}-%{release} Requires: libradosstriper-devel = %{epoch}:%{version}-%{release}
Requires: librbd1-devel = %{epoch}:%{version}-%{release} Requires: librbd-devel = %{epoch}:%{version}-%{release}
Requires: libcephfs1-devel = %{epoch}:%{version}-%{release} Requires: libcephfs-devel = %{epoch}:%{version}-%{release}
%if 0%{with cephfs_java} %if 0%{with cephfs_java}
Requires: libcephfs_jni1-devel = %{epoch}:%{version}-%{release} Requires: libcephfs_jni-devel = %{epoch}:%{version}-%{release}
%endif %endif
Provides: ceph-devel Provides: ceph-devel
%description devel-compat %description devel-compat
@ -628,6 +639,7 @@ python-cephfs instead.
# common # common
################################################################################# #################################################################################
%prep %prep
%patch1 -p1
%autosetup -p1 %autosetup -p1
%build %build
@ -889,8 +901,8 @@ DISABLE_RESTART_ON_UPDATE="yes"
%{_mandir}/man8/rbd-replay-prep.8* %{_mandir}/man8/rbd-replay-prep.8*
%dir %{_datadir}/ceph/ %dir %{_datadir}/ceph/
%{_datadir}/ceph/known_hosts_drop.ceph.com %{_datadir}/ceph/known_hosts_drop.ceph.com
%{_datadir}/ceph/id_dsa_drop.ceph.com %{_datadir}/ceph/id_rsa_drop.ceph.com
%{_datadir}/ceph/id_dsa_drop.ceph.com.pub %{_datadir}/ceph/id_rsa_drop.ceph.com.pub
%dir %{_sysconfdir}/ceph/ %dir %{_sysconfdir}/ceph/
%config %{_sysconfdir}/bash_completion.d/rados %config %{_sysconfdir}/bash_completion.d/rados
%config %{_sysconfdir}/bash_completion.d/rbd %config %{_sysconfdir}/bash_completion.d/rbd
@ -898,6 +910,7 @@ DISABLE_RESTART_ON_UPDATE="yes"
%{_unitdir}/rbdmap.service %{_unitdir}/rbdmap.service
%{python_sitelib}/ceph_argparse.py* %{python_sitelib}/ceph_argparse.py*
%{python_sitelib}/ceph_daemon.py* %{python_sitelib}/ceph_daemon.py*
%dir %{_udevrulesdir}
%{_udevrulesdir}/50-rbd.rules %{_udevrulesdir}/50-rbd.rules
%attr(3770,ceph,ceph) %dir %{_localstatedir}/log/ceph/ %attr(3770,ceph,ceph) %dir %{_localstatedir}/log/ceph/
%attr(750,ceph,ceph) %dir %{_localstatedir}/lib/ceph/ %attr(750,ceph,ceph) %dir %{_localstatedir}/lib/ceph/
@ -1167,6 +1180,7 @@ fi
%{_sbindir}/ceph-disk %{_sbindir}/ceph-disk
%{_sbindir}/ceph-disk-udev %{_sbindir}/ceph-disk-udev
%{_libexecdir}/ceph/ceph-osd-prestart.sh %{_libexecdir}/ceph/ceph-osd-prestart.sh
%dir %{_udevrulesdir}
%{_udevrulesdir}/60-ceph-by-parttypeuuid.rules %{_udevrulesdir}/60-ceph-by-parttypeuuid.rules
%{_udevrulesdir}/95-ceph-osd.rules %{_udevrulesdir}/95-ceph-osd.rules
%{_mandir}/man8/ceph-clsinfo.8* %{_mandir}/man8/ceph-clsinfo.8*
@ -1248,7 +1262,7 @@ fi
/sbin/ldconfig /sbin/ldconfig
################################################################################# #################################################################################
%files -n librados2-devel %files -n librados-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%dir %{_includedir}/rados %dir %{_includedir}/rados
%{_includedir}/rados/librados.h %{_includedir}/rados/librados.h
@ -1285,7 +1299,7 @@ fi
/sbin/ldconfig /sbin/ldconfig
################################################################################# #################################################################################
%files -n libradosstriper1-devel %files -n libradosstriper-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%dir %{_includedir}/radosstriper %dir %{_includedir}/radosstriper
%{_includedir}/radosstriper/libradosstriper.h %{_includedir}/radosstriper/libradosstriper.h
@ -1309,7 +1323,7 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
/sbin/ldconfig /sbin/ldconfig
################################################################################# #################################################################################
%files -n librbd1-devel %files -n librbd-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%dir %{_includedir}/rbd %dir %{_includedir}/rbd
%{_includedir}/rbd/librbd.h %{_includedir}/rbd/librbd.h
@ -1332,7 +1346,7 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
/sbin/ldconfig /sbin/ldconfig
################################################################################# #################################################################################
%files -n librgw2-devel %files -n librgw-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%dir %{_includedir}/rados %dir %{_includedir}/rados
%{_includedir}/rados/librgw.h %{_includedir}/rados/librgw.h
@ -1357,7 +1371,7 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
/sbin/ldconfig /sbin/ldconfig
################################################################################# #################################################################################
%files -n libcephfs1-devel %files -n libcephfs-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%dir %{_includedir}/cephfs %dir %{_includedir}/cephfs
%{_includedir}/cephfs/libcephfs.h %{_includedir}/cephfs/libcephfs.h
@ -1420,7 +1434,7 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
/sbin/ldconfig /sbin/ldconfig
################################################################################# #################################################################################
%files -n libcephfs_jni1-devel %files -n libcephfs_jni-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_libdir}/libcephfs_jni.so %{_libdir}/libcephfs_jni.so
@ -1538,6 +1552,12 @@ exit 0
%changelog %changelog
* Thu Dec 08 2016 Boris Ranto <branto@redhat.com> - 1:10.2.4-1
- New version (1:10.2.4-1)
- Disable erasure_codelib neon build
- Use newer -devel package format
- Sync up the spec file
* Wed Oct 26 2016 Ken Dreyer <ktdreyer@ktdreyer.com> 1:10.2.3-4 * Wed Oct 26 2016 Ken Dreyer <ktdreyer@ktdreyer.com> 1:10.2.3-4
- librgw: add API version defines for librgw and rgw_file - librgw: add API version defines for librgw and rgw_file

View File

@ -1 +1 @@
5d660c78a211f6d53161e197729aebd2 ceph-10.2.3.tar.gz ae84a14d93d0b7cc4fa59bac0c79746f ceph-10.2.4.tar.gz