Disable server bits (again)
This commit is contained in:
parent
4b1e850829
commit
c0f0d39af6
@ -1,11 +0,0 @@
|
|||||||
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
|
|
||||||
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
|
|
||||||
@@ -25,7 +25,7 @@
|
|
||||||
zoned/HMSMRDevice.cc)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-add_library(blk ${libblk_srcs})
|
|
||||||
+add_library(blk STATIC ${libblk_srcs})
|
|
||||||
target_include_directories(blk PRIVATE "./")
|
|
||||||
|
|
||||||
if(HAVE_LIBAIO)
|
|
@ -1,11 +0,0 @@
|
|||||||
--- ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt.orig 2021-02-01 08:25:18.006965821 -0500
|
|
||||||
+++ ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt 2021-02-01 08:25:34.244407147 -0500
|
|
||||||
@@ -19,7 +19,7 @@
|
|
||||||
target_link_libraries(ceph_test_neorados_op_speed
|
|
||||||
libneorados fmt::fmt ${unittest_libs})
|
|
||||||
|
|
||||||
-add_library(neoradostest-support common_tests.cc)
|
|
||||||
+add_library(neoradostest-support STATIC common_tests.cc)
|
|
||||||
target_link_libraries(neoradostest-support
|
|
||||||
libneorados fmt::fmt)
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
--- ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake.orig 2021-02-01 08:45:39.316108287 -0500
|
|
||||||
+++ ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake 2021-02-01 08:45:59.813665378 -0500
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
# uring_FOUND - True if uring found.
|
|
||||||
|
|
||||||
find_path(URING_INCLUDE_DIR liburing.h)
|
|
||||||
-find_library(URING_LIBRARIES liburing.a liburing)
|
|
||||||
+find_library(URING_LIBRARIES liburing.so liburing)
|
|
||||||
|
|
||||||
include(FindPackageHandleStandardArgs)
|
|
||||||
find_package_handle_standard_args(uring DEFAULT_MSG URING_LIBRARIES URING_INCLUDE_DIR)
|
|
Loading…
Reference in New Issue
Block a user