rm obsolete patches
This commit is contained in:
parent
80c32a846e
commit
b651554bd7
@ -1,13 +0,0 @@
|
||||
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
|
||||
index 65ba10b0f1..eeedc29c37 100644
|
||||
--- a/src/common/CMakeLists.txt
|
||||
+++ b/src/common/CMakeLists.txt
|
||||
@@ -165,7 +165,7 @@ elseif(HAVE_ARMV8_CRC)
|
||||
crc32c_aarch64.c)
|
||||
endif(HAVE_INTEL)
|
||||
|
||||
-add_library(crc32 ${crc32_srcs})
|
||||
+add_library(crc32 STATIC ${crc32_srcs})
|
||||
if(HAVE_ARMV8_CRC)
|
||||
set_target_properties(crc32 PROPERTIES
|
||||
COMPILE_FLAGS "${CMAKE_C_FLAGS} ${ARMV8_CRC_COMPILE_FLAGS}")
|
@ -1,11 +0,0 @@
|
||||
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
|
||||
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
|
||||
@@ -25,7 +25,7 @@
|
||||
zoned/HMSMRDevice.cc)
|
||||
endif()
|
||||
|
||||
-add_library(blk ${libblk_srcs})
|
||||
+add_library(blk STATIC ${libblk_srcs})
|
||||
target_include_directories(blk PRIVATE "./")
|
||||
|
||||
if(HAVE_LIBAIO)
|
@ -1,11 +0,0 @@
|
||||
--- ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt.orig 2021-02-01 08:25:18.006965821 -0500
|
||||
+++ ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt 2021-02-01 08:25:34.244407147 -0500
|
||||
@@ -19,7 +19,7 @@
|
||||
target_link_libraries(ceph_test_neorados_op_speed
|
||||
libneorados fmt::fmt ${unittest_libs})
|
||||
|
||||
-add_library(neoradostest-support common_tests.cc)
|
||||
+add_library(neoradostest-support STATIC common_tests.cc)
|
||||
target_link_libraries(neoradostest-support
|
||||
libneorados fmt::fmt)
|
||||
|
@ -1,63 +0,0 @@
|
||||
From 178f6bdac97b57300bbe0956633cf686a7e3ccee Mon Sep 17 00:00:00 2001
|
||||
From: Yuval Lifshitz <ylifshit@redhat.com>
|
||||
Date: Fri, 12 Mar 2021 08:56:45 +0200
|
||||
Subject: [PATCH] librgw/notifications: initialize kafka and amqp
|
||||
|
||||
Fixes: https://tracker.ceph.com/issues/49738
|
||||
|
||||
Signed-off-by: Yuval Lifshitz <ylifshit@redhat.com>
|
||||
---
|
||||
src/rgw/librgw.cc | 23 +++++++++++++++++++++++
|
||||
1 file changed, 23 insertions(+)
|
||||
|
||||
diff --git a/src/rgw/librgw.cc b/src/rgw/librgw.cc
|
||||
index 012cc54c3b..a5351dbe7c 100644
|
||||
--- a/src/rgw/librgw.cc
|
||||
+++ b/src/rgw/librgw.cc
|
||||
@@ -53,6 +53,12 @@
|
||||
#include "rgw_http_client.h"
|
||||
#include "rgw_http_client_curl.h"
|
||||
#include "rgw_perf_counters.h"
|
||||
+#ifdef WITH_RADOSGW_AMQP_ENDPOINT
|
||||
+#include "rgw_amqp.h"
|
||||
+#endif
|
||||
+#ifdef WITH_RADOSGW_KAFKA_ENDPOINT
|
||||
+#include "rgw_kafka.h"
|
||||
+#endif
|
||||
|
||||
#include "services/svc_zone.h"
|
||||
|
||||
@@ -617,6 +623,17 @@ namespace rgw {
|
||||
/* ignore error */
|
||||
}
|
||||
|
||||
+#ifdef WITH_RADOSGW_AMQP_ENDPOINT
|
||||
+ if (!rgw::amqp::init(cct.get())) {
|
||||
+ derr << "ERROR: failed to initialize AMQP manager" << dendl;
|
||||
+ }
|
||||
+#endif
|
||||
+#ifdef WITH_RADOSGW_KAFKA_ENDPOINT
|
||||
+ if (!rgw::kafka::init(cct.get())) {
|
||||
+ derr << "ERROR: failed to initialize Kafka manager" << dendl;
|
||||
+ }
|
||||
+#endif
|
||||
+
|
||||
return 0;
|
||||
} /* RGWLib::init() */
|
||||
|
||||
@@ -645,6 +662,12 @@ namespace rgw {
|
||||
rgw_shutdown_resolver();
|
||||
rgw_http_client_cleanup();
|
||||
rgw::curl::cleanup_curl();
|
||||
+#ifdef WITH_RADOSGW_AMQP_ENDPOINT
|
||||
+ rgw::amqp::shutdown();
|
||||
+#endif
|
||||
+#ifdef WITH_RADOSGW_KAFKA_ENDPOINT
|
||||
+ rgw::kafka::shutdown();
|
||||
+#endif
|
||||
|
||||
rgw_perf_stop(g_ceph_context);
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,23 +0,0 @@
|
||||
--- a/src/test/rgw/amqp_mock.cc
|
||||
+++ b/src/test/rgw/amqp_mock.cc
|
||||
@@ -291,7 +291,11 @@ amqp_confirm_select_ok_t* amqp_confirm_select(amqp_connection_state_t state, amq
|
||||
return state->confirm;
|
||||
}
|
||||
|
||||
-int amqp_simple_wait_frame_noblock(amqp_connection_state_t state, amqp_frame_t *decoded_frame, struct timeval* tv) {
|
||||
+extern "C" {
|
||||
+
|
||||
+int amqp_simple_wait_frame_noblock(amqp_connection_state_t state,
|
||||
+ amqp_frame_t *decoded_frame,
|
||||
+ const struct timeval* tv) {
|
||||
if (state->socket && state->socket->open_called &&
|
||||
state->login_called && state->channel1 && state->channel2 && state->exchange &&
|
||||
state->queue && state->consume && state->confirm && !FAIL_NEXT_READ) {
|
||||
@@ -345,6 +349,7 @@ int amqp_simple_wait_frame_noblock(amqp_connection_state_t state, amqp_frame_t *
|
||||
}
|
||||
return AMQP_STATUS_CONNECTION_CLOSED;
|
||||
}
|
||||
+} // extern "C"
|
||||
|
||||
amqp_basic_consume_ok_t* amqp_basic_consume(
|
||||
amqp_connection_state_t state, amqp_channel_t channel, amqp_bytes_t queue,
|
@ -1,11 +0,0 @@
|
||||
--- ceph-16.2.4/src/compressor/snappy/SnappyCompressor.h.orig 2021-05-26 08:30:26.205447315 -0400
|
||||
+++ ceph-16.2.4/src/compressor/snappy/SnappyCompressor.h 2021-05-26 08:31:22.570443033 -0400
|
||||
@@ -97,7 +97,7 @@
|
||||
if (qat_enabled)
|
||||
return qat_accel.decompress(p, compressed_len, dst, compressor_message);
|
||||
#endif
|
||||
- snappy::uint32 res_len = 0;
|
||||
+ std::uint32_t res_len = 0;
|
||||
BufferlistSource source_1(p, compressed_len);
|
||||
if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
|
||||
return -1;
|
@ -1,10 +0,0 @@
|
||||
--- ceph-16.2.4/src/common/Formatter.cc.orig 2021-07-07 09:32:25.513818420 -0400
|
||||
+++ ceph-16.2.4/src/common/Formatter.cc 2021-07-07 09:44:42.007373294 -0400
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <fmt/format.h>
|
||||
#include <set>
|
||||
#include <limits>
|
||||
+#include <algorithm>
|
||||
|
||||
// -----------------------
|
||||
namespace ceph {
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/rgw/rgw_string.h b/src/rgw/rgw_string.h
|
||||
index 257daa9c1fe..90e64f98a25 100644
|
||||
--- a/src/rgw/rgw_string.h
|
||||
+++ b/src/rgw/rgw_string.h
|
||||
@@ -8,6 +8,8 @@
|
||||
#include <stdlib.h>
|
||||
#include <limits.h>
|
||||
#include <string_view>
|
||||
+#include <string>
|
||||
+#include <stdexcept>
|
||||
|
||||
#include <boost/container/small_vector.hpp>
|
||||
|
@ -1,296 +0,0 @@
|
||||
diff --git a/src/kv/rocksdb_cache/BinnedLRUCache.cc b/src/kv/rocksdb_cache/BinnedLRUCache.cc
|
||||
index 0d657883e92de..47c56e2ddd769 100644
|
||||
--- a/src/kv/rocksdb_cache/BinnedLRUCache.cc
|
||||
+++ b/src/kv/rocksdb_cache/BinnedLRUCache.cc
|
||||
@@ -151,13 +151,20 @@ void BinnedLRUCacheShard::EraseUnRefEntries() {
|
||||
}
|
||||
}
|
||||
|
||||
-void BinnedLRUCacheShard::ApplyToAllCacheEntries(void (*callback)(void*, size_t),
|
||||
- bool thread_safe) {
|
||||
+void BinnedLRUCacheShard::ApplyToAllCacheEntries(
|
||||
+ const std::function<void(const rocksdb::Slice& key,
|
||||
+ void* value,
|
||||
+ size_t charge,
|
||||
+ DeleterFn)>& callback,
|
||||
+ bool thread_safe)
|
||||
+{
|
||||
if (thread_safe) {
|
||||
mutex_.lock();
|
||||
}
|
||||
table_.ApplyToAllCacheEntries(
|
||||
- [callback](BinnedLRUHandle* h) { callback(h->value, h->charge); });
|
||||
+ [callback](BinnedLRUHandle* h) {
|
||||
+ callback(h->key(), h->value, h->charge, h->deleter);
|
||||
+ });
|
||||
if (thread_safe) {
|
||||
mutex_.unlock();
|
||||
}
|
||||
@@ -345,7 +352,7 @@ bool BinnedLRUCacheShard::Release(rocksdb::Cache::Handle* handle, bool force_era
|
||||
|
||||
rocksdb::Status BinnedLRUCacheShard::Insert(const rocksdb::Slice& key, uint32_t hash, void* value,
|
||||
size_t charge,
|
||||
- void (*deleter)(const rocksdb::Slice& key, void* value),
|
||||
+ DeleterFn deleter,
|
||||
rocksdb::Cache::Handle** handle, rocksdb::Cache::Priority priority) {
|
||||
auto e = new BinnedLRUHandle();
|
||||
rocksdb::Status s;
|
||||
@@ -464,6 +471,12 @@ std::string BinnedLRUCacheShard::GetPrintableOptions() const {
|
||||
return std::string(buffer);
|
||||
}
|
||||
|
||||
+DeleterFn BinnedLRUCacheShard::GetDeleter(rocksdb::Cache::Handle* h) const
|
||||
+{
|
||||
+ auto* handle = reinterpret_cast<BinnedLRUHandle*>(h);
|
||||
+ return handle->deleter;
|
||||
+}
|
||||
+
|
||||
BinnedLRUCache::BinnedLRUCache(CephContext *c,
|
||||
size_t capacity,
|
||||
int num_shard_bits,
|
||||
@@ -519,6 +532,13 @@ void BinnedLRUCache::DisownData() {
|
||||
#endif // !__SANITIZE_ADDRESS__
|
||||
}
|
||||
|
||||
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
|
||||
+DeleterFn BinnedLRUCache::GetDeleter(Handle* handle) const
|
||||
+{
|
||||
+ return reinterpret_cast<const BinnedLRUHandle*>(handle)->deleter;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
size_t BinnedLRUCache::TEST_GetLRUSize() {
|
||||
size_t lru_size_of_all_shards = 0;
|
||||
for (int i = 0; i < num_shards_; i++) {
|
||||
diff --git a/src/kv/rocksdb_cache/BinnedLRUCache.h b/src/kv/rocksdb_cache/BinnedLRUCache.h
|
||||
index 85608be0e5734..88bf4502e8927 100644
|
||||
--- a/src/kv/rocksdb_cache/BinnedLRUCache.h
|
||||
+++ b/src/kv/rocksdb_cache/BinnedLRUCache.h
|
||||
@@ -56,7 +56,7 @@ std::shared_ptr<rocksdb::Cache> NewBinnedLRUCache(
|
||||
|
||||
struct BinnedLRUHandle {
|
||||
void* value;
|
||||
- void (*deleter)(const rocksdb::Slice&, void* value);
|
||||
+ DeleterFn deleter;
|
||||
BinnedLRUHandle* next_hash;
|
||||
BinnedLRUHandle* next;
|
||||
BinnedLRUHandle* prev;
|
||||
@@ -189,7 +189,7 @@ class alignas(CACHE_LINE_SIZE) BinnedLRUCacheShard : public CacheShard {
|
||||
// Like Cache methods, but with an extra "hash" parameter.
|
||||
virtual rocksdb::Status Insert(const rocksdb::Slice& key, uint32_t hash, void* value,
|
||||
size_t charge,
|
||||
- void (*deleter)(const rocksdb::Slice& key, void* value),
|
||||
+ DeleterFn deleter,
|
||||
rocksdb::Cache::Handle** handle,
|
||||
rocksdb::Cache::Priority priority) override;
|
||||
virtual rocksdb::Cache::Handle* Lookup(const rocksdb::Slice& key, uint32_t hash) override;
|
||||
@@ -205,13 +205,19 @@ class alignas(CACHE_LINE_SIZE) BinnedLRUCacheShard : public CacheShard {
|
||||
virtual size_t GetUsage() const override;
|
||||
virtual size_t GetPinnedUsage() const override;
|
||||
|
||||
- virtual void ApplyToAllCacheEntries(void (*callback)(void*, size_t),
|
||||
- bool thread_safe) override;
|
||||
+ virtual void ApplyToAllCacheEntries(
|
||||
+ const std::function<void(const rocksdb::Slice& key,
|
||||
+ void* value,
|
||||
+ size_t charge,
|
||||
+ DeleterFn)>& callback,
|
||||
+ bool thread_safe) override;
|
||||
|
||||
virtual void EraseUnRefEntries() override;
|
||||
|
||||
virtual std::string GetPrintableOptions() const override;
|
||||
|
||||
+ virtual DeleterFn GetDeleter(rocksdb::Cache::Handle* handle) const override;
|
||||
+
|
||||
void TEST_GetLRUList(BinnedLRUHandle** lru, BinnedLRUHandle** lru_low_pri);
|
||||
|
||||
// Retrieves number of elements in LRU, for unit test purpose only
|
||||
@@ -304,7 +310,9 @@ class BinnedLRUCache : public ShardedCache {
|
||||
virtual size_t GetCharge(Handle* handle) const override;
|
||||
virtual uint32_t GetHash(Handle* handle) const override;
|
||||
virtual void DisownData() override;
|
||||
-
|
||||
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
|
||||
+ virtual DeleterFn GetDeleter(Handle* handle) const override;
|
||||
+#endif
|
||||
// Retrieves number of elements in LRU, for unit test purpose only
|
||||
size_t TEST_GetLRUSize();
|
||||
// Sets the high pri pool ratio
|
||||
diff --git a/src/kv/rocksdb_cache/ShardedCache.cc b/src/kv/rocksdb_cache/ShardedCache.cc
|
||||
index 367140a94d8be..6cbd89ad6472c 100644
|
||||
--- a/src/kv/rocksdb_cache/ShardedCache.cc
|
||||
+++ b/src/kv/rocksdb_cache/ShardedCache.cc
|
||||
@@ -44,7 +44,7 @@ void ShardedCache::SetStrictCapacityLimit(bool strict_capacity_limit) {
|
||||
}
|
||||
|
||||
rocksdb::Status ShardedCache::Insert(const rocksdb::Slice& key, void* value, size_t charge,
|
||||
- void (*deleter)(const rocksdb::Slice& key, void* value),
|
||||
+ DeleterFn deleter,
|
||||
rocksdb::Cache::Handle** handle, Priority priority) {
|
||||
uint32_t hash = HashSlice(key);
|
||||
return GetShard(Shard(hash))
|
||||
@@ -109,13 +109,36 @@ size_t ShardedCache::GetPinnedUsage() const {
|
||||
return usage;
|
||||
}
|
||||
|
||||
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
|
||||
+DeleterFn ShardedCache::GetDeleter(Handle* handle) const
|
||||
+{
|
||||
+ uint32_t hash = GetHash(handle);
|
||||
+ return GetShard(Shard(hash))->GetDeleter(handle);
|
||||
+}
|
||||
+
|
||||
+void ShardedCache::ApplyToAllEntries(
|
||||
+ const std::function<void(const rocksdb::Slice& key, void* value, size_t charge,
|
||||
+ DeleterFn deleter)>& callback,
|
||||
+ const ApplyToAllEntriesOptions& opts)
|
||||
+{
|
||||
+ int num_shards = 1 << num_shard_bits_;
|
||||
+ for (int s = 0; s < num_shards; s++) {
|
||||
+ GetShard(s)->ApplyToAllCacheEntries(callback, true /* thread_safe */);
|
||||
+ }
|
||||
+}
|
||||
+#else
|
||||
void ShardedCache::ApplyToAllCacheEntries(void (*callback)(void*, size_t),
|
||||
bool thread_safe) {
|
||||
int num_shards = 1 << num_shard_bits_;
|
||||
for (int s = 0; s < num_shards; s++) {
|
||||
- GetShard(s)->ApplyToAllCacheEntries(callback, thread_safe);
|
||||
+ GetShard(s)->ApplyToAllCacheEntries(
|
||||
+ [callback](const rocksdb::Slice&, void* value, size_t charge, DeleterFn) {
|
||||
+ callback(value, charge);
|
||||
+ },
|
||||
+ thread_safe);
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
void ShardedCache::EraseUnRefEntries() {
|
||||
int num_shards = 1 << num_shard_bits_;
|
||||
@@ -131,7 +154,7 @@ std::string ShardedCache::GetPrintableOptions() const {
|
||||
char buffer[kBufferSize];
|
||||
{
|
||||
std::lock_guard<std::mutex> l(capacity_mutex_);
|
||||
- snprintf(buffer, kBufferSize, " capacity : %" ROCKSDB_PRIszt "\n",
|
||||
+ snprintf(buffer, kBufferSize, " capacity : %zu\n",
|
||||
capacity_);
|
||||
ret.append(buffer);
|
||||
snprintf(buffer, kBufferSize, " num_shard_bits : %d\n", num_shard_bits_);
|
||||
diff --git a/src/kv/rocksdb_cache/ShardedCache.h b/src/kv/rocksdb_cache/ShardedCache.h
|
||||
index 4d64893ab1c7b..f98421a09a33a 100644
|
||||
--- a/src/kv/rocksdb_cache/ShardedCache.h
|
||||
+++ b/src/kv/rocksdb_cache/ShardedCache.h
|
||||
@@ -14,6 +14,7 @@
|
||||
#include <string>
|
||||
#include <mutex>
|
||||
|
||||
+#include "rocksdb/version.h"
|
||||
#include "rocksdb/cache.h"
|
||||
#include "include/ceph_hash.h"
|
||||
#include "common/PriorityCache.h"
|
||||
@@ -22,10 +23,11 @@
|
||||
#ifndef CACHE_LINE_SIZE
|
||||
#define CACHE_LINE_SIZE 64 // XXX arch-specific define
|
||||
#endif
|
||||
-#define ROCKSDB_PRIszt "zu"
|
||||
|
||||
namespace rocksdb_cache {
|
||||
|
||||
+using DeleterFn = void (*)(const rocksdb::Slice& key, void* value);
|
||||
+
|
||||
// Single cache shard interface.
|
||||
class CacheShard {
|
||||
public:
|
||||
@@ -34,7 +36,7 @@ class CacheShard {
|
||||
|
||||
virtual rocksdb::Status Insert(const rocksdb::Slice& key, uint32_t hash, void* value,
|
||||
size_t charge,
|
||||
- void (*deleter)(const rocksdb::Slice& key, void* value),
|
||||
+ DeleterFn deleter,
|
||||
rocksdb::Cache::Handle** handle, rocksdb::Cache::Priority priority) = 0;
|
||||
virtual rocksdb::Cache::Handle* Lookup(const rocksdb::Slice& key, uint32_t hash) = 0;
|
||||
virtual bool Ref(rocksdb::Cache::Handle* handle) = 0;
|
||||
@@ -44,10 +46,15 @@ class CacheShard {
|
||||
virtual void SetStrictCapacityLimit(bool strict_capacity_limit) = 0;
|
||||
virtual size_t GetUsage() const = 0;
|
||||
virtual size_t GetPinnedUsage() const = 0;
|
||||
- virtual void ApplyToAllCacheEntries(void (*callback)(void*, size_t),
|
||||
- bool thread_safe) = 0;
|
||||
+ virtual void ApplyToAllCacheEntries(
|
||||
+ const std::function<void(const rocksdb::Slice& key,
|
||||
+ void* value,
|
||||
+ size_t charge,
|
||||
+ DeleterFn)>& callback,
|
||||
+ bool thread_safe) = 0;
|
||||
virtual void EraseUnRefEntries() = 0;
|
||||
virtual std::string GetPrintableOptions() const { return ""; }
|
||||
+ virtual DeleterFn GetDeleter(rocksdb::Cache::Handle* handle) const = 0;
|
||||
};
|
||||
|
||||
// Generic cache interface which shards cache by hash of keys. 2^num_shard_bits
|
||||
@@ -57,34 +64,43 @@ class ShardedCache : public rocksdb::Cache, public PriorityCache::PriCache {
|
||||
public:
|
||||
ShardedCache(size_t capacity, int num_shard_bits, bool strict_capacity_limit);
|
||||
virtual ~ShardedCache() = default;
|
||||
+ // rocksdb::Cache
|
||||
virtual const char* Name() const override = 0;
|
||||
- virtual CacheShard* GetShard(int shard) = 0;
|
||||
- virtual const CacheShard* GetShard(int shard) const = 0;
|
||||
- virtual void* Value(Handle* handle) override = 0;
|
||||
- virtual size_t GetCharge(Handle* handle) const = 0;
|
||||
- virtual uint32_t GetHash(Handle* handle) const = 0;
|
||||
- virtual void DisownData() override = 0;
|
||||
-
|
||||
- virtual void SetCapacity(size_t capacity) override;
|
||||
- virtual void SetStrictCapacityLimit(bool strict_capacity_limit) override;
|
||||
-
|
||||
virtual rocksdb::Status Insert(const rocksdb::Slice& key, void* value, size_t charge,
|
||||
- void (*deleter)(const rocksdb::Slice& key, void* value),
|
||||
+ DeleterFn,
|
||||
rocksdb::Cache::Handle** handle, Priority priority) override;
|
||||
virtual rocksdb::Cache::Handle* Lookup(const rocksdb::Slice& key, rocksdb::Statistics* stats) override;
|
||||
virtual bool Ref(rocksdb::Cache::Handle* handle) override;
|
||||
virtual bool Release(rocksdb::Cache::Handle* handle, bool force_erase = false) override;
|
||||
+ virtual void* Value(Handle* handle) override = 0;
|
||||
virtual void Erase(const rocksdb::Slice& key) override;
|
||||
virtual uint64_t NewId() override;
|
||||
- virtual size_t GetCapacity() const override;
|
||||
+ virtual void SetCapacity(size_t capacity) override;
|
||||
+ virtual void SetStrictCapacityLimit(bool strict_capacity_limit) override;
|
||||
virtual bool HasStrictCapacityLimit() const override;
|
||||
+ virtual size_t GetCapacity() const override;
|
||||
virtual size_t GetUsage() const override;
|
||||
virtual size_t GetUsage(rocksdb::Cache::Handle* handle) const override;
|
||||
virtual size_t GetPinnedUsage() const override;
|
||||
+ virtual size_t GetCharge(Handle* handle) const = 0;
|
||||
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
|
||||
+ virtual DeleterFn GetDeleter(Handle* handle) const override;
|
||||
+#endif
|
||||
+ virtual void DisownData() override = 0;
|
||||
+#if (ROCKSDB_MAJOR >= 6 && ROCKSDB_MINOR >= 22)
|
||||
+ virtual void ApplyToAllEntries(
|
||||
+ const std::function<void(const rocksdb::Slice& key, void* value, size_t charge,
|
||||
+ DeleterFn deleter)>& callback,
|
||||
+ const ApplyToAllEntriesOptions& opts) override;
|
||||
+#else
|
||||
virtual void ApplyToAllCacheEntries(void (*callback)(void*, size_t),
|
||||
bool thread_safe) override;
|
||||
+#endif
|
||||
virtual void EraseUnRefEntries() override;
|
||||
virtual std::string GetPrintableOptions() const override;
|
||||
+ virtual CacheShard* GetShard(int shard) = 0;
|
||||
+ virtual const CacheShard* GetShard(int shard) const = 0;
|
||||
+ virtual uint32_t GetHash(Handle* handle) const = 0;
|
||||
|
||||
int GetNumShardBits() const { return num_shard_bits_; }
|
||||
|
||||
@@ -120,7 +136,7 @@ class ShardedCache : public rocksdb::Cache, public PriorityCache::PriCache {
|
||||
// return Hash(s.data(), s.size(), 0);
|
||||
}
|
||||
|
||||
- uint32_t Shard(uint32_t hash) {
|
||||
+ uint32_t Shard(uint32_t hash) const {
|
||||
// Note, hash >> 32 yields hash in gcc, not the zero we expect!
|
||||
return (num_shard_bits_ > 0) ? (hash >> (32 - num_shard_bits_)) : 0;
|
||||
}
|
Loading…
Reference in New Issue
Block a user