Merge branch 'f17'
Signed-off-by: Jonathan Dieter <jdieter@lesbg.com>
This commit is contained in:
commit
b003ada4bc
2
.gitignore
vendored
2
.gitignore
vendored
@ -5,4 +5,4 @@ ceph-0.20.tar.gz
|
|||||||
/ceph-0.31.tar.gz
|
/ceph-0.31.tar.gz
|
||||||
/ceph-0.37.tar.gz
|
/ceph-0.37.tar.gz
|
||||||
/ceph-0.39.tar.gz
|
/ceph-0.39.tar.gz
|
||||||
/ceph-0.41.tar.bz2
|
/ceph-0.43.tar.bz2
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
diff -up ceph-0.39/src/mds/MDBalancer.cc.fix ceph-0.39/src/mds/MDBalancer.cc
|
|
||||||
--- ceph-0.39/src/mds/MDBalancer.cc.fix 2012-02-16 12:23:26.582302711 -0500
|
|
||||||
+++ ceph-0.39/src/mds/MDBalancer.cc 2012-02-16 12:31:44.386396603 -0500
|
|
||||||
@@ -1155,6 +1155,7 @@ void MDBalancer::dump_pop_map()
|
|
||||||
{
|
|
||||||
return; // this is dumb
|
|
||||||
|
|
||||||
+/*
|
|
||||||
|
|
||||||
char fn[32];
|
|
||||||
snprintf(fn, sizeof(fn), "popdump.%d.mds%d", beat_epoch, mds->get_nodeid());
|
|
||||||
@@ -1174,10 +1175,9 @@ void MDBalancer::dump_pop_map()
|
|
||||||
iq.pop_front();
|
|
||||||
|
|
||||||
// pop stats
|
|
||||||
- /*for (int a=0; a<MDS_NPOP; a++)
|
|
||||||
- for (int b=0; b<META_NPOP; b++)
|
|
||||||
- myfile << in->popularity[a].pop[b].get(now) << "\t";
|
|
||||||
- */
|
|
||||||
+ //for (int a=0; a<MDS_NPOP; a++)
|
|
||||||
+ // for (int b=0; b<META_NPOP; b++)
|
|
||||||
+ // myfile << in->popularity[a].pop[b].get(now) << "\t";
|
|
||||||
|
|
||||||
// recurse, depth-first.
|
|
||||||
if (in->is_dir()) {
|
|
||||||
@@ -1214,6 +1214,7 @@ void MDBalancer::dump_pop_map()
|
|
||||||
}
|
|
||||||
|
|
||||||
myfile.close();
|
|
||||||
+*/
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
@ -1,67 +0,0 @@
|
|||||||
diff -up ceph-0.41/src/cephfs.cc.compilefix ceph-0.41/src/cephfs.cc
|
|
||||||
--- ceph-0.41/src/cephfs.cc.compilefix 2012-02-16 21:08:19.983652818 -0500
|
|
||||||
+++ ceph-0.41/src/cephfs.cc 2012-02-16 21:08:31.917550083 -0500
|
|
||||||
@@ -24,6 +24,7 @@
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#include <fcntl.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
+#include <unistd.h>
|
|
||||||
#include "client/ioctl.h"
|
|
||||||
|
|
||||||
using namespace std;
|
|
||||||
diff -up ceph-0.41/src/common/safe_io.h.compilefix ceph-0.41/src/common/safe_io.h
|
|
||||||
--- ceph-0.41/src/common/safe_io.h.compilefix 2012-02-16 12:53:31.456514774 -0500
|
|
||||||
+++ ceph-0.41/src/common/safe_io.h 2012-02-16 12:54:00.045233017 -0500
|
|
||||||
@@ -16,6 +16,7 @@
|
|
||||||
#define CEPH_SAFE_IO
|
|
||||||
|
|
||||||
#include "common/compiler_extensions.h"
|
|
||||||
+#include <sys/types.h>
|
|
||||||
|
|
||||||
#ifdef __cplusplus
|
|
||||||
extern "C" {
|
|
||||||
diff -up ceph-0.41/src/osd/PG.cc.compilefix ceph-0.41/src/osd/PG.cc
|
|
||||||
--- ceph-0.41/src/osd/PG.cc.compilefix 2012-02-16 20:58:21.039559849 -0500
|
|
||||||
+++ ceph-0.41/src/osd/PG.cc 2012-02-16 20:59:07.920149937 -0500
|
|
||||||
@@ -4830,13 +4830,13 @@ bool PG::PriorSet::affected_by_map(const
|
|
||||||
}
|
|
||||||
|
|
||||||
// did a down osd in cur get (re)marked as lost?
|
|
||||||
- map<int,epoch_t>::const_iterator p = blocked_by.find(o);
|
|
||||||
- if (p != blocked_by.end()) {
|
|
||||||
+ map<int,epoch_t>::const_iterator r = blocked_by.find(o);
|
|
||||||
+ if (r != blocked_by.end()) {
|
|
||||||
if (!osdmap->exists(o)) {
|
|
||||||
dout(10) << "affected_by_map osd." << o << " no longer exists" << dendl;
|
|
||||||
return true;
|
|
||||||
}
|
|
||||||
- if (osdmap->get_info(o).lost_at != p->second) {
|
|
||||||
+ if (osdmap->get_info(o).lost_at != r->second) {
|
|
||||||
dout(10) << "affected_by_map osd." << o << " (re)marked as lost" << dendl;
|
|
||||||
return true;
|
|
||||||
}
|
|
||||||
diff -up ceph-0.41/src/osd/ReplicatedPG.cc.compilefix ceph-0.41/src/osd/ReplicatedPG.cc
|
|
||||||
--- ceph-0.41/src/osd/ReplicatedPG.cc.compilefix 2012-02-16 21:03:26.140892128 -0500
|
|
||||||
+++ ceph-0.41/src/osd/ReplicatedPG.cc 2012-02-16 21:04:45.190200945 -0500
|
|
||||||
@@ -5436,8 +5436,8 @@ int ReplicatedPG::recover_replicas(int m
|
|
||||||
}
|
|
||||||
|
|
||||||
dout(10) << __func__ << ": recover_object_replicas(" << soid << ")" << dendl;
|
|
||||||
- map<hobject_t,Missing::item>::const_iterator p = m.missing.find(soid);
|
|
||||||
- started += recover_object_replicas(soid, p->second.need);
|
|
||||||
+ map<hobject_t,Missing::item>::const_iterator r = m.missing.find(soid);
|
|
||||||
+ started += recover_object_replicas(soid, r->second.need);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
diff -up ceph-0.41/src/test/system/systest_runnable.cc.compilefix ceph-0.41/src/test/system/systest_runnable.cc
|
|
||||||
--- ceph-0.41/src/test/system/systest_runnable.cc.compilefix 2012-02-16 12:54:35.430884275 -0500
|
|
||||||
+++ ceph-0.41/src/test/system/systest_runnable.cc 2012-02-16 12:54:45.923780862 -0500
|
|
||||||
@@ -28,6 +28,7 @@
|
|
||||||
#include <sys/syscall.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <sys/wait.h>
|
|
||||||
+#include <unistd.h>
|
|
||||||
#include <vector>
|
|
||||||
|
|
||||||
#if defined(__FreeBSD__)
|
|
23
ceph.spec
23
ceph.spec
@ -1,5 +1,5 @@
|
|||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 0.41
|
Version: 0.43
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: User space components of the Ceph file system
|
Summary: User space components of the Ceph file system
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
@ -9,10 +9,8 @@ URL: http://ceph.newdream.net/
|
|||||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
|
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
|
||||||
Patch0: ceph-init-fix.patch
|
Patch0: ceph-init-fix.patch
|
||||||
Patch1: ceph.logrotate.patch
|
Patch1: ceph.logrotate.patch
|
||||||
Patch2: ceph-0.39-comment-out-unused-code-in-dump_pop_map.patch
|
|
||||||
Patch3: ceph-0.41-compile-fixes.patch
|
|
||||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm,
|
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
|
||||||
# google-perftools is not available on these:
|
# google-perftools is not available on these:
|
||||||
%ifnarch ppc64 s390 s390x
|
%ifnarch ppc64 s390 s390x
|
||||||
BuildRequires: gperftools-devel
|
BuildRequires: gperftools-devel
|
||||||
@ -81,9 +79,7 @@ file system.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .init
|
%patch0 -p1 -b .init
|
||||||
%patch1 -p0
|
%patch1 -p0
|
||||||
%patch2 -p1 -b .unusedfix
|
|
||||||
%patch3 -p1 -b .compilefix
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -108,6 +104,7 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/
|
|||||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/stat
|
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/ceph/stat
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/ceph
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/ceph
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -150,6 +147,7 @@ fi
|
|||||||
%{_bindir}/rbd
|
%{_bindir}/rbd
|
||||||
%{_bindir}/ceph-debugpack
|
%{_bindir}/ceph-debugpack
|
||||||
%{_bindir}/ceph-coverage
|
%{_bindir}/ceph-coverage
|
||||||
|
%{_bindir}/ceph-dencoder
|
||||||
%{_initrddir}/ceph
|
%{_initrddir}/ceph
|
||||||
%{_libdir}/libcephfs.so.*
|
%{_libdir}/libcephfs.so.*
|
||||||
%{_libdir}/librados.so.*
|
%{_libdir}/librados.so.*
|
||||||
@ -185,7 +183,8 @@ fi
|
|||||||
%{_mandir}/man8/rbd.8*
|
%{_mandir}/man8/rbd.8*
|
||||||
%{_mandir}/man8/ceph-authtool.8*
|
%{_mandir}/man8/ceph-authtool.8*
|
||||||
%{_mandir}/man8/ceph-debugpack.8*
|
%{_mandir}/man8/ceph-debugpack.8*
|
||||||
%{_mandir}/man8/ceph-clsinfo.8.gz
|
%{_mandir}/man8/ceph-clsinfo.8*
|
||||||
|
%{_mandir}/man8/ceph-dencoder.8*
|
||||||
%{python_sitelib}/rados.py*
|
%{python_sitelib}/rados.py*
|
||||||
%{python_sitelib}/rgw.py*
|
%{python_sitelib}/rgw.py*
|
||||||
%{python_sitelib}/rbd.py*
|
%{python_sitelib}/rbd.py*
|
||||||
@ -239,6 +238,14 @@ fi
|
|||||||
%{_bindir}/boto_tool
|
%{_bindir}/boto_tool
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 5 2012 Jonathan Dieter <jdieter@lesbg.com> - 0.43-1
|
||||||
|
- Update to 0.43
|
||||||
|
- Remove upstreamed compile fixes patch
|
||||||
|
- Remove obsoleted dump_pop patch
|
||||||
|
|
||||||
|
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.41-2
|
||||||
|
- Rebuilt for c++ ABI breakage
|
||||||
|
|
||||||
* Thu Feb 16 2012 Tom Callaway <spot@fedoraproject.org> 0.41-1
|
* Thu Feb 16 2012 Tom Callaway <spot@fedoraproject.org> 0.41-1
|
||||||
- update to 0.41
|
- update to 0.41
|
||||||
- fix issues preventing build
|
- fix issues preventing build
|
||||||
|
Loading…
Reference in New Issue
Block a user