Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2024-01-25 07:31:18 -05:00
parent 4db83e6332
commit 9c5508803e
2 changed files with 19 additions and 0 deletions

View File

@ -0,0 +1,18 @@
--- ceph/src/CMakeLists.txt.orig 2023-11-01 11:53:53.618167190 -0400
+++ ceph/src/CMakeLists.txt 2023-11-01 13:52:51.292643490 -0400
@@ -625,6 +625,7 @@
add_subdirectory(perfglue)
add_library(rados_snap_set_diff_obj OBJECT librados/snap_set_diff.cc)
+add_dependencies(rados_snap_set_diff_obj legacy-option-headers)
option(WITH_LIBRADOSSTRIPER "build with libradosstriper support" ON)
@@ -881,6 +882,7 @@
add_library(krbd STATIC krbd.cc
$<TARGET_OBJECTS:parse_secret_objs>)
target_link_libraries(krbd keyutils::keyutils)
+ add_dependencies(krbd legacy-option-headers)
endif()
add_subdirectory(librbd)
if(WITH_FUSE)

View File

@ -239,6 +239,7 @@ Patch0030: 0030-src-rgw-rgw_asio_client.cc.patch
Patch0032: 0032-cmake-modules-BuildBoost.cmake.patch
Patch0033: 0033-boost-asm.patch
Patch0034: 0034-src-pybind-rbd-rbd.pyx.patch
Patch0035: 0035-src-CMakeLists.txt.patch
Patch0036: 0036-18.2.1.release.patch
Patch0038: ceph-c99-2.patch
Patch0039: 0039-src-common-dout.h.patch