- update to 0.31
This commit is contained in:
parent
81c2739f9a
commit
9b4a6bb004
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ ceph-0.20.tar.gz
|
||||
/ceph-0.21.3.tar.gz
|
||||
/ceph-0.25.1.tar.gz
|
||||
/ceph-0.26.tar.gz
|
||||
/ceph-0.31.tar.gz
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -up ceph-0.26/src/rgw/rgw_cache.h.josef ceph-0.26/src/rgw/rgw_cache.h
|
||||
--- ceph-0.26/src/rgw/rgw_cache.h.josef 2011-04-05 15:19:29.364573666 -0700
|
||||
+++ ceph-0.26/src/rgw/rgw_cache.h 2011-04-05 15:20:11.946014058 -0700
|
||||
@@ -98,12 +98,12 @@ int RGWCache<T>::obj_stat(std::string& b
|
||||
bufferlist bl;
|
||||
uint64_t size;
|
||||
time_t mtime;
|
||||
+ int64_t t;
|
||||
|
||||
int r = cache.get(name, bl);
|
||||
if (r == 0) {
|
||||
bufferlist::iterator iter = bl.begin();
|
||||
::decode(size, iter);
|
||||
- int64_t t;
|
||||
::decode(t, iter);
|
||||
mtime = (time_t)t;
|
||||
goto done;
|
||||
@@ -113,7 +113,7 @@ int RGWCache<T>::obj_stat(std::string& b
|
||||
return r;
|
||||
bl.clear();
|
||||
::encode(size, bl);
|
||||
- int64_t t = (int64_t)mtime;
|
||||
+ t = (int64_t)mtime;
|
||||
::encode(t, bl);
|
||||
cache.put(name, bl);
|
||||
done:
|
41
ceph.spec
41
ceph.spec
@ -1,6 +1,6 @@
|
||||
Name: ceph
|
||||
Version: 0.26
|
||||
Release: 2%{?dist}
|
||||
Version: 0.31
|
||||
Release: 1%{?dist}
|
||||
Summary: User space components of the Ceph file system
|
||||
License: LGPLv2
|
||||
Group: System Environment/Base
|
||||
@ -8,13 +8,12 @@ URL: http://ceph.newdream.net/
|
||||
|
||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.gz
|
||||
Patch0: ceph-init-fix.patch
|
||||
Patch1: ceph-fix-compile-error.patch
|
||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm,
|
||||
BuildRequires: cryptopp-devel, libatomic_ops-devel, google-perftools-devel
|
||||
BuildRequires: pkgconfig, libcurl-devel
|
||||
BuildRequires: pkgconfig, libcurl-devel, keyutils-libs-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires(post): chkconfig, binutils, libedit, google-perftools
|
||||
Requires(post): chkconfig, binutils, libedit
|
||||
Requires(preun): chkconfig
|
||||
Requires(preun): initscripts
|
||||
|
||||
@ -50,6 +49,16 @@ radosgw is an S3 HTTP REST gateway for the RADOS object store. It is
|
||||
implemented as a FastCGI module using libfcgi, and can be used in
|
||||
conjunction with any FastCGI capable web server.
|
||||
|
||||
%package obsync
|
||||
Summary: synchronize data between cloud object storage providers or a local directory
|
||||
Group: Productivity/Networking/Other
|
||||
License: LGPLv2
|
||||
Requires: python, python-boto
|
||||
%description obsync
|
||||
obsync is a tool to synchronize objects between cloud object
|
||||
storage providers, such as Amazon S3 (or compatible services), a
|
||||
Ceph RADOS cluster, or a local directory.
|
||||
|
||||
%package gcephtool
|
||||
Summary: Ceph graphical monitoring tool
|
||||
Group: System Environment/Base
|
||||
@ -64,7 +73,6 @@ file system.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .init
|
||||
%patch1 -p1 -b .compile
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -110,7 +118,6 @@ fi
|
||||
%{_bindir}/ceph
|
||||
%{_bindir}/cephfs
|
||||
%{_bindir}/cconf
|
||||
%{_bindir}/cclass
|
||||
%{_bindir}/cclsinfo
|
||||
%{_bindir}/crushtool
|
||||
%{_bindir}/monmaptool
|
||||
@ -126,11 +133,12 @@ fi
|
||||
%{_bindir}/rados
|
||||
%{_bindir}/rbd
|
||||
%{_bindir}/cdebugpack
|
||||
%{_bindir}/ceph-coverage
|
||||
%{_initrddir}/ceph
|
||||
%{_libdir}/libceph.so.*
|
||||
%{_libdir}/libcrush.so.*
|
||||
%{_libdir}/librados.so.*
|
||||
%{_libdir}/librbd.so.*
|
||||
%{_libdir}/librgw.so.*
|
||||
%{_libdir}/rados-classes/libcls_rbd.so.*
|
||||
/sbin/mkcephfs
|
||||
/sbin/mount.ceph
|
||||
@ -157,11 +165,11 @@ fi
|
||||
%{_mandir}/man8/rbd.8*
|
||||
%{_mandir}/man8/cauthtool.8*
|
||||
%{_mandir}/man8/cdebugpack.8*
|
||||
%{_mandir}/man8/cclass.8.gz
|
||||
%{_mandir}/man8/cclsinfo.8.gz
|
||||
%{python_sitelib}/rados.py
|
||||
%{python_sitelib}/rados.pyc
|
||||
%{python_sitelib}/rados.pyo
|
||||
%{python_sitelib}/rgw.py*
|
||||
%dir %{_localstatedir}/lib/ceph/
|
||||
%dir %{_localstatedir}/lib/ceph/tmp/
|
||||
%dir %{_localstatedir}/log/ceph/
|
||||
@ -183,18 +191,17 @@ fi
|
||||
%{_includedir}/rados/librados.h
|
||||
%{_includedir}/rados/librados.hpp
|
||||
%{_includedir}/rados/buffer.h
|
||||
%{_includedir}/rados/atomic.h
|
||||
%{_includedir}/rados/page.h
|
||||
%{_includedir}/rados/crc32c.h
|
||||
%{_includedir}/rados/Spinlock.h
|
||||
%{_includedir}/rados/assert.h
|
||||
%{_includedir}/rados/librgw.h
|
||||
%{_includedir}/rbd/librbd.h
|
||||
%{_includedir}/rbd/librbd.hpp
|
||||
%{_libdir}/libceph.so
|
||||
%{_libdir}/libcrush.so
|
||||
%{_libdir}/librados.so
|
||||
%{_libdir}/librgw.so
|
||||
%{_libdir}/librbd.so*
|
||||
%{_libdir}/rados-classes/libcls_rbd.so
|
||||
%{_mandir}/man8/librados-config.8*
|
||||
|
||||
%files gcephtool
|
||||
%defattr(-,root,root,-)
|
||||
@ -206,7 +213,15 @@ fi
|
||||
%{_bindir}/radosgw
|
||||
%{_bindir}/radosgw_admin
|
||||
|
||||
%files obsync
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/obsync
|
||||
%{_bindir}/boto_tool
|
||||
|
||||
%changelog
|
||||
* Tue Jul 12 2011 Josef Bacik <josef@toxicpanda.com> 0.31-1
|
||||
- Update to 0.31
|
||||
|
||||
* Tue Apr 5 2011 Josef Bacik <josef@toxicpanda.com> 0.26-2
|
||||
- Add the compile fix patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user