- fix build on s390(x) - no gperftools there
This commit is contained in:
parent
c767eafe44
commit
94d715c6db
12
ceph-0.94.1-tcmalloc.patch
Normal file
12
ceph-0.94.1-tcmalloc.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up ceph-0.94.1/src/rocksdb/configure.ac.tcmalloc ceph-0.94.1/src/rocksdb/configure.ac
|
||||||
|
--- ceph-0.94.1/src/rocksdb/configure.ac.tcmalloc 2015-06-08 14:03:27.000000000 +0200
|
||||||
|
+++ ceph-0.94.1/src/rocksdb/configure.ac 2015-06-08 14:03:41.000000000 +0200
|
||||||
|
@@ -19,7 +19,7 @@ AC_CHECK_LIB([snappy], [snappy_compress]
|
||||||
|
AC_CHECK_LIB([z], [gzread], [HAVE_LIBZ=yes], [AC_MSG_FAILURE([libz not found])])
|
||||||
|
AC_CHECK_LIB([bz2], [BZ2_bzCompressInit], [HAVE_LIBBZ2=yes], [AC_MSG_FAILURE([libbz2 not found])])
|
||||||
|
AC_CHECK_LIB([rt], [clock_gettime], [HAVE_LIBRT=yes], [AC_MSG_FAILURE([librt not found])])
|
||||||
|
-AC_CHECK_LIB([tcmalloc], [malloc], [HAVE_LIBTCMALLOC=yes],[AC_MSG_FAILURE([no tcmalloc found ])])
|
||||||
|
+AC_CHECK_LIB([tcmalloc], [malloc], [HAVE_LIBTCMALLOC=yes],[AC_MSG_RESULT([no tcmalloc found ])])
|
||||||
|
|
||||||
|
OLD_CXXFLAGS="$CXXFLAGS"
|
||||||
|
CXXFLAGS="$CXXFLAGS -std=c++11"
|
14
ceph.spec
14
ceph.spec
@ -12,7 +12,7 @@
|
|||||||
#################################################################################
|
#################################################################################
|
||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 0.94.1
|
Version: 0.94.1
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: User space components of the Ceph file system
|
Summary: User space components of the Ceph file system
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
@ -25,6 +25,9 @@ Patch0: init-ceph.in-fedora.patch
|
|||||||
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
|
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
|
||||||
Patch2: 0002-Add-support-for-PPC-arch.patch
|
Patch2: 0002-Add-support-for-PPC-arch.patch
|
||||||
Patch3: 0003-Skip-initialization-if-rtdsc-is-not-implemented.patch
|
Patch3: 0003-Skip-initialization-if-rtdsc-is-not-implemented.patch
|
||||||
|
# fix build without tcmalloc
|
||||||
|
# https://github.com/ceph/rocksdb/pull/5
|
||||||
|
Patch10: ceph-0.94.1-tcmalloc.patch
|
||||||
Requires: librbd1 = %{epoch}:%{version}-%{release}
|
Requires: librbd1 = %{epoch}:%{version}-%{release}
|
||||||
Requires: librados2 = %{epoch}:%{version}-%{release}
|
Requires: librados2 = %{epoch}:%{version}-%{release}
|
||||||
Requires: libcephfs1 = %{epoch}:%{version}-%{release}
|
Requires: libcephfs1 = %{epoch}:%{version}-%{release}
|
||||||
@ -105,8 +108,10 @@ Requires: gdisk
|
|||||||
Requires(post): chkconfig
|
Requires(post): chkconfig
|
||||||
Requires(preun):chkconfig
|
Requires(preun):chkconfig
|
||||||
Requires(preun):initscripts
|
Requires(preun):initscripts
|
||||||
|
%ifnarch s390 s390x
|
||||||
BuildRequires: gperftools-devel
|
BuildRequires: gperftools-devel
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Ceph is a massively scalable, open-source, distributed
|
Ceph is a massively scalable, open-source, distributed
|
||||||
@ -428,6 +433,7 @@ python-cephfs instead.
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
%patch10 -p1 -b .tcmalloc
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Find jni.h
|
# Find jni.h
|
||||||
@ -458,6 +464,9 @@ EXTRA_LDFLAGS="-lpthread"
|
|||||||
--with-debug \
|
--with-debug \
|
||||||
--enable-cephfs-java \
|
--enable-cephfs-java \
|
||||||
--with-librocksdb-static=check \
|
--with-librocksdb-static=check \
|
||||||
|
%ifarch s390 s390x
|
||||||
|
--without-tcmalloc \
|
||||||
|
%endif
|
||||||
$MY_CONF_OPT \
|
$MY_CONF_OPT \
|
||||||
%{?_with_ocf} \
|
%{?_with_ocf} \
|
||||||
CFLAGS="$RPM_OPT_FLAGS $EXTRA_CFLAGS" \
|
CFLAGS="$RPM_OPT_FLAGS $EXTRA_CFLAGS" \
|
||||||
@ -927,6 +936,9 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
|
|||||||
# actually build this meta package.
|
# actually build this meta package.
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 08 2015 Dan Horák <dan[at]danny.cz> - 1:0.94.1-4
|
||||||
|
- fix build on s390(x) - no gperftools there
|
||||||
|
|
||||||
* Thu May 21 2015 Boris Ranto <branto@redhat.com> - 1:0.94.1-3
|
* Thu May 21 2015 Boris Ranto <branto@redhat.com> - 1:0.94.1-3
|
||||||
- Disable lttng support (rhbz#1223319)
|
- Disable lttng support (rhbz#1223319)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user