Remove unnecessary patches
This commit is contained in:
parent
2288029bf6
commit
8efc832c79
@ -1,47 +0,0 @@
|
||||
From 2a7810f39cb113570efcde5f65e5440ff9587ae0 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Wed, 11 Nov 2015 17:08:06 +0100
|
||||
Subject: [PATCH] Disable erasure_codelib neon build
|
||||
|
||||
---
|
||||
src/erasure-code/jerasure/Makefile.am | 6 +++---
|
||||
src/erasure-code/shec/Makefile.am | 6 +++---
|
||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/erasure-code/jerasure/Makefile.am b/src/erasure-code/jerasure/Makefile.am
|
||||
index 6ffe3ed..01f5112 100644
|
||||
--- a/src/erasure-code/jerasure/Makefile.am
|
||||
+++ b/src/erasure-code/jerasure/Makefile.am
|
||||
@@ -75,9 +75,9 @@ if LINUX
|
||||
libec_jerasure_neon_la_LDFLAGS += -export-symbols-regex '.*__erasure_code_.*'
|
||||
endif
|
||||
|
||||
-if HAVE_NEON
|
||||
-erasure_codelib_LTLIBRARIES += libec_jerasure_neon.la
|
||||
-endif
|
||||
+#if HAVE_NEON
|
||||
+#erasure_codelib_LTLIBRARIES += libec_jerasure_neon.la
|
||||
+#endif
|
||||
|
||||
libec_jerasure_sse3_la_SOURCES = ${jerasure_sources}
|
||||
libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
||||
diff --git a/src/erasure-code/shec/Makefile.am b/src/erasure-code/shec/Makefile.am
|
||||
index cd93132..948979b 100644
|
||||
--- a/src/erasure-code/shec/Makefile.am
|
||||
+++ b/src/erasure-code/shec/Makefile.am
|
||||
@@ -81,9 +81,9 @@ if LINUX
|
||||
libec_shec_neon_la_LDFLAGS += -export-symbols-regex '.*__erasure_code_.*'
|
||||
endif
|
||||
|
||||
-if HAVE_NEON
|
||||
-erasure_codelib_LTLIBRARIES += libec_shec_neon.la
|
||||
-endif
|
||||
+#if HAVE_NEON
|
||||
+#erasure_codelib_LTLIBRARIES += libec_shec_neon.la
|
||||
+#endif
|
||||
|
||||
libec_shec_sse3_la_SOURCES = ${shec_sources}
|
||||
libec_shec_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
||||
--
|
||||
2.7.4
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 69e888fa5c103588ee9f23ac4cec4bfc2285eb08 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Fri, 13 Jan 2017 01:15:42 +0100
|
||||
Subject: [PATCH] hack: do not test for libxfs, assume it is present
|
||||
|
||||
---
|
||||
configure.ac | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 32e273f..050e754 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -882,7 +882,7 @@ AC_ARG_WITH([libxfs],
|
||||
[AS_HELP_STRING([--without-libxfs], [disable libxfs use by FileStore])],
|
||||
[],
|
||||
[with_libxfs=yes])
|
||||
-AS_IF([test "x$with_libxfs" != "xno"], [
|
||||
+AS_IF([test "x$with_libxfs" = "hack..."], [
|
||||
# xfs/xfs.h presence and XFS_XFLAG_EXTSIZE define
|
||||
AC_CHECK_HEADER([xfs/xfs.h], [], AC_MSG_ERROR(
|
||||
[xfs/xfs.h not found (--without-libxfs to disable)]))
|
||||
@@ -900,6 +900,7 @@ AS_IF([test "x$with_libxfs" != "xno"], [
|
||||
AC_MSG_ERROR([XFS_XFLAG_EXTSIZE not found (--without-libxfs to disable)])
|
||||
])
|
||||
])
|
||||
+AC_DEFINE([HAVE_LIBXFS], [1], [Define to 1 if you have libxfs])
|
||||
AM_CONDITIONAL(WITH_LIBXFS, [test "x$with_libxfs" != "xno"])
|
||||
|
||||
# use libzfs
|
||||
--
|
||||
2.7.4
|
||||
|
Loading…
Reference in New Issue
Block a user