Rebase to latest upstream version (0.94.4)
The rtdsc patch got merged upstream and is already present in the release
This commit is contained in:
parent
7e0cdd887f
commit
8d2c0a023a
@ -1,33 +0,0 @@
|
||||
From fdd728c0872b34d1b6f96ee5601b619748afc9e8 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Mon, 18 May 2015 20:27:56 +0200
|
||||
Subject: [PATCH] Skip initialization if rtdsc is not implemented
|
||||
|
||||
Patch by James Page. See
|
||||
|
||||
https://bugs.launchpad.net/ubuntu/+source/ceph/+bug/1432786
|
||||
|
||||
for more details.
|
||||
---
|
||||
src/common/Cycles.cc | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/common/Cycles.cc b/src/common/Cycles.cc
|
||||
index a2efcf3..a5367f7 100644
|
||||
--- a/src/common/Cycles.cc
|
||||
+++ b/src/common/Cycles.cc
|
||||
@@ -52,6 +52,11 @@ void Cycles::init()
|
||||
if (cycles_per_sec != 0)
|
||||
return;
|
||||
|
||||
+
|
||||
+ // Skip initialization if rtdsc is not implemented
|
||||
+ if (rdtsc() == 0)
|
||||
+ return;
|
||||
+
|
||||
// Compute the frequency of the fine-grained CPU timer: to do this,
|
||||
// take parallel time readings using both rdtsc and gettimeofday.
|
||||
// After 10ms have elapsed, take the ratio between these readings.
|
||||
--
|
||||
2.1.0
|
||||
|
10
ceph.spec
10
ceph.spec
@ -11,8 +11,8 @@
|
||||
# common
|
||||
#################################################################################
|
||||
Name: ceph
|
||||
Version: 0.94.3
|
||||
Release: 2%{?dist}
|
||||
Version: 0.94.4
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
Summary: User space components of the Ceph file system
|
||||
License: GPLv2
|
||||
@ -23,7 +23,6 @@ Source0: http://ceph.com/download/%{name}-%{version}.tar.bz2
|
||||
Patch0: init-ceph.in-fedora.patch
|
||||
%endif
|
||||
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
|
||||
Patch3: 0003-Skip-initialization-if-rtdsc-is-not-implemented.patch
|
||||
# fix build without tcmalloc
|
||||
# https://github.com/ceph/rocksdb/pull/5
|
||||
Patch10: ceph-0.94.1-tcmalloc.patch
|
||||
@ -430,7 +429,6 @@ python-cephfs instead.
|
||||
%patch0 -p1 -b .init
|
||||
%endif
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
%patch10 -p1 -b .tcmalloc
|
||||
|
||||
%build
|
||||
@ -935,6 +933,10 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
|
||||
# actually build this meta package.
|
||||
|
||||
%changelog
|
||||
* Tue Oct 20 2015 Boris Ranto <branto@redhat.com> - 1:0.94.4-1
|
||||
- Rebase to latest upstream version
|
||||
- The rtdsc patch got merged upstream and is already present in the release
|
||||
|
||||
* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 1:0.94.3-2
|
||||
- Rebuilt for Boost 1.59
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user