- update to 0.61.7
This commit is contained in:
parent
6bb58e5016
commit
7d1f840a1f
@ -1,41 +0,0 @@
|
||||
From d02340d90c9d30d44c962bea7171db3fe3bfba8e Mon Sep 17 00:00:00 2001
|
||||
From: Alexandre Oliva <oliva@gnu.org>
|
||||
Date: Wed, 6 Feb 2013 15:27:13 -0200
|
||||
Subject: [PATCH] silence logrotate some more
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
I was getting email with logrotate error output from “which invoke-rc.d”
|
||||
on systems without an invoke-rc.d. This patch silences it.
|
||||
|
||||
Silence stderr from which when running logrotate
|
||||
|
||||
From: Alexandre Oliva <oliva@gnu.org>
|
||||
|
||||
Signed-off-by: Alexandre Oliva <oliva@gnu.org>
|
||||
---
|
||||
src/logrotate.conf | 6 +++---
|
||||
1 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/logrotate.conf b/src/logrotate.conf
|
||||
index 62101b3..e49285a 100644
|
||||
--- a/src/logrotate.conf
|
||||
+++ b/src/logrotate.conf
|
||||
@@ -4,13 +4,13 @@
|
||||
compress
|
||||
sharedscripts
|
||||
postrotate
|
||||
- if which invoke-rc.d > /dev/null && [ -x `which invoke-rc.d` ]; then
|
||||
+ if which invoke-rc.d > /dev/null 2>&1 && [ -x `which invoke-rc.d` ]; then
|
||||
invoke-rc.d ceph reload >/dev/null
|
||||
- elif which service > /dev/null && [ -x `which service` ]; then
|
||||
+ elif which service > /dev/null 2>&1 && [ -x `which service` ]; then
|
||||
service ceph reload >/dev/null
|
||||
fi
|
||||
# Possibly reload twice, but depending on ceph.conf the reload above may be a no-op
|
||||
- if which initctl > /dev/null && [ -x `which initctl` ]; then
|
||||
+ if which initctl > /dev/null 2>&1 && [ -x `which initctl` ]; then
|
||||
# upstart reload isn't very helpful here:
|
||||
# https://bugs.launchpad.net/upstart/+bug/1012938
|
||||
for type in mon osd mds; do
|
12
ceph-fix-sbin-target.patch
Normal file
12
ceph-fix-sbin-target.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up ceph-0.61.7/src/Makefile.am.fix-sbin ceph-0.61.7/src/Makefile.am
|
||||
--- ceph-0.61.7/src/Makefile.am.fix-sbin 2013-07-26 11:52:56.355915758 -0400
|
||||
+++ ceph-0.61.7/src/Makefile.am 2013-07-26 11:53:09.502808374 -0400
|
||||
@@ -28,7 +28,7 @@ bin_PROGRAMS =
|
||||
bin_DEBUGPROGRAMS =
|
||||
sbin_PROGRAMS =
|
||||
# like sbin_SCRIPTS but can be used to install to e.g. /usr/sbin
|
||||
-ceph_sbindir = $(prefix)$(sbindir)
|
||||
+ceph_sbindir = $(sbindir)
|
||||
ceph_sbin_SCRIPTS = \
|
||||
ceph-disk \
|
||||
ceph-disk-prepare \
|
27
ceph.spec
27
ceph.spec
@ -1,6 +1,6 @@
|
||||
Name: ceph
|
||||
Version: 0.56.4
|
||||
Release: 2%{?dist}
|
||||
Version: 0.61.7
|
||||
Release: 1%{?dist}
|
||||
Summary: User space components of the Ceph file system
|
||||
License: LGPLv2
|
||||
Group: System Environment/Base
|
||||
@ -9,7 +9,7 @@ URL: http://ceph.com/
|
||||
Source: http://ceph.com/download/%{name}-%{version}.tar.bz2
|
||||
Patch0: ceph-init-fix.patch
|
||||
Patch1: ceph-build-support-for-automake-1.12.patch
|
||||
Patch2: 0001-silence-logrotate-some-more.patch
|
||||
Patch2: ceph-fix-sbin-target.patch
|
||||
|
||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
|
||||
@ -90,8 +90,8 @@ EXTRA_CFLAGS="-DAO_USE_PTHREAD_DEFS"
|
||||
EXTRA_LDFLAGS="-lpthread"
|
||||
%endif
|
||||
|
||||
%{configure} --prefix=/usr --sbindir=%{_sbindir} \
|
||||
--localstatedir=/var --sysconfdir=/etc \
|
||||
%{configure} --prefix=%{_prefix} --sbindir=%{_sbindir} \
|
||||
--localstatedir=%{_localstatedir} --sysconfdir=%{_sysconfdir} \
|
||||
%ifarch ppc ppc64 s390 s390x
|
||||
--without-tcmalloc \
|
||||
%endif
|
||||
@ -138,6 +138,7 @@ fi
|
||||
%defattr(-,root,root,-)
|
||||
%doc README COPYING
|
||||
%dir %{_sysconfdir}/ceph
|
||||
%dir %{_docdir}/ceph
|
||||
%{_bindir}/ceph
|
||||
%{_bindir}/cephfs
|
||||
%{_bindir}/ceph-conf
|
||||
@ -158,15 +159,17 @@ fi
|
||||
%{_bindir}/ceph-debugpack
|
||||
%{_bindir}/ceph-coverage
|
||||
%{_bindir}/ceph-dencoder
|
||||
%{_bindir}/ceph_filestore_dump
|
||||
%{_bindir}/ceph_mon_store_converter
|
||||
%{_initrddir}/ceph
|
||||
%{_sbindir}/mkcephfs
|
||||
%{_sbindir}/mount.ceph
|
||||
%{_sbindir}/ceph-disk-activate
|
||||
%{_sbindir}/ceph-disk-prepare
|
||||
%{_sbindir}/ceph-create-keys
|
||||
%{_sbindir}/ceph-disk
|
||||
%{_sbindir}/ceph-disk-udev
|
||||
%{_libdir}/ceph
|
||||
%{_docdir}/ceph/sample.ceph.conf
|
||||
%{_docdir}/ceph/sample.fetch_config
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/ceph
|
||||
%config(noreplace) %{_sysconfdir}/bash_completion.d/rados
|
||||
%config(noreplace) %{_sysconfdir}/bash_completion.d/ceph
|
||||
@ -195,6 +198,7 @@ fi
|
||||
%{_mandir}/man8/ceph-rbdnamer.8*
|
||||
%{python_sitelib}/rados.py*
|
||||
%{python_sitelib}/rbd.py*
|
||||
%{python_sitelib}/cephfs.py*
|
||||
%dir %{_localstatedir}/lib/ceph/
|
||||
%dir %{_localstatedir}/lib/ceph/tmp/
|
||||
%dir %{_localstatedir}/log/ceph/
|
||||
@ -219,8 +223,10 @@ fi
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_bindir}/ceph-fuse
|
||||
%{_bindir}/rbd-fuse
|
||||
%{_sbindir}/mount.fuse.ceph
|
||||
%{_mandir}/man8/ceph-fuse.8*
|
||||
%{_mandir}/man8/rbd-fuse.8*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -232,6 +238,8 @@ fi
|
||||
#%{_includedir}/crush/types.h
|
||||
%{_includedir}/rados/librados.h
|
||||
%{_includedir}/rados/librados.hpp
|
||||
%{_includedir}/rados/rados_types.h
|
||||
%{_includedir}/rados/rados_types.hpp
|
||||
%{_includedir}/rados/buffer.h
|
||||
%{_includedir}/rados/page.h
|
||||
%{_includedir}/rados/crc32c.h
|
||||
@ -254,6 +262,9 @@ fi
|
||||
%{_sysconfdir}/bash_completion.d/radosgw-admin
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2013 Josef Bacik <josef@toxicpanda.com> - 0.61.7-1
|
||||
- Update to 0.61.7
|
||||
|
||||
* Sat Jul 27 2013 pmachata@redhat.com - 0.56.4-2
|
||||
- Rebuild for boost 1.54.0
|
||||
|
||||
@ -382,7 +393,7 @@ fi
|
||||
- Include rbdtool
|
||||
- Remove misc debugging, test binaries
|
||||
|
||||
* Thu Apr 30 2010 Josef Bacik <josef@toxicpanda.com> 0.19.1-4
|
||||
* Fri Apr 30 2010 Josef Bacik <josef@toxicpanda.com> 0.19.1-4
|
||||
- Add java-devel and java tricks to get hadoop to build
|
||||
|
||||
* Mon Apr 26 2010 Josef Bacik <josef@toxicpanda.com> 0.19.1-3
|
||||
|
Loading…
Reference in New Issue
Block a user