Rebase to v14.1.0
- contains updates for fixes in upstream nautilus branch
This commit is contained in:
parent
621cf4d6f7
commit
6ad252c21d
@ -1,66 +0,0 @@
|
||||
From 7b6d91fb78be31c9a95b10ad01765eb627784119 Mon Sep 17 00:00:00 2001
|
||||
From: Boris Ranto <branto@redhat.com>
|
||||
Date: Tue, 27 Nov 2018 00:30:26 +0100
|
||||
Subject: [PATCH 1/4] f30 python3 execs
|
||||
|
||||
---
|
||||
src/ceph-create-keys | 2 +-
|
||||
src/ceph-volume/bin/ceph-volume | 2 +-
|
||||
src/ceph-volume/bin/ceph-volume-systemd | 2 +-
|
||||
src/ceph.in | 2 +-
|
||||
src/mount.fuse.ceph | 2 +-
|
||||
7 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/ceph-create-keys b/src/ceph-create-keys
|
||||
index c14c02f28d..7e80aab6a2 100755
|
||||
--- a/src/ceph-create-keys
|
||||
+++ b/src/ceph-create-keys
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
import argparse
|
||||
import errno
|
||||
import json
|
||||
diff --git a/src/ceph-volume/bin/ceph-volume b/src/ceph-volume/bin/ceph-volume
|
||||
index 5905cfccc0..a4f62b4a1f 100755
|
||||
--- a/src/ceph-volume/bin/ceph-volume
|
||||
+++ b/src/ceph-volume/bin/ceph-volume
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from ceph_volume import main
|
||||
|
||||
diff --git a/src/ceph-volume/bin/ceph-volume-systemd b/src/ceph-volume/bin/ceph-volume-systemd
|
||||
index 7da8ec6b1c..f6c751cf44 100755
|
||||
--- a/src/ceph-volume/bin/ceph-volume-systemd
|
||||
+++ b/src/ceph-volume/bin/ceph-volume-systemd
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from ceph_volume.systemd import main
|
||||
|
||||
diff --git a/src/ceph.in b/src/ceph.in
|
||||
index c37ce6d846..c54f9a7006 100755
|
||||
--- a/src/ceph.in
|
||||
+++ b/src/ceph.in
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!@PYTHON_EXECUTABLE@
|
||||
+#!@PYTHON3_EXECUTABLE@
|
||||
# -*- mode:python -*-
|
||||
# vim: ts=4 sw=4 smarttab expandtab
|
||||
#
|
||||
diff --git a/src/mount.fuse.ceph b/src/mount.fuse.ceph
|
||||
index 87349a0ab0..c61625a8c2 100755
|
||||
--- a/src/mount.fuse.ceph
|
||||
+++ b/src/mount.fuse.ceph
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
'''
|
||||
Helper to mount ceph-fuse from /etc/fstab. To use, add an entry
|
||||
like:
|
||||
--
|
||||
2.19.1
|
||||
|
@ -1,53 +0,0 @@
|
||||
--- ceph-14.0.1/src/dpdk/mk/toolchain/gcc/rte.vars.mk.orig 2019-02-05 16:28:09.211608099 -0500
|
||||
+++ ceph-14.0.1/src/dpdk/mk/toolchain/gcc/rte.vars.mk 2019-02-05 18:10:00.237608099 -0500
|
||||
@@ -75,7 +75,7 @@
|
||||
WERROR_FLAGS += -Wmissing-declarations -Wold-style-definition -Wpointer-arith
|
||||
WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
|
||||
WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
|
||||
-WERROR_FLAGS += -Wundef -Wwrite-strings
|
||||
+WERROR_FLAGS += -Wundef -Wwrite-strings -Wno-address-of-packed-member
|
||||
|
||||
ifeq ($(RTE_DEVEL_BUILD),y)
|
||||
WERROR_FLAGS += -Werror
|
||||
@@ -99,5 +99,6 @@
|
||||
WERROR_FLAGS += -Wno-uninitialized
|
||||
endif
|
||||
|
||||
+
|
||||
export CC AS AR LD OBJCOPY OBJDUMP STRIP READELF
|
||||
export TOOLCHAIN_CFLAGS TOOLCHAIN_LDFLAGS TOOLCHAIN_ASFLAGS
|
||||
--- ceph-14.0.1/src/spdk/dpdk/mk/toolchain/gcc/rte.vars.mk.orig 2019-02-05 18:28:01.999608099 -0500
|
||||
+++ ceph-14.0.1/src/spdk/dpdk/mk/toolchain/gcc/rte.vars.mk 2019-02-05 18:29:08.664608099 -0500
|
||||
@@ -47,7 +47,7 @@
|
||||
WERROR_FLAGS += -Wmissing-declarations -Wold-style-definition -Wpointer-arith
|
||||
WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
|
||||
WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
|
||||
-WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated
|
||||
+WERROR_FLAGS += -Wundef -Wwrite-strings -Wno-address-of-packed-member -Wdeprecated
|
||||
|
||||
ifeq ($(RTE_DEVEL_BUILD),y)
|
||||
WERROR_FLAGS += -Werror
|
||||
--- ceph-14.0.1/src/common/config.cc.orig 2019-02-06 09:08:43.078608099 -0500
|
||||
+++ ceph-14.0.1/src/common/config.cc 2019-02-06 12:10:13.484608099 -0500
|
||||
@@ -1340,6 +1340,8 @@
|
||||
template<typename Size>
|
||||
struct get_size_visitor : public boost::static_visitor<Size>
|
||||
{
|
||||
+ get_size_visitor() {}
|
||||
+
|
||||
template<typename T>
|
||||
Size operator()(const T&) const {
|
||||
return -1;
|
||||
--- ceph-14.0.1/src/dmclock/src/dmclock_server.h.orig 2019-02-07 07:10:17.778608099 -0500
|
||||
+++ ceph-14.0.1/src/dmclock/src/dmclock_server.h 2019-02-07 07:29:47.868608099 -0500
|
||||
@@ -829,8 +829,8 @@
|
||||
AtLimitParam at_limit_param,
|
||||
double _anticipation_timeout) :
|
||||
client_info_f(_client_info_f),
|
||||
- at_limit(get_or_default<AtLimit>(at_limit_param, AtLimit::Reject)),
|
||||
- reject_threshold(get_or_default<RejectThreshold>(at_limit_param, 0)),
|
||||
+ at_limit(get_or_default(at_limit_param, AtLimit::Reject)),
|
||||
+ reject_threshold(get_or_default(at_limit_param, RejectThreshold{0})),
|
||||
anticipation_timeout(_anticipation_timeout),
|
||||
finishing(false),
|
||||
idle_age(std::chrono::duration_cast<Duration>(_idle_age)),
|
@ -1,13 +0,0 @@
|
||||
diff -ur ceph-14.0.1/src/civetweb/src/civetweb.c ceph-14.0.1.mod/src/civetweb/src/civetweb.c
|
||||
--- ceph-14.0.1/src/civetweb/src/civetweb.c 2018-06-20 15:53:52.000000000 +0200
|
||||
+++ ceph-14.0.1.mod/src/civetweb/src/civetweb.c 2019-02-21 08:28:09.797504543 +0100
|
||||
@@ -16268,6 +16268,9 @@
|
||||
conn->request_info.client_cert = 0;
|
||||
}
|
||||
}
|
||||
+ else {
|
||||
+ close_connection(conn);
|
||||
+ }
|
||||
#endif
|
||||
} else {
|
||||
/* process HTTP connection */
|
14
ceph.spec
14
ceph.spec
@ -95,8 +95,8 @@
|
||||
# main package definition
|
||||
#################################################################################
|
||||
Name: ceph
|
||||
Version: 14.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 14.1.0
|
||||
Release: 1%{?dist}
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
Epoch: 1
|
||||
%endif
|
||||
@ -110,10 +110,7 @@ License: LGPL-2.1 and CC-BY-SA-3.0 and GPL-2.0 and BSL-1.0 and BSD-3-Clause and
|
||||
%if 0%{?suse_version}
|
||||
%endif
|
||||
URL: http://ceph.com/
|
||||
Source0: %{?_remote_tarball_prefix}ceph-14.0.1.tar.bz2
|
||||
Patch001: 0001-f30-python3-execs.patch
|
||||
Patch002: 0002-f30-gcc9.patch
|
||||
Patch003: 0003-cve-2019-3821.patch
|
||||
Source0: %{?_remote_tarball_prefix}ceph-%{version}.tar.bz2
|
||||
ExcludeArch: i686 armv7hl
|
||||
#################################################################################
|
||||
# dependencies that apply across all distro families
|
||||
@ -868,7 +865,7 @@ python-rbd, python-rgw or python-cephfs instead.
|
||||
# common
|
||||
#################################################################################
|
||||
%prep
|
||||
%autosetup -p1 -n ceph-14.0.1
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -1887,6 +1884,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 27 2019 Boris Ranto <branto@redhat.com> - 1:14.1.0-1
|
||||
- Rebase to v14.1.0 (updated for fixes in upstream nautilus branch)
|
||||
|
||||
* Thu Feb 21 2019 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 1:14.0.1-2
|
||||
- Eliminate redundant CMAKE_* macros when using %%cmake global
|
||||
- Add CMAKE_BUILD_TYPE=RelWithDeb(ug)Info and BUILD_CONFIG=rpmbuild
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ceph-14.0.1.tar.bz2) = a949ea3cbd6ee0cae1cf60193b3e8de80b7af43155869f8f504e2aeedc7ee2db5d484013572b28d5ae1a0a0b7b619ee912f536a0015f4c9d18ea2a8705f9150a
|
||||
SHA512 (ceph-14.1.0.tar.bz2) = 6d24cd24092a75ef8b2bc14543f3eca33528467af39322f4ae9169b28fccf2b1840caeec7998cf305ac0e9dc52e8fd68b8c6a90baf0b9da6a1d37e4f10a412eb
|
||||
|
Loading…
Reference in New Issue
Block a user