updating to 0.51
This commit is contained in:
parent
19726c103f
commit
6449f95424
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@ ceph-0.20.tar.gz
|
||||
/ceph-0.44.tar.bz2
|
||||
/ceph-0.45.tar.bz2
|
||||
/ceph-0.46.tar.bz2
|
||||
/ceph-0.51.tar.bz2
|
||||
|
@ -1,52 +0,0 @@
|
||||
From d3bcac241f25f681a585c2115a79befe43dd7d6c Mon Sep 17 00:00:00 2001
|
||||
From: Jim Schutt <jaschut@sandia.gov>
|
||||
Date: Wed, 21 Mar 2012 10:09:09 -0600
|
||||
Subject: [PATCH] Makefile: fix modules that cannot find pk11pub.h when
|
||||
compiling with NSS on RHEL6
|
||||
|
||||
Signed-off-by: Jim Schutt <jaschut@sandia.gov>
|
||||
Signed-off-by: Sage Weil <sage.weil@dreamhost.com>
|
||||
---
|
||||
src/Makefile.am | 5 ++++-
|
||||
1 files changed, 4 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index a6e6a95..80802bc 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -48,7 +48,7 @@ if LINUX
|
||||
ceph_osd_LDADD += -ldl
|
||||
endif
|
||||
bin_PROGRAMS += ceph-osd
|
||||
-ceph_osd_CXXFLAGS = ${AM_CXXFLAGS} \
|
||||
+ceph_osd_CXXFLAGS = ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS} \
|
||||
-I$(top_srcdir)/src/leveldb/include
|
||||
|
||||
# mds
|
||||
@@ -111,6 +111,7 @@ osdmaptool_LDADD = $(LIBGLOBAL_LDA)
|
||||
bin_PROGRAMS += monmaptool crushtool osdmaptool
|
||||
|
||||
ceph_dencoder_SOURCES = test/encoding/ceph_dencoder.cc
|
||||
+ceph_dencoder_CXXFLAGS = ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS}
|
||||
ceph_dencoder_LDADD = $(LIBGLOBAL_LDA) libosd.la libmds.a libos.la libmon.la
|
||||
bin_PROGRAMS += ceph-dencoder
|
||||
|
||||
@@ -1002,6 +1003,7 @@ libmon_la_SOURCES = \
|
||||
mon/AuthMonitor.cc \
|
||||
mon/Elector.cc \
|
||||
mon/MonitorStore.cc
|
||||
+libmon_la_CXXFLAGS= ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS}
|
||||
libmon_la_LIBADD = libglobal.la
|
||||
noinst_LTLIBRARIES += libmon.la
|
||||
|
||||
@@ -1070,6 +1072,7 @@ libosdc_la_SOURCES = \
|
||||
osdc/ObjectCacher.cc \
|
||||
osdc/Filer.cc \
|
||||
osdc/Journaler.cc
|
||||
+libosdc_la_CXXFLAGS= ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS}
|
||||
libosdc_la_LIBADD = libcommon.la
|
||||
noinst_LTLIBRARIES += libosdc.la
|
||||
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -1,51 +0,0 @@
|
||||
diff -up ceph-0.45/src/leveldb/configure.ac.atomic ceph-0.45/src/leveldb/configure.ac
|
||||
--- ceph-0.45/src/leveldb/configure.ac.atomic 2012-04-23 18:56:15.000000000 +0200
|
||||
+++ ceph-0.45/src/leveldb/configure.ac 2012-04-23 19:33:27.000000000 +0200
|
||||
@@ -10,11 +10,11 @@ AC_CONFIG_FILES([
|
||||
])
|
||||
AC_PROG_RANLIB
|
||||
|
||||
-AC_MSG_CHECKING(whether compiler supports C++11 cstdatomic)
|
||||
+AC_MSG_CHECKING(whether compiler supports C++11 atomic)
|
||||
OLD_CXXFLAGS="$CXXFLAGS"
|
||||
CXXFLAGS="$CXXFLAGS -std=c++0x"
|
||||
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
-#include <cstdatomic>
|
||||
+#include <atomic>
|
||||
int main() {}
|
||||
])], [
|
||||
AC_MSG_RESULT(yes)
|
||||
diff -up ceph-0.45/src/leveldb/configure.atomic ceph-0.45/src/leveldb/configure
|
||||
--- ceph-0.45/src/leveldb/configure.atomic 2012-04-23 18:56:19.000000000 +0200
|
||||
+++ ceph-0.45/src/leveldb/configure 2012-04-23 18:56:43.000000000 +0200
|
||||
@@ -3885,15 +3885,15 @@ else
|
||||
fi
|
||||
|
||||
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports C++11 cstdatomic" >&5
|
||||
-$as_echo_n "checking whether compiler supports C++11 cstdatomic... " >&6; }
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports C++11 atomic" >&5
|
||||
+$as_echo_n "checking whether compiler supports C++11 atomic... " >&6; }
|
||||
OLD_CXXFLAGS="$CXXFLAGS"
|
||||
CXXFLAGS="$CXXFLAGS -std=c++0x"
|
||||
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
|
||||
-#include <cstdatomic>
|
||||
+#include <atomic>
|
||||
int main() {}
|
||||
|
||||
_ACEOF
|
||||
diff -up ceph-0.45/src/leveldb/port/atomic_pointer.h.atomic ceph-0.45/src/leveldb/port/atomic_pointer.h
|
||||
--- ceph-0.45/src/leveldb/port/atomic_pointer.h.atomic 2012-04-23 18:56:54.000000000 +0200
|
||||
+++ ceph-0.45/src/leveldb/port/atomic_pointer.h 2012-04-23 18:57:00.000000000 +0200
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include <stdint.h>
|
||||
#ifdef LEVELDB_CSTDATOMIC_PRESENT
|
||||
-#include <cstdatomic>
|
||||
+#include <atomic>
|
||||
#endif
|
||||
#ifdef OS_WIN
|
||||
#include <windows.h>
|
@ -1,11 +1,11 @@
|
||||
--- ./src/logrotate.conf.new 2012-01-11 18:23:10.597593501 -0500
|
||||
+++ ./src/logrotate.conf 2012-01-11 18:23:26.808390838 -0500
|
||||
--- src/logrotate.conf 2012-07-03 00:22:59.000000000 -0400
|
||||
+++ src/logrotate.conf.new 2012-09-09 12:56:09.912929358 -0400
|
||||
@@ -4,7 +4,7 @@
|
||||
compress
|
||||
sharedscripts
|
||||
postrotate
|
||||
- invoke-rc.d ceph reload >/dev/null || service ceph reload >/dev/null
|
||||
+ service ceph reload >/dev/null 2>/dev/null || true
|
||||
endscript
|
||||
missingok
|
||||
}
|
||||
|
||||
# upstart reload isn't very helpful here:
|
||||
# https://bugs.launchpad.net/upstart/+bug/1012938
|
||||
|
45
ceph.spec
45
ceph.spec
@ -1,16 +1,14 @@
|
||||
Name: ceph
|
||||
Version: 0.46
|
||||
Release: 2%{?dist}
|
||||
Version: 0.51
|
||||
Release: 1%{?dist}
|
||||
Summary: User space components of the Ceph file system
|
||||
License: LGPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://ceph.newdream.net/
|
||||
URL: http://ceph.com/
|
||||
|
||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
|
||||
Source: http://ceph.com/download/%{name}-%{version}.tar.bz2
|
||||
Patch0: ceph-init-fix.patch
|
||||
Patch1: ceph.logrotate.patch
|
||||
# http://tracker.newdream.net/issues/2329
|
||||
Patch2: ceph-gxx-atomic.patch
|
||||
|
||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
|
||||
@ -82,22 +80,11 @@ obsync is a tool to synchronize objects between cloud object
|
||||
storage providers, such as Amazon S3 (or compatible services), a
|
||||
Ceph RADOS cluster, or a local directory.
|
||||
|
||||
%package gcephtool
|
||||
Summary: Ceph graphical monitoring tool
|
||||
Group: System Environment/Base
|
||||
License: LGPLv2
|
||||
Requires: gtk2 gtkmm24
|
||||
BuildRequires: gtk2-devel gtkmm24-devel
|
||||
|
||||
%description gcephtool
|
||||
gcephtool is a graphical monitor for the clusters running the Ceph distributed
|
||||
file system.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .init
|
||||
%patch1 -p0
|
||||
%patch2 -p1 -b .atomic
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -182,6 +169,8 @@ fi
|
||||
%{_initrddir}/ceph
|
||||
/sbin/mkcephfs
|
||||
/sbin/mount.ceph
|
||||
/sbin/ceph-disk-activate
|
||||
/sbin/ceph-disk-prepare
|
||||
%{_libdir}/ceph
|
||||
%{_docdir}/ceph/sample.ceph.conf
|
||||
%{_docdir}/ceph/sample.fetch_config
|
||||
@ -223,9 +212,9 @@ fi
|
||||
%doc COPYING
|
||||
%{_libdir}/librados.so.*
|
||||
%{_libdir}/librbd.so.*
|
||||
%{_libdir}/librgw.so.*
|
||||
%{_libdir}/rados-classes/libcls_rbd.so.*
|
||||
%{_libdir}/rados-classes/libcls_rgw.so*
|
||||
%{_libdir}/rados-classes/libcls_lock*
|
||||
|
||||
%files libcephfs
|
||||
%defattr(-,root,root,-)
|
||||
@ -242,29 +231,25 @@ fi
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_includedir}/cephfs/libcephfs.h
|
||||
%{_includedir}/crush/crush.h
|
||||
%{_includedir}/crush/hash.h
|
||||
%{_includedir}/crush/mapper.h
|
||||
%{_includedir}/crush/types.h
|
||||
#%{_includedir}/crush/crush.h
|
||||
#%{_includedir}/crush/hash.h
|
||||
#%{_includedir}/crush/mapper.h
|
||||
#%{_includedir}/crush/types.h
|
||||
%{_includedir}/rados/librados.h
|
||||
%{_includedir}/rados/librados.hpp
|
||||
%{_includedir}/rados/buffer.h
|
||||
%{_includedir}/rados/page.h
|
||||
%{_includedir}/rados/crc32c.h
|
||||
%{_includedir}/rados/librgw.h
|
||||
#%{_includedir}/rados/librgw.h
|
||||
%{_includedir}/rbd/librbd.h
|
||||
%{_includedir}/rbd/librbd.hpp
|
||||
%{_libdir}/libcephfs.so
|
||||
%{_libdir}/librados.so
|
||||
%{_libdir}/librgw.so
|
||||
#%{_libdir}/librgw.so
|
||||
%{_libdir}/librbd.so*
|
||||
%{_libdir}/rados-classes/libcls_rbd.so
|
||||
%{_mandir}/man8/librados-config.8*
|
||||
|
||||
%files gcephtool
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/gceph
|
||||
%{_datadir}/ceph_tool/gui_resources/*
|
||||
|
||||
%files radosgw
|
||||
%defattr(-,root,root,-)
|
||||
@ -278,6 +263,10 @@ fi
|
||||
%{_bindir}/boto_tool
|
||||
|
||||
%changelog
|
||||
* Fri Sep 07 2012 David Nalley <david@gnsa.us> - 0.51-1
|
||||
- Updating to 0.51
|
||||
- Updated url and source url.
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.46-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user